summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2019-01-04 15:13:02 -0600
committerJohn Klug <john.klug@multitech.com>2019-07-03 11:22:01 -0500
commit75e93f426d1c79d392f4c88e4aa10b4915433641 (patch)
treec56448e91c54dad9eb9f5704f8cab05f551623ae
parentc31d878b30d082c999ef4f74c8ca91c3ac9b98f1 (diff)
downloadmeta-multitech-75e93f426d1c79d392f4c88e4aa10b4915433641.tar.gz
meta-multitech-75e93f426d1c79d392f4c88e4aa10b4915433641.tar.bz2
meta-multitech-75e93f426d1c79d392f4c88e4aa10b4915433641.zip
Simplify package updates with OPKG
-rw-r--r--recipes-kernel/linux/linux-at91_4.9.87.bb8
1 files changed, 2 insertions, 6 deletions
diff --git a/recipes-kernel/linux/linux-at91_4.9.87.bb b/recipes-kernel/linux/linux-at91_4.9.87.bb
index 60685f0..8b55f61 100644
--- a/recipes-kernel/linux/linux-at91_4.9.87.bb
+++ b/recipes-kernel/linux/linux-at91_4.9.87.bb
@@ -99,11 +99,7 @@ pkg_prerm_kernel-image-uimage() {
PACKAGES =+ "kernel-image-uimage-inst kernel-dt-bindings-dev"
# Not sure how to get the name below generated automatically
-#KERNELVERSION = "4.9.87-linux4sam-5.8-dirty"
-KERNELVERSION = "${PV}"
-#KERNELVERSION2 = "4.9.87-linux4sam_5.8-dirty"
-KERNELVERSION2 = "${PV}"
-RDEPENDS_kernel-image-uimage-inst += "kernel-image-uimage-${KERNELVERSION}"
+RDEPENDS_kernel-image-uimage-inst += "kernel-image-uimage-${PV}"
ALLOW_EMPTY_kernel-image-uimage-inst = "1"
pkg_postinst_kernel-image-uimage-inst() {
@@ -113,7 +109,7 @@ pkg_postinst_kernel-image-uimage-inst() {
set -x
kernel_mtd="/dev/$(cat /proc/mtd | grep '\"uImage\"' | cut -d : -f 1)"
flash_erase ${kernel_mtd} 0 0
- if nandwrite -p ${kernel_mtd} /boot/uImage-${KERNELVERSION2} ; then
+ if nandwrite -p ${kernel_mtd} /boot/uImage-${PV} ; then
echo 'Kernel image update is successful'
fi
set +x