summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Hatch <jhatch@multitech.com>2022-05-24 12:33:42 -0500
committerJeff Hatch <jhatch@multitech.com>2022-05-24 12:33:42 -0500
commit62983121a825fb807ab3783aec9a1f1990251798 (patch)
tree465e56bad85f7e4d798fd2030b1ba54ca8c25fd1
parentcec6945d9087a9b66c5107c66f1029eca3f62364 (diff)
parentfc393dbed7b562c3dd761d94575138b278ff99c6 (diff)
downloadmeta-multitech-62983121a825fb807ab3783aec9a1f1990251798.tar.gz
meta-multitech-62983121a825fb807ab3783aec9a1f1990251798.tar.bz2
meta-multitech-62983121a825fb807ab3783aec9a1f1990251798.zip
Merge branch 'mpower-dev-nxp' into 6
-rw-r--r--recipes-bsp/multitech/mts-id-eeprom.inc4
-rw-r--r--recipes-bsp/multitech/mts-id-eeprom_0.6.5.bb (renamed from recipes-bsp/multitech/mts-id-eeprom_0.6.3.bb)2
-rw-r--r--recipes-bsp/multitech/mts-io-sysfs_0.2.5.bb (renamed from recipes-bsp/multitech/mts-io-sysfs_0.2.4.bb)4
-rw-r--r--recipes-bsp/multitech/mts-io.inc16
-rw-r--r--recipes-bsp/multitech/mts-io_4.9.5.bb (renamed from recipes-bsp/multitech/mts-io_4.9.2.bb)0
5 files changed, 18 insertions, 8 deletions
diff --git a/recipes-bsp/multitech/mts-id-eeprom.inc b/recipes-bsp/multitech/mts-id-eeprom.inc
index 13f2b05..7e1df05 100644
--- a/recipes-bsp/multitech/mts-id-eeprom.inc
+++ b/recipes-bsp/multitech/mts-id-eeprom.inc
@@ -4,7 +4,7 @@ SECTION = "console/utils"
PRIORITY = "optional"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-INC_PR = "r7"
+INC_PR = "r0"
DEPENDS = "mts-io openssl"
DEPENDS_append_mtcdt3 = " mtcdt3b"
DEPENDS_append_mtcdt3hs = " mtcdt3b"
@@ -26,7 +26,7 @@ TARGET_CFLAGS_append_mtre = " -D MTRE"
SRCREV = "${PV}"
FILESEXTRAPATHS_prepend_mtcpmhs := "${THISDIR}/mts-id-eeprom/mtcdt:"
-SRC_URI = "git://git.multitech.net/mts-id-eeprom;protocol=git"
+SRC_URI = "git://git@gitlab.multitech.net/mirrors/mts-id-eeprom;protocol=ssh;branch=master"
SRC_URI_append_mtcdt = " file://mtcdt-fpga-v31.hex file://mtcdt-fpga-v35.hex"
SRC_URI_append_mtcpmhs = " file://mtcdt-fpga-v31.hex file://mtcdt-fpga-v35.hex"
SRC_URI_append_mtcap = " file://mtcap-fpga-v31.hex file://mtcap-fpga-v35.hex"
diff --git a/recipes-bsp/multitech/mts-id-eeprom_0.6.3.bb b/recipes-bsp/multitech/mts-id-eeprom_0.6.5.bb
index 12c32c4..ccf3521 100644
--- a/recipes-bsp/multitech/mts-id-eeprom_0.6.3.bb
+++ b/recipes-bsp/multitech/mts-id-eeprom_0.6.5.bb
@@ -1,3 +1,3 @@
require mts-id-eeprom.inc
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.0"
diff --git a/recipes-bsp/multitech/mts-io-sysfs_0.2.4.bb b/recipes-bsp/multitech/mts-io-sysfs_0.2.5.bb
index a489468..3b8bf7f 100644
--- a/recipes-bsp/multitech/mts-io-sysfs_0.2.4.bb
+++ b/recipes-bsp/multitech/mts-io-sysfs_0.2.5.bb
@@ -8,11 +8,11 @@ inherit update-rc.d
DEPENDS = "libmts openssl"
RDEPENDS_${PN} = "bash"
-PR = "r1"
+PR = "r0"
SRCREV = "${PV}"
-SRC_URI = "git://git.multitech.net/mts-io-sysfs.git;protocol=git;branch=master \
+SRC_URI = "git://git@gitlab.multitech.net/mirrors/mts-io-sysfs;protocol=ssh;branch=master \
file://mts-io-sysfs.init"
S = "${WORKDIR}/git"
diff --git a/recipes-bsp/multitech/mts-io.inc b/recipes-bsp/multitech/mts-io.inc
index 93b9a10..bcc28e6 100644
--- a/recipes-bsp/multitech/mts-io.inc
+++ b/recipes-bsp/multitech/mts-io.inc
@@ -7,9 +7,10 @@ LIC_FILES_CHKSUM = "file://io-module/COPYING;md5=94d55d512a9ba36caa9b7df079bae19
file://io-tool/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
"
do_fetch[depends] += "virtual/kernel:do_shared_workdir"
-INC_PR = "r1"
+INC_PR = "r0"
SRCREV = "${PV}"
+
PR = "${INC_PR}.0"
PKGR = "${PR}-${KERNEL_MODULE_PACKAGE_SUFFIX}${EXTENDPRAUTO}"
@@ -20,7 +21,7 @@ RDEPENDS_${PN}-noarch_append_mtcap = " mts-io-sysfs i2c-tools"
SRC_URI = " \
- git://git.multitech.net/mts-io.git;protocol=git \
+ git://git@gitlab.multitech.net/mirrors/mts-io;protocol=ssh;branch=master \
file://led-status_heartbeat_trigger \
file://lora-led-updater \
file://mts-io.init \
@@ -35,11 +36,14 @@ inherit update-rc.d
inherit autotools
EXTRA_OEMAKE = " -C ${STAGING_KERNEL_DIR} \
+ EXTRA_CFLAGS='-I${B}' \
KBUILD_VERBOSE=1 \
M=${S}/io-module \
modules \
"
-EXTRA_OEMAKE_append_mtre = "EXTRA_CFLAGS='-D MTRE'"
+EXTRA_OEMAKE_append_mtre = "EXTRA_CFLAGS+=' -D MTRE'"
+
+EXTRA_OEMAKE_append_mtcap3 = "EXTRA_CFLAGS+=' -D PLATFORM_BUS_SYMLINK'"
do_compile () {
bbnote make "$@"
@@ -65,6 +69,7 @@ FILES_${PN}-noarch = "${sysconfdir}/init.d/mts-io \
FILES_${PN}-noarch_append_mtcap += "${sbindir}/lora-led-updater"
+FILES_${PN}-noarch_append_mtcap3 += "${sbindir}/lora-led-updater"
FILES_${PN}-util += "${sbindir}/mts-util-lora2-reset"
FILES_${PN}-util-dbg += "/usr/src /usr/sbin/.debug"
FILES_${PN}-dev += "${includedir}/linux ${includedir}/mts-kernel-headers"
@@ -122,6 +127,11 @@ fakeroot do_install_append_mtcap() {
install -m 0755 ${WORKDIR}/lora-led-updater ${D}${sbindir}/lora-led-updater
}
+fakeroot do_install_append_mtcap3() {
+ install -m 0755 ${WORKDIR}/lora-led-updater ${D}${sbindir}/lora-led-updater
+ sed -i 's/spidev0.0/spidev1.0/' ${D}${sbindir}/lora-led-updater
+}
+
fakeroot do_install_append_mtre() {
# no status led on mtre
echo "" > ${D}${sysconfdir}/init.d/led-status_heartbeat_trigger
diff --git a/recipes-bsp/multitech/mts-io_4.9.2.bb b/recipes-bsp/multitech/mts-io_4.9.5.bb
index ee4fcfa..ee4fcfa 100644
--- a/recipes-bsp/multitech/mts-io_4.9.2.bb
+++ b/recipes-bsp/multitech/mts-io_4.9.5.bb