summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarsh Sharma <harsh.sharma@multitech.com>2021-10-25 14:53:26 -0500
committerHarsh Sharma <harsh.sharma@multitech.com>2021-10-25 14:53:26 -0500
commit5ec3c59dd16c42c4bade24ee75773a8764fcb01e (patch)
tree32bcad1f1bd592c31e3f9920b13dceeb9c54140e
parentd390864f59232db90b80e5e65705c03687db2f1a (diff)
downloadmeta-multitech-5ec3c59dd16c42c4bade24ee75773a8764fcb01e.tar.gz
meta-multitech-5ec3c59dd16c42c4bade24ee75773a8764fcb01e.tar.bz2
meta-multitech-5ec3c59dd16c42c4bade24ee75773a8764fcb01e.zip
Revert "Added support for mtac-003"
This reverts commit d390864f59232db90b80e5e65705c03687db2f1a.
-rwxr-xr-xrecipes-bsp/multitech/mt-dt-overlay/init44
-rw-r--r--recipes-bsp/multitech/mt-dt-overlay_1.0.4.bb (renamed from recipes-bsp/multitech/mt-dt-overlay_1.0.5.bb)2
-rw-r--r--recipes-bsp/multitech/mtac-gpiob_1.1.4.bb4
-rw-r--r--recipes-bsp/multitech/mtac_4.0.7.bb (renamed from recipes-bsp/multitech/mtac_4.0.9.bb)4
-rwxr-xr-xrecipes-bsp/multitech/mts-io/mts-io.init11
5 files changed, 27 insertions, 38 deletions
diff --git a/recipes-bsp/multitech/mt-dt-overlay/init b/recipes-bsp/multitech/mt-dt-overlay/init
index 5bd8523..5114e4e 100755
--- a/recipes-bsp/multitech/mt-dt-overlay/init
+++ b/recipes-bsp/multitech/mt-dt-overlay/init
@@ -5,39 +5,24 @@
# device tree.
sysdir=/sys/devices/platform/mts-io
+i2c=/sys/bus/i2c/devices/
DEVTREE="/sys/kernel/config/device-tree/overlays/"
SYSFS="/usr/sbin/mts-io-sysfs"
-I2CDIR="/sys/bus/i2c/devices"
-AP1_EEPROM=$I2CDIR"/1-0050/eeprom"
-AP2_EEPROM=$I2CDIR"/1-0052/eeprom"
install_dtbo_dir() {
- if ! [[ -d ${DEVTREE} ]] ; then
- mount configfs
- fi
- if ([ -f "$AP1_EEPROM" ] && grep -q GPIOB "$AP1_EEPROM") || ([ -f "$AP2_EEPROM" ] && grep -q GPIOB "$AP2_EEPROM"); then
- for f in *gpiob.dtbo ; do
- if ! [[ -f $f ]] ; then
- continue
- fi
- # f2 is the extracted device name
- base=$(basename $f .dtbo)
- /bin/mkdir ${DEVTREE}/$base || true
- /bin/cat $f >${DEVTREE}/$base/dtbo
- done
- modprobe mt_ac_gpiob
- else
- for f in *lora.dtbo ; do
- if ! [[ -f $f ]] ; then
- continue
- fi
- # f2 is the extracted device name
- base=$(basename $f .dtbo)
- /bin/mkdir ${DEVTREE}/$base || true
- /bin/cat $f >${DEVTREE}/$base/dtbo
- done
- fi
+ for f in *.dtbo ; do
+ if ! [[ -f $f ]] ; then
+ continue
+ fi
+ if ! [[ -d ${DEVTREE} ]] ; then
+ mount configfs
+ fi
+ # f2 is the extracted device name
+ base=$(basename $f .dtbo)
+ /bin/mkdir ${DEVTREE}/$base || true
+ /bin/cat $f >${DEVTREE}/$base/dtbo
+ done
}
# Device tree format:
@@ -72,7 +57,7 @@ setdevtree() {
done
if [[ $best == -1 ]] ; then
# No overlay found
- exit 0
+ exit 0
fi
cd $best
install_dtbo_dir
@@ -108,4 +93,3 @@ case $1 in
exit 2
;;
esac
-
diff --git a/recipes-bsp/multitech/mt-dt-overlay_1.0.5.bb b/recipes-bsp/multitech/mt-dt-overlay_1.0.4.bb
index 5727e14..97635c9 100644
--- a/recipes-bsp/multitech/mt-dt-overlay_1.0.5.bb
+++ b/recipes-bsp/multitech/mt-dt-overlay_1.0.4.bb
@@ -24,7 +24,7 @@ dt_dir = "/lib/dtoverlays"
PR = "r1"
SRC_URI = " \
- git://git.multitech.net/mt-dt-overlay.git;protocol=git \
+ git://git.multitech.net/mt-dt-overlay.git;protocol=git \
file://init \
"
diff --git a/recipes-bsp/multitech/mtac-gpiob_1.1.4.bb b/recipes-bsp/multitech/mtac-gpiob_1.1.4.bb
index f004cec..ecc1fb2 100644
--- a/recipes-bsp/multitech/mtac-gpiob_1.1.4.bb
+++ b/recipes-bsp/multitech/mtac-gpiob_1.1.4.bb
@@ -49,12 +49,12 @@ do_compile () {
PACKAGES = "kernel-module-${PN}"
-FILES_kernel-module-${PN} = "${base_libdir}/modules/${KERNEL_VERSION}/extra/mt_ac_gpiob.ko"
+FILES_kernel-module-${PN} = "${base_libdir}/modules/${KERNEL_VERSION}/extra/mtac_gpiob.ko"
PARALLEL_MAKE = ""
fakeroot do_install () {
install -m 0755 -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra
# use cp instead of install so the driver doesn't get stripped
- cp ${S}/mtac_gpiob.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra/mt_ac_gpiob.ko
+ cp ${S}/mtac_gpiob.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra
}
diff --git a/recipes-bsp/multitech/mtac_4.0.9.bb b/recipes-bsp/multitech/mtac_4.0.7.bb
index ecabcb3..ebe091a 100644
--- a/recipes-bsp/multitech/mtac_4.0.9.bb
+++ b/recipes-bsp/multitech/mtac_4.0.7.bb
@@ -9,7 +9,7 @@ DEPENDS = "virtual/kernel mts-io"
INC_PR = "r0"
COMPATIBLE_MACHINE = "(mtcdt|mtcpmhs)"
-SRCREV = "${AUTOREV}"
+SRCREV = "${PV}"
# AUTOREV breaks mLinux source tarballs in Thud
# SRCREV = "${AUTOREV}"
@@ -22,7 +22,7 @@ PR = "${INC_PR}.1"
PKGR = "${PR}${KERNEL_MODULE_PACKAGE_SUFFIX}${EXTENDPRAUTO}"
SRC_URI = " \
- git://git@gitlab.multitech.net/mirrors/mtac;protocol=ssh;branch=master \
+ git://git.multitech.net/mtac.git;protocol=git;branch=master \
"
S = "${WORKDIR}/git"
diff --git a/recipes-bsp/multitech/mts-io/mts-io.init b/recipes-bsp/multitech/mts-io/mts-io.init
index a75ceb9..ed0475e 100755
--- a/recipes-bsp/multitech/mts-io/mts-io.init
+++ b/recipes-bsp/multitech/mts-io/mts-io.init
@@ -210,13 +210,18 @@ read_card_info() {
return 0
fi
-
- if [[ ${hw_name} == MTCAP ]] || [[ ${hw_name} == MTCDT ]]; then
+ if [ -d $port1 ] && [[ $(cat $port1/hw-version) = $lora_hw ]]; then
+ modprobe spidev
+ ln -sf /dev/spidev32766.2 /dev/spidev0.0
+ elif [ -d $port2 ] && [[ $(cat $port2/hw-version) = $lora_hw ]]; then
+ modprobe spidev
+ ln -sf /dev/spidev32765.2 /dev/spidev0.0
+ elif [[ ${hw_name} == MTCAP ]]; then
modprobe spidev
elif [[ ${hw_name} == MTCDTIPHP ]]; then
modprobe spidev
ln -sf /dev/spidev32766.2 /dev/spidev0.0
- fi
+ fi
}
mfser_init() {