summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2018-12-03 16:43:02 -0600
committerJohn Klug <john.klug@multitech.com>2019-07-03 11:22:01 -0500
commit47880ff61e61b1efb714a709f78a653cf44137b2 (patch)
tree4909b28d03f6283794b2001e2fea46d1f34b4444
parent003a0be3868ff3a6b11874611f1ad061f5e4c58d (diff)
downloadmeta-multitech-47880ff61e61b1efb714a709f78a653cf44137b2.tar.gz
meta-multitech-47880ff61e61b1efb714a709f78a653cf44137b2.tar.bz2
meta-multitech-47880ff61e61b1efb714a709f78a653cf44137b2.zip
fixdep is needed for deviced tree compiles
-rw-r--r--recipes-kernel/linux/linux-at91_4.9.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-at91_4.9.bb b/recipes-kernel/linux/linux-at91_4.9.bb
index b0f9a4a..28d6a14 100644
--- a/recipes-kernel/linux/linux-at91_4.9.bb
+++ b/recipes-kernel/linux/linux-at91_4.9.bb
@@ -101,9 +101,10 @@ pkg_postinst_kernel-image-uimage-inst() {
fi
}
-# Install dtc to build any device tree overlays in other recipes/modules.
+# Install dtc and fixdep to build any device tree overlays in other recipes/modules.
do_install_append() {
install -D -m 0755 scripts/dtc/dtc ${STAGING_DIR_NATIVE}${USRBINPATH_class-native}/dtc
+ install -D -m 0755 scripts/basic/fixdep ${STAGING_DIR_NATIVE}${USRBINPATH_class-native}/fixdep
install -d -m 0755 ${D}${includedir}/linux
cp -a ${STAGING_KERNEL_DIR}/include/dt-bindings ${D}${includedir}/linux/
install -d -m 0755 ${STAGING_DIR_TARGET}/${includedir}/linux