summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Hatch <jhatch@multitech.com>2022-01-14 08:44:26 -0600
committerJeff Hatch <jhatch@multitech.com>2022-01-14 08:44:26 -0600
commit0927d35d3ff04ee475d50d66531f92ed9564cfcc (patch)
tree923f18f4cd73a29f3ccf99a501731805f2423505
parent0e1269c9c5f91cc5c6edac0ec3bffe5d606b5b48 (diff)
parent8f7ef428b1bfcb11e396a873764b116f05f3edbb (diff)
downloadmeta-multitech-0927d35d3ff04ee475d50d66531f92ed9564cfcc.tar.gz
meta-multitech-0927d35d3ff04ee475d50d66531f92ed9564cfcc.tar.bz2
meta-multitech-0927d35d3ff04ee475d50d66531f92ed9564cfcc.zip
Merge branch 'vs/mtx-4338' into 6
-rw-r--r--recipes-bsp/multitech/mt-dt-overlay_1.1.2.bb (renamed from recipes-bsp/multitech/mt-dt-overlay_1.1.1.bb)0
-rw-r--r--recipes-bsp/multitech/mts-id-eeprom_0.6.3.bb (renamed from recipes-bsp/multitech/mts-id-eeprom_0.6.2.bb)0
-rw-r--r--recipes-bsp/multitech/mts-io.inc2
-rw-r--r--recipes-bsp/multitech/mts-io/mts-io.conf3
-rwxr-xr-xrecipes-bsp/multitech/mts-io/mts-io.init6
-rw-r--r--recipes-bsp/multitech/mts-io_4.8.3.bb (renamed from recipes-bsp/multitech/mts-io_4.8.0.bb)0
6 files changed, 7 insertions, 4 deletions
diff --git a/recipes-bsp/multitech/mt-dt-overlay_1.1.1.bb b/recipes-bsp/multitech/mt-dt-overlay_1.1.2.bb
index 09c8f4a..09c8f4a 100644
--- a/recipes-bsp/multitech/mt-dt-overlay_1.1.1.bb
+++ b/recipes-bsp/multitech/mt-dt-overlay_1.1.2.bb
diff --git a/recipes-bsp/multitech/mts-id-eeprom_0.6.2.bb b/recipes-bsp/multitech/mts-id-eeprom_0.6.3.bb
index 12c32c4..12c32c4 100644
--- a/recipes-bsp/multitech/mts-id-eeprom_0.6.2.bb
+++ b/recipes-bsp/multitech/mts-id-eeprom_0.6.3.bb
diff --git a/recipes-bsp/multitech/mts-io.inc b/recipes-bsp/multitech/mts-io.inc
index 10d4527..d810d32 100644
--- a/recipes-bsp/multitech/mts-io.inc
+++ b/recipes-bsp/multitech/mts-io.inc
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://io-module/COPYING;md5=94d55d512a9ba36caa9b7df079bae19
file://io-tool/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
"
do_fetch[depends] += "virtual/kernel:do_shared_workdir"
-INC_PR = "r6"
+INC_PR = "r2"
SRCREV = "${PV}"
PR = "${INC_PR}.0"
diff --git a/recipes-bsp/multitech/mts-io/mts-io.conf b/recipes-bsp/multitech/mts-io/mts-io.conf
index 4ed5e31..977346e 100644
--- a/recipes-bsp/multitech/mts-io/mts-io.conf
+++ b/recipes-bsp/multitech/mts-io/mts-io.conf
@@ -17,3 +17,6 @@ SUPERCAPFULL=1
#
SUPERCAPFULL_MAXWAIT=180
+# Print dynamic debug for mts-io to kernel
+# ring buffer (dmesg)
+# MTS_IO_PARAMS="dyndbg==pmf"
diff --git a/recipes-bsp/multitech/mts-io/mts-io.init b/recipes-bsp/multitech/mts-io/mts-io.init
index cd93fbb..b62bcb1 100755
--- a/recipes-bsp/multitech/mts-io/mts-io.init
+++ b/recipes-bsp/multitech/mts-io/mts-io.init
@@ -131,7 +131,7 @@ reset_path() {
pin=$1
${LOGDBG} -t "mts-io" -p daemon.info Reset $pin
if [[ -f ${pin} ]] ; then
- if ! ( (echo 1 >${pin}) && ${WAIT} && (echo 0 >${pin}) && ${WAIT} && (echo 1 >${pin}) ) ; then
+ if ! ( (echo 0 >${pin}) && ${WAIT} && (echo 1 >${pin}) ) ; then
/usr/bin/logger -t "mts-io" -p daemon.error -s "Failed write to ${pin}"
return 1
fi
@@ -325,7 +325,7 @@ case $1 in
echo -n ${i2c} > /sys/module/firmware_class/parameters/path
/usr/bin/logger -t "mts-io" -p daemon.info -s "Loading mts-io module"
- if ! modprobe mts_io ; then
+ if ! modprobe mts_io "$MTS_IO_PARAMS" ; then
((fail++))
fi
# MTCDTBB driver is needed to determine the product type on MTCDT3
@@ -362,7 +362,7 @@ case $1 in
# MTCDT-0.2 has issues with resetting RS9113 twice.
# RS9113 is reset in /etc/init.d/rs9113.
# Remove for MTRV1 reset as well, as it is redundant.
- if [[ $hw_name == MTCDT ]] || [[ $hw_name == MTRV1 ]] ; then
+ if [[ $hw_name == MTCDT ]] || [[ $hw_name == MTRV1 ]] || [[ $hw_name == MTCDTIP ]] ; then
RST[${WIFIBTRESET}]="/dev/null"
fi
reset_array
diff --git a/recipes-bsp/multitech/mts-io_4.8.0.bb b/recipes-bsp/multitech/mts-io_4.8.3.bb
index ee4fcfa..ee4fcfa 100644
--- a/recipes-bsp/multitech/mts-io_4.8.0.bb
+++ b/recipes-bsp/multitech/mts-io_4.8.3.bb