summaryrefslogtreecommitdiff
path: root/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/at91bootstrap/at91bootstrap-3.5.3')
-rw-r--r--recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/.at91bootstrap-3.5.2-onetime-slow-clock-switch.patch.swpbin12288 -> 0 bytes
-rw-r--r--recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.2-add-install.patch20
-rw-r--r--recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.2-onetime-slow-clock-switch.patch91
-rw-r--r--recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.3-disable-rtc-interrupts.patch27
-rw-r--r--recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.3-mtcdt.patch129
-rw-r--r--recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.3-mtr.patch102
-rw-r--r--recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.3-mtrv1-DDRlowDriveStrength.patch34
-rw-r--r--recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.3-remove-std-includes.patch12
-rw-r--r--recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91sam9x5_4bit_pmecc_header.bin1
-rwxr-xr-xrecipes-bsp/at91bootstrap/at91bootstrap-3.5.3/create_4bit_pmecc_header.rb5
10 files changed, 0 insertions, 421 deletions
diff --git a/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/.at91bootstrap-3.5.2-onetime-slow-clock-switch.patch.swp b/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/.at91bootstrap-3.5.2-onetime-slow-clock-switch.patch.swp
deleted file mode 100644
index f31477d..0000000
--- a/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/.at91bootstrap-3.5.2-onetime-slow-clock-switch.patch.swp
+++ /dev/null
Binary files differ
diff --git a/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.2-add-install.patch b/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.2-add-install.patch
deleted file mode 100644
index 6f007b9..0000000
--- a/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.2-add-install.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Index: at91bootstrap-3.5.2/Makefile
-===================================================================
---- at91bootstrap-3.5.2.orig/Makefile 2013-02-08 14:38:40.660054339 -0600
-+++ at91bootstrap-3.5.2/Makefile 2013-02-08 14:41:30.626272862 -0600
-@@ -359,4 +359,15 @@
-
- PHONY+=tarball tarballx
-
-+install:
-+ -install -d $(DESTDIR)
-+ install $(AT91BOOTSTRAP) $(DESTDIR)/$(IMAGE)
-+ -rm -f $(DESTDIR)/$(SYMLINK)
-+ (cd ${DESTDIR} ; \
-+ ln -sf ${IMAGE} ${SYMLINK} \
-+ )
-+
-+
-+PHONY+=install
-+
- .PHONY: $(PHONY)
diff --git a/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.2-onetime-slow-clock-switch.patch b/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.2-onetime-slow-clock-switch.patch
deleted file mode 100644
index 98ccd41..0000000
--- a/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.2-onetime-slow-clock-switch.patch
+++ /dev/null
@@ -1,91 +0,0 @@
-Index: at91bootstrap-3.5.2/driver/at91_slowclk.c
-===================================================================
---- at91bootstrap-3.5.2.orig/driver/at91_slowclk.c 2013-01-30 04:01:20.000000000 -0600
-+++ at91bootstrap-3.5.2/driver/at91_slowclk.c 2013-04-24 11:35:44.369827054 -0500
-@@ -33,12 +33,17 @@
- {
- unsigned int reg;
-
-- /*
-- * Enable the 32768 Hz oscillator by setting the bit OSC32EN to 1
-- */
-+
- reg = readl(AT91C_BASE_SCKCR);
-- reg |= AT91C_SLCKSEL_OSC32EN;
-- writel(reg, AT91C_BASE_SCKCR);
-+
-+ /* Only enable 32768 Hz oscillator if needed */
-+ if ( !(reg & AT91C_SLCKSEL_OSC32EN) ) {
-+ /*
-+ * Enable the 32768 Hz oscillator by setting the bit OSC32EN to 1
-+ */
-+ reg |= AT91C_SLCKSEL_OSC32EN;
-+ writel(reg, AT91C_BASE_SCKCR);
-+ }
-
- /* start a internal timer */
- start_interval_timer();
-@@ -50,32 +55,40 @@
- {
- unsigned int reg;
-
-- /*
-- * Wait 32768 Hz Startup Time for clock stabilization (software loop)
-- * wait about 1s (1000ms)
-- */
-- wait_interval_timer(1000);
--
-- /*
-- * Switching from internal 32kHz RC oscillator to 32768 Hz oscillator
-- * by setting the bit OSCSEL to 1
-- */
- reg = readl(AT91C_BASE_SCKCR);
-- reg |= AT91C_SLCKSEL_OSCSEL;
-- writel(reg, AT91C_BASE_SCKCR);
-
-- /*
-- * Waiting 5 slow clock cycles for internal resynchronization
-- * 5 slow clock cycles = ~153 us (5 / 32768)
-- */
-- udelay(153);
--
-- /*
-- * Disable the 32kHz RC oscillator by setting the bit RCEN to 0
-- */
-+ /* Only switch clock source if needed */
-+ if ( !(reg & AT91C_SLCKSEL_OSCSEL) ) {
-+ dbgu_print("Switching slow clock to external oscillator...\n\r");
-+ /*
-+ * Wait 32768 Hz Startup Time for clock stabilization (software loop)
-+ * wait about 1s (1000ms)
-+ */
-+ wait_interval_timer(1000);
-+
-+ /*
-+ * Switching from internal 32kHz RC oscillator to 32768 Hz oscillator
-+ * by setting the bit OSCSEL to 1
-+ */
-+ reg |= AT91C_SLCKSEL_OSCSEL;
-+ writel(reg, AT91C_BASE_SCKCR);
-+
-+ /*
-+ * Waiting 5 slow clock cycles for internal resynchronization
-+ * 5 slow clock cycles = ~153 us (5 / 32768)
-+ */
-+ udelay(153);
-+ }
-+
-+ /* Only disable internal RC oscillator if needed */
- reg = readl(AT91C_BASE_SCKCR);
-- reg &= ~AT91C_SLCKSEL_RCEN;
-- writel(reg, AT91C_BASE_SCKCR);
-+ if (reg | AT91C_SLCKSEL_RCEN) {
-+ /*
-+ * Disable the 32kHz RC oscillator by setting the bit RCEN to 0
-+ */
-+ reg &= ~AT91C_SLCKSEL_RCEN;
-+ writel(reg, AT91C_BASE_SCKCR);
-+ }
-
- return 0;
- }
diff --git a/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.3-disable-rtc-interrupts.patch b/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.3-disable-rtc-interrupts.patch
deleted file mode 100644
index e5dd013..0000000
--- a/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.3-disable-rtc-interrupts.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Index: at91bootstrap-3.5.3/board/at91sam9x5ek/at91sam9x5ek.c
-===================================================================
---- at91bootstrap-3.5.3.orig/board/at91sam9x5ek/at91sam9x5ek.c 2015-12-21 15:42:05.498892917 -0600
-+++ at91bootstrap-3.5.3/board/at91sam9x5ek/at91sam9x5ek.c 2015-12-22 14:53:59.151521592 -0600
-@@ -46,6 +46,9 @@
-
- #include "onewire_info.h"
-
-+#define RTC_SCCR 0x1C
-+#define RTC_IDR 0x24
-+
- #ifdef CONFIG_USER_HW_INIT
- extern void hw_init_hook(void);
- #endif
-@@ -207,6 +210,12 @@
- #ifdef CONFIG_USER_HW_INIT
- hw_init_hook();
- #endif
-+
-+ /* disable all RTC interrupts and clear status register.
-+ * Prevents possible Linux lockup due to unexpected RTC interrupt
-+ */
-+ writel(0xFF, RTC_IDR + AT91C_BASE_RTC);
-+ writel(0xFF, RTC_SCCR + AT91C_BASE_RTC);
- }
- #endif /* #ifdef CONFIG_HW_INIT */
-
diff --git a/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.3-mtcdt.patch b/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.3-mtcdt.patch
deleted file mode 100644
index 92a3a3b..0000000
--- a/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.3-mtcdt.patch
+++ /dev/null
@@ -1,129 +0,0 @@
-Index: git/board/at91sam9x5ek/at91sam9x5eknf_uboot_defconfig
-===================================================================
---- git.orig/board/at91sam9x5ek/at91sam9x5eknf_uboot_defconfig 2015-01-13 13:31:45.162884794 -0600
-+++ git/board/at91sam9x5ek/at91sam9x5eknf_uboot_defconfig 2015-01-13 13:45:17.967816395 -0600
-@@ -1,6 +1,6 @@
- #
- # Automatically generated make config: don't edit
--# Thu Apr 11 16:45:29 2013
-+# Tue Jan 13 13:09:23 2015
- #
- HAVE_DOT_CONFIG=y
- CONFIG_BOARDNAME="at91sam9x5ek"
-@@ -42,7 +42,7 @@
- ALLOW_PIO3=y
- CONFIG_HAS_PIO3=y
- CPU_HAS_PMECC=y
--CONFIG_LOAD_ONE_WIRE=y
-+# CONFIG_LOAD_ONE_WIRE is not set
- # CONFIG_MMC_SUPPORT is not set
-
- #
-@@ -60,8 +60,8 @@
- # ALLOW_SDRAM_16BIT is not set
- # CONFIG_RAM_32MB is not set
- # CONFIG_RAM_64MB is not set
--CONFIG_RAM_128MB=y
--# CONFIG_RAM_256MB is not set
-+# CONFIG_RAM_128MB is not set
-+CONFIG_RAM_256MB=y
- # CONFIG_RAM_512MB is not set
- # CONFIG_DATAFLASH is not set
- # CONFIG_FLASH is not set
-@@ -81,8 +81,8 @@
- #
- # PMECC Configuration
- #
--CONFIG_PMECC_CORRECT_BITS_2=y
--# CONFIG_PMECC_CORRECT_BITS_4 is not set
-+# CONFIG_PMECC_CORRECT_BITS_2 is not set
-+CONFIG_PMECC_CORRECT_BITS_4=y
- # CONFIG_PMECC_CORRECT_BITS_8 is not set
- # CONFIG_PMECC_CORRECT_BITS_12 is not set
- # CONFIG_PMECC_CORRECT_BITS_24 is not set
-@@ -101,7 +101,7 @@
- # CONFIG_LOAD_64KB is not set
- CONFIG_IMG_ADDRESS="0x00040000"
- CONFIG_IMG_SIZE="0x00080000"
--CONFIG_JUMP_ADDR="0x26F00000"
-+CONFIG_JUMP_ADDR="0x2EF00000"
-
- #
- # U-Boot Image Storage Setup
-@@ -116,4 +116,4 @@
- # CONFIG_USER_HW_INIT is not set
- CONFIG_THUMB=y
- CONFIG_SCLK=y
--CONFIG_DISABLE_WATCHDOG=y
-+# CONFIG_DISABLE_WATCHDOG is not set
-Index: git/board/at91sam9x5ek/at91sam9x5ek.c
-===================================================================
---- git.orig/board/at91sam9x5ek/at91sam9x5ek.c 2019-04-04 15:49:54.143358228 -0500
-+++ git/board/at91sam9x5ek/at91sam9x5ek.c 2019-04-04 17:07:51.999219741 -0500
-@@ -53,6 +53,32 @@
- extern void hw_init_hook(void);
- #endif
-
-+
-+static void initialize_mt_gpio(void)
-+{
-+ /* Configure DBGU pins */
-+ const struct pio_desc mt_gpio_pins[] = {
-+ /* Misc. pins -- Pins PD15-PD18 belong to PERIPH
-+ * B A20-A25 until bootstrap shuts them down.
-+ * This code prevents these pins from being used
-+ * during boot, since we do not
-+ * need these pins to boot the system and we
-+ * do not want resets to toggle needlessly.
-+ */
-+ {"WFBT-RESET",AT91C_PIN_PD(14), 1, PIO_PULLUP, PIO_OUTPUT},
-+ {"GNSS-RESET",AT91C_PIN_PD(15), 1, PIO_PULLUP, PIO_OUTPUT},
-+ {"SECURE-RESET",AT91C_PIN_PD(16), 1, PIO_PULLUP, PIO_OUTPUT},
-+ {"MTQ-RESET",AT91C_PIN_PD(17), 1, PIO_PULLUP, PIO_OUTPUT},
-+ {"USBHUB-RESET",AT91C_PIN_PD(18), 1, PIO_PULLUP, PIO_OUTPUT},
-+ {"GNSS-INT",AT91C_PIN_PD(19), 1, PIO_PULLUP, PIO_OUTPUT},
-+ {"WIFI-BT-LPMODE",AT91C_PIN_PD(20), 0, PIO_PULLUP, PIO_INPUT},
-+ {(char *)0, 0, 0, PIO_DEFAULT, PIO_PERIPH_A},
-+ };
-+
-+ pio_configure(mt_gpio_pins);
-+}
-+
-+
- static void at91_dbgu_hw_init(void)
- {
- /* Configure DBGU pins */
-@@ -198,6 +223,9 @@
- slowclk_enable_osc32();
- #endif
-
-+ /* Initialize MT GPIO */
-+ initialize_mt_gpio();
-+
- /* Initialize dbgu */
- initialize_dbgu();
-
-@@ -322,10 +350,8 @@
-
- reg = readl(AT91C_BASE_CCFG + CCFG_EBICSA);
- reg |= AT91C_EBI_CS3A_SM;
-- if (get_cm_rev() == 'A')
-- reg &= ~AT91C_EBI_NFD0_ON_D16;
-- else
-- reg |= (AT91C_EBI_DDR_MP_EN | AT91C_EBI_NFD0_ON_D16);
-+ /* MTCDT */
-+ reg |= (AT91C_EBI_DDR_MP_EN | AT91C_EBI_NFD0_ON_D16);
-
- reg &= ~AT91C_EBI_DRV;
- writel(reg, AT91C_BASE_CCFG + CCFG_EBICSA);
-@@ -355,9 +381,7 @@
- AT91C_BASE_SMC + SMC_CTRL3);
-
- /* Configure the PIO controller */
-- if (get_cm_rev() == 'A')
-- pio_configure(nand_pins_lo);
-- else
-+ /* MTCDT */
- pio_configure(nand_pins_hi);
-
- writel((1 << AT91C_ID_PIOC_D), (PMC_PCER + AT91C_BASE_PMC));
diff --git a/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.3-mtr.patch b/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.3-mtr.patch
deleted file mode 100644
index 0a7600d..0000000
--- a/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.3-mtr.patch
+++ /dev/null
@@ -1,102 +0,0 @@
-Index: at91bootstrap-3.5.3/board/at91sam9x5ek/at91sam9x5eknf_uboot_defconfig
-===================================================================
---- at91bootstrap-3.5.3.orig/board/at91sam9x5ek/at91sam9x5eknf_uboot_defconfig 2013-04-11 05:07:35.000000000 -0500
-+++ at91bootstrap-3.5.3/board/at91sam9x5ek/at91sam9x5eknf_uboot_defconfig 2013-04-29 15:13:01.390913836 -0500
-@@ -42,7 +42,8 @@
- ALLOW_PIO3=y
- CONFIG_HAS_PIO3=y
- CPU_HAS_PMECC=y
--CONFIG_LOAD_ONE_WIRE=y
-+# MTS: don't load one wire
-+# CONFIG_LOAD_ONE_WIRE is not set
- # CONFIG_MMC_SUPPORT is not set
-
- #
-@@ -81,8 +82,8 @@
- #
- # PMECC Configuration
- #
--CONFIG_PMECC_CORRECT_BITS_2=y
--# CONFIG_PMECC_CORRECT_BITS_4 is not set
-+# CONFIG_PMECC_CORRECT_BITS_2 is not set
-+CONFIG_PMECC_CORRECT_BITS_4=y
- # CONFIG_PMECC_CORRECT_BITS_8 is not set
- # CONFIG_PMECC_CORRECT_BITS_12 is not set
- # CONFIG_PMECC_CORRECT_BITS_24 is not set
-@@ -116,4 +117,5 @@
- # CONFIG_USER_HW_INIT is not set
- CONFIG_THUMB=y
- CONFIG_SCLK=y
--CONFIG_DISABLE_WATCHDOG=y
-+# MTS: don't disable watchdog
-+# CONFIG_DISABLE_WATCHDOG is not set
-Index: at91bootstrap-3.5.3/board/at91sam9x5ek/at91sam9x5ek.c
-===================================================================
---- at91bootstrap-3.5.3.orig/board/at91sam9x5ek/at91sam9x5ek.c 2019-04-04 15:49:54.143358228 -0500
-+++ at91bootstrap-3.5.3/board/at91sam9x5ek/at91sam9x5ek.c 2019-04-04 17:31:57.691176941 -0500
-@@ -53,6 +53,31 @@
- extern void hw_init_hook(void);
- #endif
-
-+
-+static void initialize_mt_gpio(void)
-+{
-+ /* Configure DBGU pins */
-+ const struct pio_desc mt_gpio_pins[] = {
-+ /* Misc. pins -- Pins PD15-PD18 belong to PERIPH
-+ * B A20-A25 until bootstrap shuts them down.
-+ * This code prevents these pins from being used
-+ * during boot, since we do not
-+ * need these pins to boot the system and we
-+ * do not want resets to toggle needlessly.
-+ */
-+ {"GNSS-RESET",AT91C_PIN_PD(15), 1, PIO_PULLUP, PIO_OUTPUT},
-+ {"SECURE-RESET",AT91C_PIN_PD(16), 1, PIO_PULLUP, PIO_OUTPUT},
-+ {"MTQ-RESET",AT91C_PIN_PD(17), 1, PIO_PULLUP, PIO_OUTPUT},
-+ {"USBHUB-RESET",AT91C_PIN_PD(18), 1, PIO_PULLUP, PIO_OUTPUT},
-+ {"GNSS-INT",AT91C_PIN_PD(19), 1, PIO_PULLUP, PIO_OUTPUT},
-+ {"WIFI-BT-LPMODE",AT91C_PIN_PD(20), 0, PIO_PULLUP, PIO_INPUT},
-+ {(char *)0, 0, 0, PIO_DEFAULT, PIO_PERIPH_A},
-+ };
-+
-+ pio_configure(mt_gpio_pins);
-+}
-+
-+
- static void at91_dbgu_hw_init(void)
- {
- /* Configure DBGU pins */
-@@ -198,6 +223,9 @@
- slowclk_enable_osc32();
- #endif
-
-+ /* Initialize MT GPIO */
-+ initialize_mt_gpio();
-+
- /* Initialize dbgu */
- initialize_dbgu();
-
-@@ -322,10 +350,8 @@
-
- reg = readl(AT91C_BASE_CCFG + CCFG_EBICSA);
- reg |= AT91C_EBI_CS3A_SM;
-- if (get_cm_rev() == 'A')
-- reg &= ~AT91C_EBI_NFD0_ON_D16;
-- else
-- reg |= (AT91C_EBI_DDR_MP_EN | AT91C_EBI_NFD0_ON_D16);
-+ /* MTR */
-+ reg |= (AT91C_EBI_DDR_MP_EN | AT91C_EBI_NFD0_ON_D16);
-
- reg &= ~AT91C_EBI_DRV;
- writel(reg, AT91C_BASE_CCFG + CCFG_EBICSA);
-@@ -355,9 +381,7 @@
- AT91C_BASE_SMC + SMC_CTRL3);
-
- /* Configure the PIO controller */
-- if (get_cm_rev() == 'A')
-- pio_configure(nand_pins_lo);
-- else
-+ /* MTR2 */
- pio_configure(nand_pins_hi);
-
- writel((1 << AT91C_ID_PIOC_D), (PMC_PCER + AT91C_BASE_PMC));
diff --git a/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.3-mtrv1-DDRlowDriveStrength.patch b/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.3-mtrv1-DDRlowDriveStrength.patch
deleted file mode 100644
index 912a891..0000000
--- a/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.3-mtrv1-DDRlowDriveStrength.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Index: at91bootstrap-3.5.3/board/at91sam9x5ek/at91sam9x5ek.c
-===================================================================
---- at91bootstrap-3.5.3.orig/board/at91sam9x5ek/at91sam9x5ek.c 2015-09-29 09:55:07.335113881 -0500
-+++ at91bootstrap-3.5.3/board/at91sam9x5ek/at91sam9x5ek.c 2015-09-29 10:13:19.397489104 -0500
-@@ -81,7 +81,8 @@
- | AT91C_DDRC2_CAS_3 /* CAS Latency 3 */
- | AT91C_DDRC2_NB_BANKS_8 /* 8 banks */
- | AT91C_DDRC2_DLL_RESET_DISABLED /* DLL not reset */
-- | AT91C_DDRC2_DECOD_INTERLEAVED);/*Interleaved decode*/
-+ | AT91C_DDRC2_DIC_DS /* Low DDR Drive Strength */
-+ | AT91C_DDRC2_DECOD_INTERLEAVED);/* Interleaved decode*/
-
- /*
- * Make sure to uncomment the following line if the DDR controller
-Index: at91bootstrap-3.5.3/main.c
-===================================================================
---- at91bootstrap-3.5.3.orig/main.c 2013-04-11 05:07:35.000000000 -0500
-+++ at91bootstrap-3.5.3/main.c 2015-09-29 10:10:21.354971492 -0500
-@@ -68,12 +68,15 @@
- {
- char *version = "AT91Bootstrap";
- char *ver_num = " "AT91BOOTSTRAP_VERSION" ("COMPILE_TIME")";
-+ char *feature = "DDR Drive Strength: low";
-
- dbgu_print("\n\r");
- dbgu_print("\n\r");
- dbgu_print(version);
- dbgu_print(ver_num);
- dbgu_print("\n\r");
-+ dbgu_print(feature);
-+ dbgu_print("\n\r");
- dbgu_print("\n\r");
- }
-
diff --git a/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.3-remove-std-includes.patch b/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.3-remove-std-includes.patch
deleted file mode 100644
index 01920c2..0000000
--- a/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91bootstrap-3.5.3-remove-std-includes.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: at91bootstrap-3.5.3/driver/debug.c
-===================================================================
---- at91boostrap-3.5.3.orig/driver/debug.c.orig 2017-02-13 16:14:17.214217038 -0600
-+++ at91boostrap-3.5.3/driver/debug.c 2017-02-13 15:48:44.106262425 -0600
-@@ -27,7 +27,6 @@
- */
- #include "dbgu.h"
- #include "debug.h"
--#include <stdio.h>
- #include <stdarg.h>
-
- #define MAX_BUFFER 128
diff --git a/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91sam9x5_4bit_pmecc_header.bin b/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91sam9x5_4bit_pmecc_header.bin
deleted file mode 100644
index f8d6073..0000000
--- a/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/at91sam9x5_4bit_pmecc_header.bin
+++ /dev/null
@@ -1 +0,0 @@
-$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$ \ No newline at end of file
diff --git a/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/create_4bit_pmecc_header.rb b/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/create_4bit_pmecc_header.rb
deleted file mode 100755
index 780d728..0000000
--- a/recipes-bsp/at91bootstrap/at91bootstrap-3.5.3/create_4bit_pmecc_header.rb
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/usr/bin/env ruby
-
-52.times do
- print ["052490c0"].pack('H*')
-end