summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
authorMykyta Dorokhin <mykyta.dorokhin@globallogic.com>2021-01-14 18:17:03 +0200
committerMykyta Dorokhin <mykyta.dorokhin@globallogic.com>2021-01-14 18:17:03 +0200
commitdb7c7662c42993bea556e180eba02efdd790f62f (patch)
tree944828feccf82300d451f821f81c237e9138f8fe /recipes-kernel/linux
parentfe7ff1fdfa75034dcf85b27f7bb8811b58d7e3e0 (diff)
downloadmeta-multitech-atmel-db7c7662c42993bea556e180eba02efdd790f62f.tar.gz
meta-multitech-atmel-db7c7662c42993bea556e180eba02efdd790f62f.tar.bz2
meta-multitech-atmel-db7c7662c42993bea556e180eba02efdd790f62f.zip
linux 5.4: files needed to build external kernel modules
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-at91_5.4.81.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-at91_5.4.81.bb b/recipes-kernel/linux/linux-at91_5.4.81.bb
index d41eea1..4ce96ec 100644
--- a/recipes-kernel/linux/linux-at91_5.4.81.bb
+++ b/recipes-kernel/linux/linux-at91_5.4.81.bb
@@ -72,6 +72,14 @@ python do_unpack_append () {
bb.build.exec_func('copy_mts_dts_files', d)
}
+# Files needed to build external kernel modules.
+do_shared_workdir_append() {
+ install -d -m 755 ${STAGING_KERNEL_BUILDDIR}/include/config
+ cp -a ${B}/include/config ${STAGING_KERNEL_BUILDDIR}/include/
+ cp -a ${B}/scripts ${STAGING_KERNEL_BUILDDIR}
+ echo ${PR} > ${STAGING_KERNEL_BUILDDIR}/mlinux_pr
+}
+
do_configure_prepend() {
if [ ! -f "${WORKDIR}/defconfig" ] && [ -n "${KBUILD_DEFCONFIG}" ]; then
if [ -f "${S}/arch/${ARCH}/configs/${KBUILD_DEFCONFIG}" ]; then