summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
authorMykyta Dorokhin <mykyta.dorokhin@globallogic.com>2021-01-14 18:15:06 +0200
committerMykyta Dorokhin <mykyta.dorokhin@globallogic.com>2021-01-14 18:15:06 +0200
commit9efe03c07d0abd47d67c78be06d2af22f3f66eb1 (patch)
treec5e6451b341bd64f5aabf35be5595927e6a40bff /recipes-kernel/linux
parent2ef6078c7e83b8ba9d470a2ce70a4bacda65ef24 (diff)
downloadmeta-multitech-atmel-9efe03c07d0abd47d67c78be06d2af22f3f66eb1.tar.gz
meta-multitech-atmel-9efe03c07d0abd47d67c78be06d2af22f3f66eb1.tar.bz2
meta-multitech-atmel-9efe03c07d0abd47d67c78be06d2af22f3f66eb1.zip
linux 5.4: reimplemented patches
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-at91-5.4.81/EXTRAVERSION.patch25
-rw-r--r--recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-add-num_accessory_ports-config-option.patch34
-rw-r--r--recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-addl-time-for-pmeccerrloc.patch25
-rw-r--r--recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-at91sam9_wdt-10second-timeout.patch25
-rw-r--r--recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-cdc-acm-ignore-exar-devices.patch49
-rw-r--r--recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-disable-atmel_mci-mmc_pwrseq-due-to-build-fail.patch30
-rw-r--r--recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-spidev_squack.patch24
7 files changed, 212 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-at91-5.4.81/EXTRAVERSION.patch b/recipes-kernel/linux/linux-at91-5.4.81/EXTRAVERSION.patch
new file mode 100644
index 0000000..9d7ca43
--- /dev/null
+++ b/recipes-kernel/linux/linux-at91-5.4.81/EXTRAVERSION.patch
@@ -0,0 +1,25 @@
+From 3f3b492072c2cb42f22f231f6f906292b66cdddf Mon Sep 17 00:00:00 2001
+From: Mykyta Dorokhin <mykyta.dorokhin@globallogic.com>
+Date: Thu, 31 Dec 2020 17:20:11 +0200
+Subject: [PATCH] extraversion
+
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 97efb5b..5bbb760 100644
+--- a/Makefile
++++ b/Makefile
+@@ -2,7 +2,7 @@
+ VERSION = 5
+ PATCHLEVEL = 4
+ SUBLEVEL = 81
+-EXTRAVERSION = -linux4sam-2020.10-rc5
++EXTRAVERSION =
+ NAME = Kleptomaniac Octopus
+
+ # *DOCUMENTATION*
+--
+1.9.1
+
diff --git a/recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-add-num_accessory_ports-config-option.patch b/recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-add-num_accessory_ports-config-option.patch
new file mode 100644
index 0000000..78ebd4f
--- /dev/null
+++ b/recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-add-num_accessory_ports-config-option.patch
@@ -0,0 +1,34 @@
+From e614da84515574d14ce3050ee11d5f90e900dcf5 Mon Sep 17 00:00:00 2001
+From: Mykyta Dorokhin <mykyta.dorokhin@globallogic.com>
+Date: Thu, 31 Dec 2020 17:23:13 +0200
+Subject: [PATCH] add-num_accessory_ports-config-option
+
+---
+ arch/arm/Kconfig | 11 +++++++++++
+ 1 file changed, 11 insertions(+)
+
+diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
+index 9aa8871..7187161 100644
+--- a/arch/arm/Kconfig
++++ b/arch/arm/Kconfig
+@@ -286,6 +286,17 @@ config PGTABLE_LEVELS
+ default 3 if ARM_LPAE
+ default 2
+
++menu "MTS"
++
++config MTS_NUM_ACCESSORY_PORTS
++ int "Number of accessory ports in the MTS product"
++ default 0
++ help
++ Enter the number of accessory ports on your MTS device.
++ If unsure, say '0'.
++
++endmenu
++
+ menu "System Type"
+
+ config MMU
+--
+1.9.1
+
diff --git a/recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-addl-time-for-pmeccerrloc.patch b/recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-addl-time-for-pmeccerrloc.patch
new file mode 100644
index 0000000..7077a03
--- /dev/null
+++ b/recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-addl-time-for-pmeccerrloc.patch
@@ -0,0 +1,25 @@
+From bf403e15e724dfe4a319b9e2bcd7e9aad558d27d Mon Sep 17 00:00:00 2001
+From: Mykyta Dorokhin <mykyta.dorokhin@globallogic.com>
+Date: Fri, 1 Jan 2021 03:07:05 +0200
+Subject: [PATCH] linux-5.6-addl-time-for-pmeccerrloc
+
+---
+ drivers/mtd/nand/raw/atmel/pmecc.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/drivers/mtd/nand/raw/atmel/pmecc.c b/drivers/mtd/nand/raw/atmel/pmecc.c
+index e1c5459..01e4729 100644
+--- a/drivers/mtd/nand/raw/atmel/pmecc.c
++++ b/drivers/mtd/nand/raw/atmel/pmecc.c
+@@ -64,7 +64,7 @@
+ #define PMECC_LOOKUP_TABLE_SIZE_1024 0x4000
+
+ /* Time out value for reading PMECC status register */
+-#define PMECC_MAX_TIMEOUT_MS 100
++#define PMECC_MAX_TIMEOUT_MS 300
+
+ /* PMECC Register Definitions */
+ #define ATMEL_PMECC_CFG 0x0
+--
+1.9.1
+
diff --git a/recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-at91sam9_wdt-10second-timeout.patch b/recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-at91sam9_wdt-10second-timeout.patch
new file mode 100644
index 0000000..03aabfb
--- /dev/null
+++ b/recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-at91sam9_wdt-10second-timeout.patch
@@ -0,0 +1,25 @@
+From 4c91fb02348b92473c324e3861ebd0b558c7f535 Mon Sep 17 00:00:00 2001
+From: Mykyta Dorokhin <mykyta.dorokhin@globallogic.com>
+Date: Fri, 1 Jan 2021 03:12:51 +0200
+Subject: [PATCH] at91sam9_wdt-10second-timeout
+
+---
+ drivers/watchdog/at91sam9_wdt.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/drivers/watchdog/at91sam9_wdt.c b/drivers/watchdog/at91sam9_wdt.c
+index 292b5a1..d1fdee4 100644
+--- a/drivers/watchdog/at91sam9_wdt.c
++++ b/drivers/watchdog/at91sam9_wdt.c
+@@ -60,7 +60,7 @@
+ #define WDT_COUNTER_MAX_SECS ticks_to_secs(WDT_COUNTER_MAX_TICKS)
+
+ /* Hardware timeout in seconds */
+-#define WDT_HW_TIMEOUT 2
++#define WDT_HW_TIMEOUT 10
+
+ /* Timer heartbeat (500ms) */
+ #define WDT_TIMEOUT (HZ/2)
+--
+1.9.1
+
diff --git a/recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-cdc-acm-ignore-exar-devices.patch b/recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-cdc-acm-ignore-exar-devices.patch
new file mode 100644
index 0000000..b4d68e5
--- /dev/null
+++ b/recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-cdc-acm-ignore-exar-devices.patch
@@ -0,0 +1,49 @@
+From 37e541cbd166fcfd7a736d25ced4938647c9a167 Mon Sep 17 00:00:00 2001
+From: Mykyta Dorokhin <mykyta.dorokhin@globallogic.com>
+Date: Tue, 12 Jan 2021 23:20:37 +0200
+Subject: [PATCH] linux-5.4-cdc-acm-ignore-exar-devices
+
+---
+ drivers/usb/class/cdc-acm.c | 18 +++++++++++++++++-
+ 1 file changed, 17 insertions(+), 1 deletion(-)
+
+diff --git a/drivers/usb/class/cdc-acm.c b/drivers/usb/class/cdc-acm.c
+index 16c98e7..422f216 100644
+--- a/drivers/usb/class/cdc-acm.c
++++ b/drivers/usb/class/cdc-acm.c
+@@ -1174,8 +1174,10 @@ static int acm_probe(struct usb_interface *intf,
+ /* normal quirks */
+ quirks = (unsigned long)id->driver_info;
+
+- if (quirks == IGNORE_DEVICE)
++ if (quirks == IGNORE_DEVICE) {
++ dev_dbg(&intf->dev, "Ignoring device\n");
+ return -ENODEV;
++ }
+
+ memset(&h, 0x00, sizeof(struct usb_cdc_parsed_header));
+
+@@ -1937,6 +1939,20 @@ static int acm_pre_reset(struct usb_interface *intf)
+ .driver_info = SEND_ZERO_PACKET,
+ },
+
++ /* Ignore Exar XR21V141X usb serial chips
++ * This elminates conflicting with the Exar vizzini driver.
++ * The ACM driver cannot use features in the Exar chip,
++ * such as setting the baud rate. */
++ {USB_DEVICE(0x04e2, 0x1410),
++ .driver_info = IGNORE_DEVICE,
++ },
++ {USB_DEVICE(0x04e2, 0x1412),
++ .driver_info = IGNORE_DEVICE,
++ },
++ {USB_DEVICE(0x04e2, 0x1414),
++ .driver_info = IGNORE_DEVICE,
++ },
++
+ /* control interfaces without any protocol set */
+ { USB_INTERFACE_INFO(USB_CLASS_COMM, USB_CDC_SUBCLASS_ACM,
+ USB_CDC_PROTO_NONE) },
+--
+1.9.1
+
diff --git a/recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-disable-atmel_mci-mmc_pwrseq-due-to-build-fail.patch b/recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-disable-atmel_mci-mmc_pwrseq-due-to-build-fail.patch
new file mode 100644
index 0000000..3155c92
--- /dev/null
+++ b/recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-disable-atmel_mci-mmc_pwrseq-due-to-build-fail.patch
@@ -0,0 +1,30 @@
+From d75e4b5446bf26085a8db8ff8dca0f78136c9286 Mon Sep 17 00:00:00 2001
+From: Mykyta Dorokhin <mykyta.dorokhin@globallogic.com>
+Date: Fri, 1 Jan 2021 02:35:45 +0200
+Subject: [PATCH] disable atmel_mci mmc_pwrseq due to build fail
+
+---
+ drivers/mmc/host/atmel-mci.c | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/drivers/mmc/host/atmel-mci.c b/drivers/mmc/host/atmel-mci.c
+index 088803b..a750b0c 100644
+--- a/drivers/mmc/host/atmel-mci.c
++++ b/drivers/mmc/host/atmel-mci.c
+@@ -2301,7 +2301,13 @@ static int atmci_init_slot(struct atmel_mci *host,
+
+ host->slot[id] = slot;
+ mmc_regulator_get_supply(mmc);
++#if 0
++ // pwrsec is not used anyways having this line
++ // breaks building qtmel_mci as a module (only built-in)
++ // which breaks wifi reload support (modprobe atmel_mci/modprobe -r atmel_mci)
++ // on MTR devices (see wireless-conf.init)
+ mmc_pwrseq_alloc(slot->mmc);
++#endif
+ mmc_add_host(mmc);
+
+ if (gpio_is_valid(slot->detect_pin)) {
+--
+1.9.1
+
diff --git a/recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-spidev_squack.patch b/recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-spidev_squack.patch
new file mode 100644
index 0000000..09fcb15
--- /dev/null
+++ b/recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-spidev_squack.patch
@@ -0,0 +1,24 @@
+From 0a763d945e6e495c605cc8ca81df4ca6f22b3b43 Mon Sep 17 00:00:00 2001
+From: Mykyta Dorokhin <mykyta.dorokhin@globallogic.com>
+Date: Tue, 12 Jan 2021 23:27:55 +0200
+Subject: [PATCH] linux-5.4-spidev_squack.patch
+
+---
+ drivers/spi/spidev.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/drivers/spi/spidev.c b/drivers/spi/spidev.c
+index be503a0..a2b6825 100644
+--- a/drivers/spi/spidev.c
++++ b/drivers/spi/spidev.c
+@@ -678,6 +678,7 @@ static int spidev_release(struct inode *inode, struct file *filp)
+ { .compatible = "lwn,bk4" },
+ { .compatible = "dh,dhcom-board" },
+ { .compatible = "menlo,m53cpld" },
++ { .compatible = "mts,mtac" },
+ {},
+ };
+ MODULE_DEVICE_TABLE(of, spidev_dt_ids);
+--
+1.9.1
+