summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
authorMykyta Dorokhin <mykyta.dorokhin@globallogic.com>2021-02-06 23:16:04 +0200
committerMykyta Dorokhin <mykyta.dorokhin@globallogic.com>2021-02-06 23:17:01 +0200
commit7817d29df15b64fe9d8d9a4948c922d89e66a19e (patch)
tree3a6bf0d7f15e9d3b5224871677e4466f80f7b606 /recipes-kernel/linux
parent3d427056864ead89d0fd025eec5df4fdee61d21b (diff)
downloadmeta-multitech-atmel-7817d29df15b64fe9d8d9a4948c922d89e66a19e.tar.gz
meta-multitech-atmel-7817d29df15b64fe9d8d9a4948c922d89e66a19e.tar.bz2
meta-multitech-atmel-7817d29df15b64fe9d8d9a4948c922d89e66a19e.zip
linux-5.4: revert "minor kernel recipe optimization"
This reverts commit 3d427056864ead89d0fd025eec5df4fdee61d21b.
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-at91_5.4.81.bb13
1 files changed, 9 insertions, 4 deletions
diff --git a/recipes-kernel/linux/linux-at91_5.4.81.bb b/recipes-kernel/linux/linux-at91_5.4.81.bb
index 557026b..acb0272 100644
--- a/recipes-kernel/linux/linux-at91_5.4.81.bb
+++ b/recipes-kernel/linux/linux-at91_5.4.81.bb
@@ -48,19 +48,15 @@ COMMON_PATCHES = " \
"
SRC_URI_append_mtcdt = "\
- file://mts-dts/mtcdt.dts \
${COMMON_PATCHES} \
"
SRC_URI_append_mtrv1 = "\
- file://mts-dts/mtrv1.dts \
${COMMON_PATCHES} \
"
SRC_URI_append_mtcap = "\
- file://mts-dts/mtcap.dts \
${COMMON_PATCHES} \
"
SRC_URI_append_mtr = "\
- file://mts-dts/mtr.dts \
${COMMON_PATCHES} \
file://linux-5.4-fix-atmel-mci-reg-overloading.patch \
file://linux-5.4-wl12xx_enable_disable.patch \
@@ -71,6 +67,15 @@ python __anonymous () {
d.appendVar('DEPENDS', ' u-boot-mkimage-native dtc-native')
}
+copy_mts_dts_files () {
+ # Install MTS device tree files
+ cp -f ${THISDIR}/linux-at91-5.4.81/mts-dts/${MACHINE}.dts ${S}/arch/${ARCH}/boot/dts/
+}
+
+python do_unpack_append () {
+ bb.build.exec_func('copy_mts_dts_files', d)
+}
+
# Files needed to build external kernel modules.
do_shared_workdir_append() {
install -d -m 755 ${STAGING_KERNEL_BUILDDIR}/include/config