summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
authorMykyta Dorokhin <mykyta.dorokhin@globallogic.com>2021-02-06 03:08:08 +0200
committerMykyta Dorokhin <mykyta.dorokhin@globallogic.com>2021-02-06 03:10:32 +0200
commit37cf2eb3598fd2fdced4f0f9723b6a7ccaef33e2 (patch)
tree2405a19148da3152f8769507b36508dc74a72541 /recipes-kernel/linux
parenta0084c56de2ef09ef0f34dace7ee21d6747b3832 (diff)
downloadmeta-multitech-atmel-37cf2eb3598fd2fdced4f0f9723b6a7ccaef33e2.tar.gz
meta-multitech-atmel-37cf2eb3598fd2fdced4f0f9723b6a7ccaef33e2.tar.bz2
meta-multitech-atmel-37cf2eb3598fd2fdced4f0f9723b6a7ccaef33e2.zip
linux-5.4: mtr mmc: rework mmc_pwrseq_alloc fix
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-disable-atmel_mci-mmc_pwrseq-due-to-build-fail.patch30
-rw-r--r--recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-export-mmc_pwrseq_alloc.patch25
-rw-r--r--recipes-kernel/linux/linux-at91_5.4.81.bb2
3 files changed, 26 insertions, 31 deletions
diff --git a/recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-disable-atmel_mci-mmc_pwrseq-due-to-build-fail.patch b/recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-disable-atmel_mci-mmc_pwrseq-due-to-build-fail.patch
deleted file mode 100644
index 3155c92..0000000
--- a/recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-disable-atmel_mci-mmc_pwrseq-due-to-build-fail.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From d75e4b5446bf26085a8db8ff8dca0f78136c9286 Mon Sep 17 00:00:00 2001
-From: Mykyta Dorokhin <mykyta.dorokhin@globallogic.com>
-Date: Fri, 1 Jan 2021 02:35:45 +0200
-Subject: [PATCH] disable atmel_mci mmc_pwrseq due to build fail
-
----
- drivers/mmc/host/atmel-mci.c | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/drivers/mmc/host/atmel-mci.c b/drivers/mmc/host/atmel-mci.c
-index 088803b..a750b0c 100644
---- a/drivers/mmc/host/atmel-mci.c
-+++ b/drivers/mmc/host/atmel-mci.c
-@@ -2301,7 +2301,13 @@ static int atmci_init_slot(struct atmel_mci *host,
-
- host->slot[id] = slot;
- mmc_regulator_get_supply(mmc);
-+#if 0
-+ // pwrsec is not used anyways having this line
-+ // breaks building qtmel_mci as a module (only built-in)
-+ // which breaks wifi reload support (modprobe atmel_mci/modprobe -r atmel_mci)
-+ // on MTR devices (see wireless-conf.init)
- mmc_pwrseq_alloc(slot->mmc);
-+#endif
- mmc_add_host(mmc);
-
- if (gpio_is_valid(slot->detect_pin)) {
---
-1.9.1
-
diff --git a/recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-export-mmc_pwrseq_alloc.patch b/recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-export-mmc_pwrseq_alloc.patch
new file mode 100644
index 0000000..c08ac22
--- /dev/null
+++ b/recipes-kernel/linux/linux-at91-5.4.81/linux-5.4-export-mmc_pwrseq_alloc.patch
@@ -0,0 +1,25 @@
+From 9c624cc6c8e38c587ed1b78ca7b3edf82f05e9b5 Mon Sep 17 00:00:00 2001
+From: Mykyta Dorokhin <mykyta.dorokhin@globallogic.com>
+Date: Sat, 6 Feb 2021 02:27:06 +0200
+Subject: [PATCH] linux-5.4: export mmc_pwrseq_alloc. Otherwise atmel_mci as a
+ module faile to get reloaded
+
+---
+ drivers/mmc/core/pwrseq.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/drivers/mmc/core/pwrseq.c b/drivers/mmc/core/pwrseq.c
+index ef675f3..44b4caa 100644
+--- a/drivers/mmc/core/pwrseq.c
++++ b/drivers/mmc/core/pwrseq.c
+@@ -50,6 +50,7 @@ int mmc_pwrseq_alloc(struct mmc_host *host)
+
+ return 0;
+ }
++EXPORT_SYMBOL_GPL(mmc_pwrseq_alloc);
+
+ void mmc_pwrseq_pre_power_on(struct mmc_host *host)
+ {
+--
+1.9.1
+
diff --git a/recipes-kernel/linux/linux-at91_5.4.81.bb b/recipes-kernel/linux/linux-at91_5.4.81.bb
index 1086e57..4bdf729 100644
--- a/recipes-kernel/linux/linux-at91_5.4.81.bb
+++ b/recipes-kernel/linux/linux-at91_5.4.81.bb
@@ -36,7 +36,7 @@ KERNEL_MODULE_PACKAGE_SUFFIX=""
COMMON_PATCHES = " \
file://defconfig \
file://linux-5.4-at91sam9_wdt-10second-timeout.patch \
- file://linux-5.4-disable-atmel_mci-mmc_pwrseq-due-to-build-fail.patch \
+ file://linux-5.4-export-mmc_pwrseq_alloc.patch \
file://linux-5.4-spidev_squack.patch \
file://linux-5.4-add-num_accessory_ports-config-option.patch \
file://linux-5.4-cdc-acm-ignore-exar-devices.patch \