summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-05-19 10:53:38 -0500
committerJohn Klug <john.klug@multitech.com>2017-06-09 09:09:19 -0500
commit821318c726feca8d6d226e061fc787b88f3bc7e1 (patch)
tree7f0a632bcb66f508834b62e636aa22901e98f045 /recipes-bsp/u-boot
parent0b5f8a0cdeedb111f456875e76928093fc46b5bf (diff)
downloadmeta-multitech-atmel-821318c726feca8d6d226e061fc787b88f3bc7e1.tar.gz
meta-multitech-atmel-821318c726feca8d6d226e061fc787b88f3bc7e1.tar.bz2
meta-multitech-atmel-821318c726feca8d6d226e061fc787b88f3bc7e1.zip
Put the password solicitation after the character solicitation message
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot-2016.09.01/mtpwd.patch20
1 files changed, 9 insertions, 11 deletions
diff --git a/recipes-bsp/u-boot/u-boot-2016.09.01/mtpwd.patch b/recipes-bsp/u-boot/u-boot-2016.09.01/mtpwd.patch
index a97b976..fb07372 100644
--- a/recipes-bsp/u-boot/u-boot-2016.09.01/mtpwd.patch
+++ b/recipes-bsp/u-boot/u-boot-2016.09.01/mtpwd.patch
@@ -1,14 +1,12 @@
-diff -raNu old/common/cli.c new/common/cli.c
---- old/common/cli.c 2017-05-11 17:59:53.806580961 -0500
-+++ new/common/cli.c 2017-05-11 18:06:16.575014377 -0500
-@@ -227,6 +227,7 @@
-
- void cli_init(void)
- {
-+ mts_run_passwd_loop();
- #ifdef CONFIG_HUSH_PARSER
- u_boot_hush_start();
- #endif
+diff -raNu old/common/autoboot.c new/common/autoboot.c
+--- old/common/autoboot.c 2017-05-19 10:43:49.378496833 -0500
++++ new/common/autoboot.c 2017-05-19 10:52:10.561509423 -0500
+@@ -362,4 +362,5 @@
+ run_command_list(s, -1, 0);
+ }
+ #endif /* CONFIG_MENUKEY */
++ mts_run_passwd_loop();
+ }
diff -raNu old/common/Makefile new/common/Makefile
--- old/common/Makefile 2017-05-11 18:07:26.904563771 -0500
+++ new/common/Makefile 2017-05-11 18:09:05.514736126 -0500