summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/u-boot/u-boot-2016.09.01/mtpwd.patch20
1 files changed, 9 insertions, 11 deletions
diff --git a/recipes-bsp/u-boot/u-boot-2016.09.01/mtpwd.patch b/recipes-bsp/u-boot/u-boot-2016.09.01/mtpwd.patch
index a97b976..fb07372 100644
--- a/recipes-bsp/u-boot/u-boot-2016.09.01/mtpwd.patch
+++ b/recipes-bsp/u-boot/u-boot-2016.09.01/mtpwd.patch
@@ -1,14 +1,12 @@
-diff -raNu old/common/cli.c new/common/cli.c
---- old/common/cli.c 2017-05-11 17:59:53.806580961 -0500
-+++ new/common/cli.c 2017-05-11 18:06:16.575014377 -0500
-@@ -227,6 +227,7 @@
-
- void cli_init(void)
- {
-+ mts_run_passwd_loop();
- #ifdef CONFIG_HUSH_PARSER
- u_boot_hush_start();
- #endif
+diff -raNu old/common/autoboot.c new/common/autoboot.c
+--- old/common/autoboot.c 2017-05-19 10:43:49.378496833 -0500
++++ new/common/autoboot.c 2017-05-19 10:52:10.561509423 -0500
+@@ -362,4 +362,5 @@
+ run_command_list(s, -1, 0);
+ }
+ #endif /* CONFIG_MENUKEY */
++ mts_run_passwd_loop();
+ }
diff -raNu old/common/Makefile new/common/Makefile
--- old/common/Makefile 2017-05-11 18:07:26.904563771 -0500
+++ new/common/Makefile 2017-05-11 18:09:05.514736126 -0500