summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2023-01-03 13:35:14 -0600
committerJohn Klug <john.klug@multitech.com>2023-01-10 16:42:56 -0600
commitb17a74fb0f45c268259ba53b424004a134848d1e (patch)
tree33c63a27b5838defc8114ed89a0935ceeed50551
parent52f875e9431b42375f1545b15a4ea75808f35fc3 (diff)
downloadmeta-multitech-atmel-b17a74fb0f45c268259ba53b424004a134848d1e.tar.gz
meta-multitech-atmel-b17a74fb0f45c268259ba53b424004a134848d1e.tar.bz2
meta-multitech-atmel-b17a74fb0f45c268259ba53b424004a134848d1e.zip
New concurrent mode patch from SiLabs and bump handle_card_ready patch
-rw-r--r--recipes-kernel/rsi-91x/files/0001_concurrent_compilation_fix.patch26
-rw-r--r--recipes-kernel/rsi-91x/files/0002-fix-rsi_handle_card_ready-card-ready.patch (renamed from recipes-kernel/rsi-91x/files/0001-fix-rsi_handle_card_ready-card-ready.patch)0
-rw-r--r--recipes-kernel/rsi-91x/rsi-91x_2.5.1.bb3
-rw-r--r--recipes-kernel/rsi-91x/rsi-bt91x_2.5.1.bb4
4 files changed, 31 insertions, 2 deletions
diff --git a/recipes-kernel/rsi-91x/files/0001_concurrent_compilation_fix.patch b/recipes-kernel/rsi-91x/files/0001_concurrent_compilation_fix.patch
new file mode 100644
index 0000000..5615c78
--- /dev/null
+++ b/recipes-kernel/rsi-91x/files/0001_concurrent_compilation_fix.patch
@@ -0,0 +1,26 @@
+rs9116 rsi-91x linux driver fails to compile in Station + AP mode
+
+Silicon labs patch from case 00297277
+
+https://community.silabs.com/5008Y000024DTst
+==================================================
+diff --git a/rsi_91x_per.c b/rsi_91x_per.c
+index 031f3fc..d57b8fa 100644
+--- a/rsi_91x_per.c
++++ b/rsi_91x_per.c
+@@ -145,7 +145,6 @@ int rsi_send_rx_stats_cmd(struct rsi_hw *adapter, struct nlmsghdr *nlh)
+ int status = 0;
+ #endif
+
+- if (common->driver_mode == E2E_MODE) {
+ #ifndef CONFIG_STA_PLUS_AP
+ struct ieee80211_vif *vif = adapter->vifs[0];
+ bool assoc = vif && vif->bss_conf.assoc;
+@@ -154,6 +153,7 @@ int rsi_send_rx_stats_cmd(struct rsi_hw *adapter, struct nlmsghdr *nlh)
+ bool assoc = sta_vif && sta_vif->bss_conf.assoc;
+ #endif
+
++ if (common->driver_mode == E2E_MODE) {
+ if (!assoc && adapter->ps_state == PS_ENABLED)
+ rsi_disable_ps(adapter);
+ goto SEND_STATS_FRAME;
diff --git a/recipes-kernel/rsi-91x/files/0001-fix-rsi_handle_card_ready-card-ready.patch b/recipes-kernel/rsi-91x/files/0002-fix-rsi_handle_card_ready-card-ready.patch
index aeed2c9..aeed2c9 100644
--- a/recipes-kernel/rsi-91x/files/0001-fix-rsi_handle_card_ready-card-ready.patch
+++ b/recipes-kernel/rsi-91x/files/0002-fix-rsi_handle_card_ready-card-ready.patch
diff --git a/recipes-kernel/rsi-91x/rsi-91x_2.5.1.bb b/recipes-kernel/rsi-91x/rsi-91x_2.5.1.bb
index 96646df..24e79a1 100644
--- a/recipes-kernel/rsi-91x/rsi-91x_2.5.1.bb
+++ b/recipes-kernel/rsi-91x/rsi-91x_2.5.1.bb
@@ -8,7 +8,8 @@ inherit module
SRCREV = "v${PV}"
SRC_URI = "git://github.com/SiliconLabs/RS911X-nLink-OSD.git;protocol=https \
file://rsi-91x-config.patch;striplevel=2 \
- file://0001-fix-rsi_handle_card_ready-card-ready.patch \
+ file://0001_concurrent_compilation_fix.patch \
+ file://0002-fix-rsi_handle_card_ready-card-ready.patch \
"
S = "${WORKDIR}/git/rsi"
diff --git a/recipes-kernel/rsi-91x/rsi-bt91x_2.5.1.bb b/recipes-kernel/rsi-91x/rsi-bt91x_2.5.1.bb
index 044ae68..d2cdaa9 100644
--- a/recipes-kernel/rsi-91x/rsi-bt91x_2.5.1.bb
+++ b/recipes-kernel/rsi-91x/rsi-bt91x_2.5.1.bb
@@ -1,6 +1,6 @@
LICENSE = "GPLv2+|BSD"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-PR = "r1"
+PR = "r2"
PKGR = "${PR}${KERNEL_MODULE_PACKAGE_SUFFIX}${EXTENDPRAUTO}"
RPROVIDES_kernel-module-rsi-bt91x = "rsi-bt91x"
inherit module
@@ -8,6 +8,8 @@ inherit module
SRCREV = "v${PV}"
SRC_URI = "git://github.com/SiliconLabs/RS911X-nLink-OSD.git;protocol=https \
file://rsi-bt91x-config.patch;striplevel=2 \
+ file://0001_concurrent_compilation_fix.patch \
+ file://0002-fix-rsi_handle_card_ready-card-ready.patch \
"
S = "${WORKDIR}/git/rsi"