summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerhii Voloshynov <serhii.voloshynov@globallogic.com>2022-12-29 11:23:00 +0200
committerJohn Klug <john.klug@multitech.com>2023-01-10 16:42:56 -0600
commit52f875e9431b42375f1545b15a4ea75808f35fc3 (patch)
tree553626a4b3b84ea97de06cc95e41a6e3dbaad9c1
parent4dc27623470b61aeb0845d74c0dc073ffff485b7 (diff)
downloadmeta-multitech-atmel-52f875e9431b42375f1545b15a4ea75808f35fc3.tar.gz
meta-multitech-atmel-52f875e9431b42375f1545b15a4ea75808f35fc3.tar.bz2
meta-multitech-atmel-52f875e9431b42375f1545b15a4ea75808f35fc3.zip
During the new driver testing we found the following issue:
when rsi_91x module is loaded, the message appears: -rsi_91x: ***** Firmware Loading successful ***** -rsi_handle_card_ready: card ready indication in invalid state 0. After that, there are no wifi interfaces, although all related modules are loaded. The rootcause of the issue is the late initialisation of common->fsm_state variable
-rw-r--r--recipes-kernel/rsi-91x/files/0001-fix-rsi_handle_card_ready-card-ready.patch36
-rw-r--r--recipes-kernel/rsi-91x/rsi-91x_2.5.1.bb3
2 files changed, 38 insertions, 1 deletions
diff --git a/recipes-kernel/rsi-91x/files/0001-fix-rsi_handle_card_ready-card-ready.patch b/recipes-kernel/rsi-91x/files/0001-fix-rsi_handle_card_ready-card-ready.patch
new file mode 100644
index 0000000..aeed2c9
--- /dev/null
+++ b/recipes-kernel/rsi-91x/files/0001-fix-rsi_handle_card_ready-card-ready.patch
@@ -0,0 +1,36 @@
+From 822df5990784ba914a1622e81b2b9ea4e079d5ea Mon Sep 17 00:00:00 2001
+From: Serhii Voloshynov <serhii.voloshynov@globallogic.com>
+Date: Thu, 29 Dec 2022 09:36:07 +0200
+Subject: [PATCH] fix 'rsi_handle_card_ready: card ready indication in invalid
+ state 0.' issue
+
+---
+rsi_91x_hal.c | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/rsi_91x_hal.c b/rsi_91x_hal.c
+index c3d5823..e3eeec6 100644
+--- a/rsi_91x_hal.c
++++ b/rsi_91x_hal.c
+@@ -1703,6 +1703,9 @@ int rsi_hal_device_init(struct rsi_hw *adapter)
+
+ rsi_dbg(ERR_ZONE, "%s: oper_mode = %d, coex_mode = %d\n", __func__, common->oper_mode, common->coex_mode);
+
++ adapter->common_hal_fsm = COMMAN_HAL_WAIT_FOR_CARD_READY;
++ common->fsm_state = FSM_CARD_NOT_READY;
++
+ switch (adapter->device_model) {
+ case RSI_DEV_9113:
+ case RSI_DEV_9116:
+@@ -1714,8 +1717,6 @@ int rsi_hal_device_init(struct rsi_hw *adapter)
+ default:
+ return -EINVAL;
+ }
+- adapter->common_hal_fsm = COMMAN_HAL_WAIT_FOR_CARD_READY;
+- common->fsm_state = FSM_CARD_NOT_READY;
+
+ #if defined(CONFIG_RSI_BT_ALONE) || defined(CONFIG_RSI_COEX_MODE)
+ adapter->priv->bt_fsm_state = BT_DEVICE_NOT_READY;
+--
+2.25.1
+
diff --git a/recipes-kernel/rsi-91x/rsi-91x_2.5.1.bb b/recipes-kernel/rsi-91x/rsi-91x_2.5.1.bb
index 872e248..96646df 100644
--- a/recipes-kernel/rsi-91x/rsi-91x_2.5.1.bb
+++ b/recipes-kernel/rsi-91x/rsi-91x_2.5.1.bb
@@ -1,6 +1,6 @@
LICENSE = "GPLv2+|BSD"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-PR = "r1"
+PR = "r2"
PKGR = "${PR}${KERNEL_MODULE_PACKAGE_SUFFIX}${EXTENDPRAUTO}"
RPROVIDES_kernel-module-rsi-91x = "rsi-91x"
inherit module
@@ -8,6 +8,7 @@ inherit module
SRCREV = "v${PV}"
SRC_URI = "git://github.com/SiliconLabs/RS911X-nLink-OSD.git;protocol=https \
file://rsi-91x-config.patch;striplevel=2 \
+ file://0001-fix-rsi_handle_card_ready-card-ready.patch \
"
S = "${WORKDIR}/git/rsi"