summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2023-01-05 17:53:37 -0600
committerJohn Klug <john.klug@multitech.com>2023-01-10 16:42:56 -0600
commita2a00ca0f5c8a10ce2dfe2dac8c7ef71c8074662 (patch)
tree42269d5894ee107a7bfd3751367227195e8f06b3
parentb17a74fb0f45c268259ba53b424004a134848d1e (diff)
downloadmeta-multitech-atmel-a2a00ca0f5c8a10ce2dfe2dac8c7ef71c8074662.tar.gz
meta-multitech-atmel-a2a00ca0f5c8a10ce2dfe2dac8c7ef71c8074662.tar.bz2
meta-multitech-atmel-a2a00ca0f5c8a10ce2dfe2dac8c7ef71c8074662.zip
Add examples for hostapd/wpa_supplicant
-rw-r--r--recipes-kernel/rsi-91x/files/PD.patch6
-rw-r--r--recipes-kernel/rsi-91x/rp-net-examples_1.6.5.bb25
-rw-r--r--recipes-kernel/rsi-91x/rs9113-fw_1.6.5.bb1
3 files changed, 32 insertions, 0 deletions
diff --git a/recipes-kernel/rsi-91x/files/PD.patch b/recipes-kernel/rsi-91x/files/PD.patch
new file mode 100644
index 0000000..c565ffa
--- /dev/null
+++ b/recipes-kernel/rsi-91x/files/PD.patch
@@ -0,0 +1,6 @@
+Index: rp-net-examples-1.6.5/LICENSE
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ rp-net-examples-1.6.5/LICENSE 1970-01-01 00:00:00.000000000 +0000
+@@ -0,0 +1 @@
++Public Domain
diff --git a/recipes-kernel/rsi-91x/rp-net-examples_1.6.5.bb b/recipes-kernel/rsi-91x/rp-net-examples_1.6.5.bb
new file mode 100644
index 0000000..aea0c5c
--- /dev/null
+++ b/recipes-kernel/rsi-91x/rp-net-examples_1.6.5.bb
@@ -0,0 +1,25 @@
+# Example configuration files for wifi
+
+LICENSE = "PD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7bf87fc37976e93ec66ad84fac58c098"
+
+PR = "r1"
+
+inherit allarch
+SRCREV = "v${PV}"
+
+SRC_URI = " \
+ https://www.multitech.net/mlinux/sources/${BPN}-${PV}.tar.gz \
+ file://PD.patch \
+"
+SRC_URI[sha256sum] = "bfe3ca64b50a5f0426b2e11980543cfea5e4ddca30dfd9d8599d00770745014b"
+
+FILES_${PN} = "/opt"
+PACKAGES = "${BPN}"
+
+do_install() {
+ cd ${WORKDIR}
+ pwd
+ install -m 0755 -d ${D}/opt/rs9113
+ install ${S}/*.conf ${D}/opt/rs9113
+}
diff --git a/recipes-kernel/rsi-91x/rs9113-fw_1.6.5.bb b/recipes-kernel/rsi-91x/rs9113-fw_1.6.5.bb
index c3513c4..9b250ec 100644
--- a/recipes-kernel/rsi-91x/rs9113-fw_1.6.5.bb
+++ b/recipes-kernel/rsi-91x/rs9113-fw_1.6.5.bb
@@ -10,6 +10,7 @@ SRC_URI = "https://www.multitech.net/mlinux/sources/rs9113-fw-1.6.5.tar.gz"
SRC_URI[sha256sum] = "5d11e5859a9540364fb9b11948a4a70ea77bbe5cda9471f0db40458b691c252a"
FILES_${PN} = "${nonarch_base_libdir}"
+PACKAGES = "${BPN}"
do_install() {
cd ${WORKDIR}