summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2022-05-17 09:30:12 -0500
committerJohn Klug <john.klug@multitech.com>2022-11-16 18:03:56 -0600
commit98ef7f7f13d49f3660218ff2cfb310a91cab814c (patch)
tree7025a51fedbee1c25996d3140451eb4c707fdcd5
parent0038f22031027106d606d855db2aa4669ae57e15 (diff)
downloadmeta-multitech-atmel-98ef7f7f13d49f3660218ff2cfb310a91cab814c.tar.gz
meta-multitech-atmel-98ef7f7f13d49f3660218ff2cfb310a91cab814c.tar.bz2
meta-multitech-atmel-98ef7f7f13d49f3660218ff2cfb310a91cab814c.zip
Create an mLinux with SD card Bootstrap and U-BOot with USB
-rw-r--r--recipes-bsp/at91bootstrap/at91bootstrap-3.8.12/README-SD44
-rw-r--r--recipes-bsp/at91bootstrap/at91bootstrap-3.8.12/defconfig30
-rw-r--r--recipes-bsp/u-boot/u-boot-2016.09.01/configfactory.patch647
-rw-r--r--recipes-bsp/u-boot/u-boot-2016.09.01/mtcdt_flush_console_autoboot.patch14
-rw-r--r--recipes-bsp/u-boot/u-boot.inc6
-rw-r--r--recipes-bsp/u-boot/u-boot_2016.09.01.bb10
6 files changed, 727 insertions, 24 deletions
diff --git a/recipes-bsp/at91bootstrap/at91bootstrap-3.8.12/README-SD b/recipes-bsp/at91bootstrap/at91bootstrap-3.8.12/README-SD
new file mode 100644
index 0000000..060f3cb
--- /dev/null
+++ b/recipes-bsp/at91bootstrap/at91bootstrap-3.8.12/README-SD
@@ -0,0 +1,44 @@
+This procedure from (on May 16, 2022):
+
+https://www.linux4sam.org/bin/view/Linux4SAM/SDCardBootNotice
+
+
+For SD card boot, there are several files in the first partition:
+
+BOOT.BIN (at91bootstrap)
+u-boot.bin (U-Boot)
+uImage (kernel)
+
+
+To make the SD card as root on a Linux PC:
+
+dd if=/dev/zero of=/dev/sdx bs=10M count=1
+
+fdisk /dev/sdx
+
+Command (m for help): p
+Disk /dev/sdx: 2002 MB, 2002780160 bytes
+11 heads, 10 sectors/track, 35560 cylinders
+Units = cylinders of 110 * 512 = 56320 bytes
+Sector size (logical/physical): 512 bytes / 512 bytes
+I/O size (minimum/optimal): 512 bytes / 512 bytes
+Disk identifier: 0x00000000
+
+ Device Boot Start End Blocks Id System
+
+Command (m for help): n
+Command action
+ e extended
+ p primary partition (1-4)
+p
+Partition number (1-4): 1
+First cylinder (1-35560, default 1):
+Using default value 1
+Last cylinder, +cylinders or +size{K,M,G} (1-35560, default 35560): +64M
+
+Command (m for help): t
+Selected partition 1
+Hex code (type L to list codes): 6
+Changed system type of partition 1 to 6 (FAT16)
+
+
diff --git a/recipes-bsp/at91bootstrap/at91bootstrap-3.8.12/defconfig b/recipes-bsp/at91bootstrap/at91bootstrap-3.8.12/defconfig
index ba0a902..32f9575 100644
--- a/recipes-bsp/at91bootstrap/at91bootstrap-3.8.12/defconfig
+++ b/recipes-bsp/at91bootstrap/at91bootstrap-3.8.12/defconfig
@@ -19,9 +19,10 @@ CONFIG_AT91SAM9X5EK=y
# CONFIG_SAMA5D3X_CMP is not set
# CONFIG_SAMA5D4EK is not set
# CONFIG_SAMA5D4_XPLAINED is not set
-# CONFIG_SAMA5D2_PTC is not set
+# CONFIG_SAMA5D2_PTC_EK is not set
# CONFIG_SAMA5D2_XPLAINED is not set
# CONFIG_SAMA5D27_SOM1_EK is not set
+# CONFIG_SAMA5D2_LPDDR2SIP_VB is not set
# CONFIG_VINCO is not set
# CONFIG_AT91SAM9X5_ARIA is not set
# CONFIG_AT91SAM9X5_ARIETTA is not set
@@ -29,9 +30,12 @@ CONFIG_AT91SAM9X5EK=y
# CONFIG_SAMA5D2_ROADRUNNER is not set
# CONFIG_CORE9G25 is not set
# CONFIG_SAMA5D3_LINEA is not set
+# CONFIG_PICOSAM9G45 is not set
+# CONFIG_SAMA5D3_STEPHAN is not set
CONFIG_BOARDNAME="at91sam9x5ek"
AT91SAM9X5=y
CONFIG_MACH_TYPE="3373"
+# CONFIG_OVERRIDE_MACH_TYPE is not set
CONFIG_LINK_ADDR="0x300000"
CONFIG_TOP_OF_MEMORY="0x308000"
CONFIG_CRYSTAL_12_000MHZ=y
@@ -108,6 +112,7 @@ CPU_HAS_SPI1=y
# CPU_HAS_QSPI1_IOSET1 is not set
# CPU_HAS_QSPI1_IOSET2 is not set
# CPU_HAS_QSPI1_IOSET3 is not set
+# BOARD_HAS_2_BANKS is not set
CPU_HAS_PIO3=y
# CPU_HAS_L2CC is not set
CPU_HAS_PMECC=y
@@ -119,7 +124,7 @@ CONFIG_HAS_HW_INFO=y
# CONFIG_TWI3 is not set
# CONFIG_MACB is not set
# CONFIG_AES is not set
-CONFIG_LOAD_HW_INFO=y
+# CONFIG_LOAD_HW_INFO is not set
CPU_HAS_TWI0=y
CPU_HAS_TWI1=y
CPU_HAS_TWI2=y
@@ -156,14 +161,19 @@ CONFIG_DDR2=y
# CONFIG_SAMA5D2_LPDDR2 is not set
# CONFIG_DATAFLASH is not set
# CONFIG_FLASH is not set
-CONFIG_NANDFLASH=y
-# CONFIG_SDCARD is not set
-CONFIG_MEMORY="nandflash"
-ALLOW_BOOT_FROM_DATAFLASH_CS0=y
+# CONFIG_NANDFLASH is not set
+CONFIG_SDCARD=y
+CONFIG_MEMORY="sdcard"
#
-# NAND flash configuration
+# SD Card Configuration
#
+CONFIG_AT91_MCI=y
+CONFIG_AT91_MCI0=y
+# CONFIG_AT91_MCI1 is not set
+# CONFIG_AT91_MCI2 is not set
+CONFIG_FATFS=y
+ALLOW_BOOT_FROM_DATAFLASH_CS0=y
# CONFIG_ENABLE_SW_ECC is not set
CONFIG_USE_PMECC=y
# CONFIG_ON_DIE_ECC is not set
@@ -184,7 +194,7 @@ CONFIG_ONFI_DETECT_SUPPORT=y
CONFIG_USE_ON_DIE_ECC_SUPPORT=y
# ALLOW_NANDFLASH_RECOVERY is not set
CONFIG_BOOTSTRAP_MAXSIZE="23000"
-CONFIG_PROJECT="nandflash"
+CONFIG_PROJECT="sdcard"
CONFIG_LOAD_UBOOT=y
# CONFIG_LOAD_LINUX is not set
# CONFIG_LOAD_ANDROID is not set
@@ -200,9 +210,9 @@ CONFIG_JUMP_ADDR="0x2EF00000"
CONFIG_IMG_SIZE="0x00080000"
CONFIG_IMAGE_NAME="u-boot.bin"
CONFIG_DEBUG=y
-CONFIG_DEBUG_INFO=y
+# CONFIG_DEBUG_INFO is not set
# CONFIG_DEBUG_LOUD is not set
-CONFIG_DEBUG_VERY_LOUD=y is not set
+CONFIG_DEBUG_VERY_LOUD=y
CONFIG_THUMB=y
# CONFIG_DISABLE_WATCHDOG is not set
diff --git a/recipes-bsp/u-boot/u-boot-2016.09.01/configfactory.patch b/recipes-bsp/u-boot/u-boot-2016.09.01/configfactory.patch
new file mode 100644
index 0000000..6a32476
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-2016.09.01/configfactory.patch
@@ -0,0 +1,647 @@
+diff -Naru orig/configs/at91sam9x5ek_nandflash_defconfig new/configs/at91sam9x5ek_nandflash_defconfig
+--- orig/configs/at91sam9x5ek_nandflash_defconfig 2022-05-11 17:23:26.522032483 -0500
++++ new/configs/at91sam9x5ek_nandflash_defconfig 2022-05-12 12:23:20.268431980 -0500
+@@ -1,25 +1,639 @@
++#
++# Automatically generated file; DO NOT EDIT.
++# U-Boot 2016.09.01 Configuration
++#
++CONFIG_CREATE_ARCH_SYMLINK=y
++# CONFIG_ARC is not set
+ CONFIG_ARM=y
++# CONFIG_AVR32 is not set
++# CONFIG_BLACKFIN is not set
++# CONFIG_M68K is not set
++# CONFIG_MICROBLAZE is not set
++# CONFIG_MIPS is not set
++# CONFIG_NDS32 is not set
++# CONFIG_NIOS2 is not set
++# CONFIG_OPENRISC is not set
++# CONFIG_PPC is not set
++# CONFIG_SANDBOX is not set
++# CONFIG_SH is not set
++# CONFIG_SPARC is not set
++# CONFIG_X86 is not set
++# CONFIG_XTENSA is not set
++CONFIG_SYS_ARCH="arm"
++CONFIG_SYS_CPU="arm926ejs"
++CONFIG_SYS_SOC="at91"
++CONFIG_SYS_VENDOR="atmel"
++CONFIG_SYS_BOARD="at91sam9x5ek"
++CONFIG_SYS_CONFIG_NAME="at91sam9x5ek"
++
++#
++# ARM architecture
++#
++CONFIG_CPU_ARM926EJS=y
++CONFIG_SYS_ARM_ARCH=5
++CONFIG_SYS_CACHE_SHIFT_5=y
++CONFIG_SYS_CACHELINE_SIZE=32
++# CONFIG_SEMIHOSTING is not set
++# CONFIG_SYS_L2CACHE_OFF is not set
++# CONFIG_ENABLE_ARM_SOC_BOOT0_HOOK is not set
+ CONFIG_ARCH_AT91=y
++# CONFIG_TARGET_EDB93XX is not set
++# CONFIG_TARGET_VCMA9 is not set
++# CONFIG_TARGET_SMDK2410 is not set
++# CONFIG_TARGET_ASPENITE is not set
++# CONFIG_TARGET_GPLUGD is not set
++# CONFIG_ARCH_DAVINCI is not set
++# CONFIG_KIRKWOOD is not set
++# CONFIG_ARCH_MVEBU is not set
++# CONFIG_TARGET_DEVKIT3250 is not set
++# CONFIG_TARGET_WORK_92105 is not set
++# CONFIG_TARGET_MX25PDK is not set
++# CONFIG_TARGET_ZMX25 is not set
++# CONFIG_TARGET_APF27 is not set
++# CONFIG_TARGET_APX4DEVKIT is not set
++# CONFIG_TARGET_XFI3 is not set
++# CONFIG_TARGET_M28EVK is not set
++# CONFIG_TARGET_MX23EVK is not set
++# CONFIG_TARGET_MX28EVK is not set
++# CONFIG_TARGET_MX23_OLINUXINO is not set
++# CONFIG_TARGET_BG0900 is not set
++# CONFIG_TARGET_SANSA_FUZE_PLUS is not set
++# CONFIG_TARGET_SC_SPS_1 is not set
++# CONFIG_ORION5X is not set
++# CONFIG_TARGET_SPEAR300 is not set
++# CONFIG_TARGET_SPEAR310 is not set
++# CONFIG_TARGET_SPEAR320 is not set
++# CONFIG_TARGET_SPEAR600 is not set
++# CONFIG_TARGET_STV0991 is not set
++# CONFIG_TARGET_X600 is not set
++# CONFIG_TARGET_IMX31_PHYCORE is not set
++# CONFIG_TARGET_MX31ADS is not set
++# CONFIG_TARGET_MX31PDK is not set
++# CONFIG_TARGET_WOODBURN is not set
++# CONFIG_TARGET_WOODBURN_SD is not set
++# CONFIG_TARGET_FLEA3 is not set
++# CONFIG_TARGET_MX35PDK is not set
++# CONFIG_ARCH_BCM283X is not set
++# CONFIG_TARGET_VEXPRESS_CA15_TC2 is not set
++# CONFIG_TARGET_VEXPRESS_CA5X2 is not set
++# CONFIG_TARGET_VEXPRESS_CA9X4 is not set
++# CONFIG_TARGET_BRXRE1 is not set
++# CONFIG_TARGET_BRPPT1 is not set
++# CONFIG_TARGET_CM_T335 is not set
++# CONFIG_TARGET_PEPPER is not set
++# CONFIG_TARGET_AM335X_IGEP0033 is not set
++# CONFIG_TARGET_PCM051 is not set
++# CONFIG_TARGET_DRACO is not set
++# CONFIG_TARGET_THUBAN is not set
++# CONFIG_TARGET_RASTABAN is not set
++# CONFIG_TARGET_ETAMIN is not set
++# CONFIG_TARGET_PXM2 is not set
++# CONFIG_TARGET_RUT is not set
++# CONFIG_TARGET_PENGWYN is not set
++# CONFIG_TARGET_AM335X_BALTOS is not set
++# CONFIG_TARGET_AM335X_EVM is not set
++# CONFIG_TARGET_AM335X_SHC is not set
++# CONFIG_TARGET_AM335X_SL50 is not set
++# CONFIG_TARGET_BAV335X is not set
++# CONFIG_TARGET_TI814X_EVM is not set
++# CONFIG_TARGET_TI816X_EVM is not set
++# CONFIG_TARGET_BCM23550_W1D is not set
++# CONFIG_TARGET_BCM28155_AP is not set
++# CONFIG_TARGET_BCMCYGNUS is not set
++# CONFIG_TARGET_BCMNSP is not set
++# CONFIG_ARCH_EXYNOS is not set
++# CONFIG_ARCH_S5PC1XX is not set
++# CONFIG_ARCH_HIGHBANK is not set
++# CONFIG_ARCH_INTEGRATOR is not set
++# CONFIG_ARCH_KEYSTONE is not set
++# CONFIG_ARCH_MESON is not set
++# CONFIG_ARCH_MX7 is not set
++# CONFIG_ARCH_MX6 is not set
++# CONFIG_ARCH_MX5 is not set
++# CONFIG_TARGET_M53EVK is not set
++# CONFIG_TARGET_MX51EVK is not set
++# CONFIG_TARGET_MX53ARD is not set
++# CONFIG_TARGET_MX53EVK is not set
++# CONFIG_TARGET_MX53LOCO is not set
++# CONFIG_TARGET_MX53SMD is not set
++# CONFIG_OMAP34XX is not set
++# CONFIG_OMAP44XX is not set
++# CONFIG_OMAP54XX is not set
++# CONFIG_AM43XX is not set
++# CONFIG_ARCH_RMOBILE is not set
++# CONFIG_TARGET_S32V234EVB is not set
++# CONFIG_ARCH_SNAPDRAGON is not set
++# CONFIG_ARCH_SOCFPGA is not set
++# CONFIG_TARGET_CM_T43 is not set
++# CONFIG_ARCH_SUNXI is not set
++# CONFIG_TARGET_TS4800 is not set
++# CONFIG_TARGET_VF610TWR is not set
++# CONFIG_TARGET_COLIBRI_VF is not set
++# CONFIG_TARGET_PCM052 is not set
++# CONFIG_ARCH_ZYNQ is not set
++# CONFIG_ARCH_ZYNQMP is not set
++# CONFIG_TEGRA is not set
++# CONFIG_TARGET_VEXPRESS64_AEMV8A is not set
++# CONFIG_TARGET_VEXPRESS64_BASE_FVP is not set
++# CONFIG_TARGET_VEXPRESS64_BASE_FVP_DRAM is not set
++# CONFIG_TARGET_VEXPRESS64_JUNO is not set
++# CONFIG_TARGET_LS2080A_EMU is not set
++# CONFIG_TARGET_LS2080A_SIMU is not set
++# CONFIG_TARGET_LS2080AQDS is not set
++# CONFIG_TARGET_LS2080ARDB is not set
++# CONFIG_TARGET_HIKEY is not set
++# CONFIG_TARGET_LS1012AQDS is not set
++# CONFIG_TARGET_LS1012ARDB is not set
++# CONFIG_TARGET_LS1012AFRDM is not set
++# CONFIG_TARGET_LS1021AQDS is not set
++# CONFIG_TARGET_LS1021ATWR is not set
++# CONFIG_TARGET_LS1043AQDS is not set
++# CONFIG_TARGET_LS1043ARDB is not set
++# CONFIG_TARGET_H2200 is not set
++# CONFIG_TARGET_ZIPITZ2 is not set
++# CONFIG_TARGET_COLIBRI_PXA270 is not set
++# CONFIG_ARCH_UNIPHIER is not set
++# CONFIG_STM32 is not set
++# CONFIG_ARCH_ROCKCHIP is not set
++# CONFIG_TARGET_THUNDERX_88XX is not set
++# CONFIG_TARGET_AT91RM9200EK is not set
++# CONFIG_TARGET_AT91SAM9260EK is not set
++# CONFIG_TARGET_ETHERNUT5 is not set
++# CONFIG_TARGET_SNAPPER9260 is not set
++# CONFIG_TARGET_GURNARD is not set
++# CONFIG_TARGET_AT91SAM9261EK is not set
++# CONFIG_TARGET_PM9261 is not set
++# CONFIG_TARGET_AT91SAM9263EK is not set
++# CONFIG_TARGET_USB_A9263 is not set
++# CONFIG_TARGET_PM9263 is not set
++# CONFIG_TARGET_AT91SAM9M10G45EK is not set
++# CONFIG_TARGET_PM9G45 is not set
++# CONFIG_TARGET_PICOSAM9G45 is not set
++# CONFIG_TARGET_AT91SAM9N12EK is not set
++# CONFIG_TARGET_AT91SAM9RLEK is not set
+ CONFIG_TARGET_AT91SAM9X5EK=y
+-CONFIG_SPL=y
++# CONFIG_TARGET_SAMA5D2_PTC is not set
++# CONFIG_TARGET_SAMA5D2_XPLAINED is not set
++# CONFIG_TARGET_SAMA5D3_XPLAINED is not set
++# CONFIG_TARGET_SAMA5D3XEK is not set
++# CONFIG_TARGET_SAMA5D4_XPLAINED is not set
++# CONFIG_TARGET_SAMA5D4EK is not set
++# CONFIG_TARGET_MA5D4EVK is not set
++# CONFIG_TARGET_MEESC is not set
++# CONFIG_TARGET_CORVUS is not set
++# CONFIG_TARGET_TAURUS is not set
++# CONFIG_TARGET_SMARTWEB is not set
++# CONFIG_TARGET_VINCO is not set
++
++#
++# ARM debug
++#
++# CONFIG_DEBUG_LL is not set
++
++#
++# General setup
++#
++CONFIG_LOCALVERSION=""
++CONFIG_LOCALVERSION_AUTO=y
++CONFIG_CC_OPTIMIZE_FOR_SIZE=y
++# CONFIG_DISTRO_DEFAULTS is not set
++# CONFIG_SYS_MALLOC_F is not set
++CONFIG_EXPERT=y
++CONFIG_SYS_MALLOC_CLEAR_ON_INIT=y
++# CONFIG_TOOLS_DEBUG is not set
++# CONFIG_PHYS_64BIT is not set
++
++#
++# Boot images
++#
++CONFIG_SUPPORT_SPL=y
++# CONFIG_SPL is not set
++# CONFIG_FIT is not set
++# CONFIG_OF_BOARD_SETUP is not set
++# CONFIG_OF_SYSTEM_SETUP is not set
++# CONFIG_OF_STDOUT_VIA_ALIAS is not set
+ CONFIG_SYS_EXTRA_OPTIONS="AT91SAM9X5,SYS_USE_NANDFLASH"
+-CONFIG_BOOTDELAY=3
++CONFIG_ARCH_FIXUP_FDT=y
++
++#
++# Boot timing
++#
++# CONFIG_BOOTSTAGE is not set
++CONFIG_BOOTSTAGE_USER_COUNT=20
++CONFIG_BOOTSTAGE_STASH_ADDR=0
++CONFIG_BOOTSTAGE_STASH_SIZE=4096
++
++#
++# Boot media
++#
++# CONFIG_NAND_BOOT is not set
++# CONFIG_ONENAND_BOOT is not set
++# CONFIG_QSPI_BOOT is not set
++# CONFIG_SATA_BOOT is not set
++# CONFIG_SD_BOOT is not set
++# CONFIG_SPI_BOOT is not set
++CONFIG_BOOTDELAY=0
++# CONFIG_CONSOLE_RECORD is not set
++# CONFIG_SYS_NO_FLASH is not set
++# CONFIG_VERSION_VARIABLE is not set
++# CONFIG_SILENT_CONSOLE is not set
++
++#
++# Command line interface
++#
++CONFIG_CMDLINE=y
+ CONFIG_HUSH_PARSER=y
+ CONFIG_SYS_PROMPT="U-Boot> "
++
++#
++# Autoboot options
++#
++CONFIG_AUTOBOOT=y
++# CONFIG_AUTOBOOT_KEYED is not set
++
++#
++# FASTBOOT
++#
++# CONFIG_FASTBOOT is not set
++
++#
++# Commands
++#
++
++#
++# Info commands
++#
++CONFIG_CMD_BDI=y
++CONFIG_CMD_CONSOLE=y
++# CONFIG_CMD_CPU is not set
++# CONFIG_CMD_LICENSE is not set
++
++#
++# Boot commands
++#
++CONFIG_CMD_BOOTD=y
++CONFIG_CMD_BOOTM=y
+ CONFIG_CMD_BOOTZ=y
++CONFIG_CMD_BOOTEFI=y
++CONFIG_CMD_ELF=y
++CONFIG_CMD_FDT=y
++CONFIG_CMD_GO=y
++CONFIG_CMD_RUN=y
+ # CONFIG_CMD_IMI is not set
+ # CONFIG_CMD_IMLS is not set
++CONFIG_CMD_XIMG=y
++
++#
++# Environment commands
++#
++# CONFIG_CMD_ASKENV is not set
++CONFIG_CMD_EXPORTENV=y
++CONFIG_CMD_IMPORTENV=y
++CONFIG_CMD_EDITENV=y
++# CONFIG_CMD_GREPENV is not set
++CONFIG_CMD_SAVEENV=y
++CONFIG_CMD_ENV_EXISTS=y
++
++#
++# Memory commands
++#
++CONFIG_CMD_MEMORY=y
++CONFIG_CMD_CRC32=y
++# CONFIG_LOOPW is not set
++# CONFIG_CMD_MEMTEST is not set
++# CONFIG_CMD_MX_CYCLIC is not set
++# CONFIG_CMD_MEMINFO is not set
++
++#
++# Device access commands
++#
++# CONFIG_CMD_LOADB is not set
++# CONFIG_CMD_LOADS is not set
+ # CONFIG_CMD_FLASH is not set
+-CONFIG_CMD_MMC=y
+-CONFIG_CMD_SF=y
++# CONFIG_CMD_ARMFLASH is not set
++# CONFIG_CMD_MMC is not set
++# CONFIG_CMD_NAND is not set
++# CONFIG_CMD_SF is not set
++# CONFIG_CMD_SPI is not set
++CONFIG_CMD_I2C=y
+ CONFIG_CMD_USB=y
++# CONFIG_CMD_DFU is not set
++# CONFIG_CMD_USB_MASS_STORAGE is not set
+ # CONFIG_CMD_FPGA is not set
++# CONFIG_CMD_GPIO is not set
++
++#
++# Shell scripting commands
++#
++CONFIG_CMD_ECHO=y
++CONFIG_CMD_ITEST=y
++CONFIG_CMD_SOURCE=y
+ # CONFIG_CMD_SETEXPR is not set
++
++#
++# Network commands
++#
++CONFIG_CMD_NET=y
++# CONFIG_CMD_TFTPPUT is not set
++# CONFIG_CMD_TFTPSRV is not set
++# CONFIG_CMD_RARP is not set
+ CONFIG_CMD_DHCP=y
++# CONFIG_CMD_NFS is not set
++# CONFIG_CMD_MII is not set
+ CONFIG_CMD_PING=y
++# CONFIG_CMD_CDP is not set
++# CONFIG_CMD_SNTP is not set
++# CONFIG_CMD_DNS is not set
++# CONFIG_CMD_LINK_LOCAL is not set
++
++#
++# Misc commands
++#
++# CONFIG_CMD_CACHE is not set
++# CONFIG_CMD_TIME is not set
++CONFIG_CMD_MISC=y
++# CONFIG_CMD_TIMER is not set
++# CONFIG_CMD_QFW is not set
++
++#
++# Power commands
++#
++
++#
++# Security commands
++#
++
++#
++# Filesystem commands
++#
++# CONFIG_CMD_EXT2 is not set
++CONFIG_CMD_EXT4=y
++CONFIG_CMD_EXT4_WRITE=y
+ CONFIG_CMD_FAT=y
++CONFIG_CMD_FS_GENERIC=y
++CONFIG_SUPPORT_OF_CONTROL=y
++
++#
++# Device Tree Control
++#
++# CONFIG_OF_CONTROL is not set
++CONFIG_NET=y
++# CONFIG_NET_RANDOM_ETHADDR is not set
++# CONFIG_NETCONSOLE is not set
++CONFIG_NET_TFTP_VARS=y
++CONFIG_BOOTP_PXE_CLIENTARCH=0x15
++CONFIG_BOOTP_VCI_STRING="U-Boot.arm"
++
++#
++# Device Drivers
++#
++
++#
++# Generic Driver Options
++#
++# CONFIG_DM is not set
++# CONFIG_ADC is not set
++# CONFIG_ADC_EXYNOS is not set
++# CONFIG_ADC_SANDBOX is not set
++# CONFIG_BLOCK_CACHE is not set
++
++#
++# Clock
++#
++# CONFIG_CPU is not set
++
++#
++# Hardware crypto devices
++#
++# CONFIG_FSL_CAAM is not set
++
++#
++# Demo for driver model
++#
++
++#
++# DFU support
++#
++# CONFIG_DFU_TFTP is not set
++
++#
++# DMA Support
++#
++# CONFIG_TI_EDMA3 is not set
++
++#
++# GPIO Support
++#
++
++#
++# I2C support
++#
++# CONFIG_SYS_I2C_DW is not set
++# CONFIG_CROS_EC_KEYB is not set
++
++#
++# LED Support
++#
++
++#
++# Mailbox Controller Support
++#
++
++#
++# Memory Controller drivers
++#
++
++#
++# Multifunction device drivers
++#
++# CONFIG_CROS_EC is not set
++# CONFIG_FSL_SEC_MON is not set
++# CONFIG_MXC_OCOTP is not set
++# CONFIG_NUVOTON_NCT6102D is not set
++# CONFIG_PCA9551_LED is not set
++# CONFIG_WINBOND_W83627 is not set
++
++#
++# MMC Host controller Support
++#
++
++#
++# MTD Support
++#
++
++#
++# NAND Device Support
++#
++# CONFIG_NAND_DENALI is not set
++# CONFIG_NAND_VF610_NFC is not set
++# CONFIG_NAND_PXA3XX is not set
++# CONFIG_NAND_ARASAN is not set
++
++#
++# Generic NAND options
++#
++
++#
++# SPI Flash Support
++#
+ CONFIG_SPI_FLASH=y
++# CONFIG_SPI_FLASH_BAR is not set
+ CONFIG_SPI_FLASH_ATMEL=y
++# CONFIG_SPI_FLASH_EON is not set
++# CONFIG_SPI_FLASH_GIGADEVICE is not set
++# CONFIG_SPI_FLASH_MACRONIX is not set
++# CONFIG_SPI_FLASH_SPANSION is not set
++# CONFIG_SPI_FLASH_STMICRO is not set
++# CONFIG_SPI_FLASH_SST is not set
++# CONFIG_SPI_FLASH_WINBOND is not set
++CONFIG_SPI_FLASH_USE_4K_SECTORS=y
++# CONFIG_SPI_FLASH_MTD is not set
++# CONFIG_PHYLIB is not set
++# CONFIG_NETDEVICES is not set
++
++#
++# PCI
++#
++
++#
++# Pin controllers
++#
++
++#
++# Power
++#
++
++#
++# Power Domain Support
++#
++
++#
++# Remote Processor drivers
++#
++
++#
++# Reset Controller Support
++#
++
++#
++# Real Time Clock
++#
++
++#
++# Serial drivers
++#
++# CONFIG_DEBUG_UART is not set
++# CONFIG_DEBUG_UART_SKIP_INIT is not set
++# CONFIG_FSL_LPUART is not set
++# CONFIG_SYS_NS16550 is not set
++
++#
++# Sound support
++#
++# CONFIG_SOUND is not set
++
++#
++# SPI Support
++#
++# CONFIG_FSL_ESPI is not set
++# CONFIG_TI_QSPI is not set
++
++#
++# SPMI support
++#
++
++#
++# System reset device drivers
++#
++# CONFIG_DM_THERMAL is not set
++
++#
++# Timer Support
++#
++
++#
++# TPM support
++#
+ CONFIG_USB=y
++
++#
++# USB Host Controller Drivers
++#
++# CONFIG_USB_XHCI_HCD is not set
++# CONFIG_USB_EHCI_HCD is not set
++# CONFIG_USB_EHCI is not set
++# CONFIG_USB_OHCI_HCD is not set
++# CONFIG_USB_UHCI_HCD is not set
++# CONFIG_USB_DWC3 is not set
++
++#
++# MUSB Controller Driver
++#
++# CONFIG_USB_MUSB_HOST is not set
++# CONFIG_USB_MUSB_GADGET is not set
++
++#
++# ULPI drivers
++#
++
++#
++# USB peripherals
++#
+ CONFIG_USB_STORAGE=y
++# CONFIG_USB_KEYBOARD is not set
++CONFIG_USB_GADGET=y
++CONFIG_USB_GADGET_ATMEL_USBA=y
++# CONFIG_USB_GADGET_BCM_UDC_OTG_PHY is not set
++# CONFIG_USB_GADGET_DWC2_OTG is not set
++# CONFIG_CI_UDC is not set
++CONFIG_USB_GADGET_VBUS_DRAW=2
++CONFIG_USB_GADGET_DUALSPEED=y
++# CONFIG_USB_GADGET_DOWNLOAD is not set
++
++#
++# Graphics support
++#
++
++#
++# TrueType Fonts
++#
++# CONFIG_VIDEO_VESA is not set
++# CONFIG_VIDEO_LCD_ANX9804 is not set
++# CONFIG_VIDEO_LCD_SSD2828 is not set
++# CONFIG_VIDEO_MVEBU is not set
++# CONFIG_PHYS_TO_BUS is not set
++
++#
++# File systems
++#
++
++#
++# Library routines
++#
++# CONFIG_CC_OPTIMIZE_LIBS_FOR_SPEED is not set
++CONFIG_HAVE_PRIVATE_LIBGCC=y
++CONFIG_USE_PRIVATE_LIBGCC=y
++CONFIG_SYS_HZ=1000
++# CONFIG_USE_TINY_PRINTF is not set
++CONFIG_REGEX=y
++# CONFIG_LIB_RAND is not set
++# CONFIG_CMD_DHRYSTONE is not set
++# CONFIG_RSA is not set
++
++#
++# Hashing Support
++#
++# CONFIG_SHA1 is not set
++# CONFIG_SHA256 is not set
++# CONFIG_SHA_HW_ACCEL is not set
++
++#
++# Compression Support
++#
++# CONFIG_LZ4 is not set
++# CONFIG_ERRNO_STR is not set
+ CONFIG_OF_LIBFDT=y
++# CONFIG_OF_LIBFDT_OVERLAY is not set
++# CONFIG_SPL_OF_LIBFDT is not set
++CONFIG_EFI_LOADER=y
++# CONFIG_UNIT_TEST is not set
diff --git a/recipes-bsp/u-boot/u-boot-2016.09.01/mtcdt_flush_console_autoboot.patch b/recipes-bsp/u-boot/u-boot-2016.09.01/mtcdt_flush_console_autoboot.patch
index d08843a..6280862 100644
--- a/recipes-bsp/u-boot/u-boot-2016.09.01/mtcdt_flush_console_autoboot.patch
+++ b/recipes-bsp/u-boot/u-boot-2016.09.01/mtcdt_flush_console_autoboot.patch
@@ -1,3 +1,5 @@
+# Now sets the boot delay from python code in u-boot.inc
+==============================================================
# This change sets the bootdelay to 2 seconds. On old devices
# the bootdelay may be in the environment variable partitions.
# When updating a system, u-boot setenv command must be used
@@ -29,15 +31,3 @@ diff -Naru orig/common/autoboot.c new/common/autoboot.c
/*
* Check if key already pressed
*/
-diff -Naru orig/configs/at91sam9x5ek_nandflash_defconfig new/configs/at91sam9x5ek_nandflash_defconfig
---- orig/configs/at91sam9x5ek_nandflash_defconfig 2019-08-15 10:49:30.223481632 -0500
-+++ new/configs/at91sam9x5ek_nandflash_defconfig 2019-08-15 10:50:10.703480433 -0500
-@@ -3,7 +3,7 @@
- CONFIG_TARGET_AT91SAM9X5EK=y
- CONFIG_SPL=n
- CONFIG_SYS_EXTRA_OPTIONS="AT91SAM9X5,SYS_USE_NANDFLASH"
--CONFIG_BOOTDELAY=0
-+CONFIG_BOOTDELAY=2
- CONFIG_HUSH_PARSER=y
- CONFIG_SYS_PROMPT="U-Boot> "
- CONFIG_CMD_BOOTZ=y
diff --git a/recipes-bsp/u-boot/u-boot.inc b/recipes-bsp/u-boot/u-boot.inc
index c69c650..a44dde5 100644
--- a/recipes-bsp/u-boot/u-boot.inc
+++ b/recipes-bsp/u-boot/u-boot.inc
@@ -85,6 +85,12 @@ do_patch_append () {
except TypeError:
bb.fatal("PR is missing from recipe")
f.write(PR + os.linesep)
+ try:
+ S = d.getVar("S",True)
+ except TypeError:
+ bb.fatal("S is missing from recipe")
+
+ os.system("sed -i s/^CONFIG_BOOTDELAY=.*/CONFIG_BOOTDELAY=2/ " + S + "/configs/at91sam9x5ek_nandflash_defconfig")
}
diff --git a/recipes-bsp/u-boot/u-boot_2016.09.01.bb b/recipes-bsp/u-boot/u-boot_2016.09.01.bb
index 879fa76..a0a068b 100644
--- a/recipes-bsp/u-boot/u-boot_2016.09.01.bb
+++ b/recipes-bsp/u-boot/u-boot_2016.09.01.bb
@@ -3,16 +3,20 @@ require u-boot.inc
DEPENDS += "dtc-native"
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-2016.09.01:"
+FCONFIG_PATCH = "file://configfactory.patch"
+CONFIG_PATCH = "file://config.patch"
+
SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
file://kconfig_common.patch \
- file://config.patch \
+ ${FCONFIG_PATCH} \
file://i2c.patch \
file://printeepromcrc.patch \
file://mtpwd.patch \
file://tftpput.patch \
file://hide_uboot_version.patch \
file://fix_2_6.patch \
- file://fix_net.patch"
+ file://fix_net.patch \
+"
SRC_URI_append_mtcdt = " \
file://mtcdt.patch \
@@ -38,3 +42,5 @@ SRC_URI[md5sum] = "61c628f8034477c946e173ed174efeb4"
SRC_URI[sha256sum] = "95728e89dd476d17428f94080752ab48884be477b6a678941582aeef618b70bb"
S = "${WORKDIR}/${PN}-${PV}"
+
+