summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2019-02-22 16:38:30 -0600
committerJohn Klug <john.klug@multitech.com>2019-02-22 16:38:30 -0600
commit1d7494802ec6f683648ef2087915d7f9ceb75fcf (patch)
tree671fece18c16c87389b400f52eac432aba4efc42
parentd49fbd2e259c75638c2d0f9d6f00d68da18d4522 (diff)
downloadmeta-multitech-atmel-1d7494802ec6f683648ef2087915d7f9ceb75fcf.tar.gz
meta-multitech-atmel-1d7494802ec6f683648ef2087915d7f9ceb75fcf.tar.bz2
meta-multitech-atmel-1d7494802ec6f683648ef2087915d7f9ceb75fcf.zip
Add the TI wifi stuff to Linux4
-rw-r--r--recipes-bsp/ti-wifi-utils/ti-wifi-utils/plt_drop_insmod_rmmod.patch35
-rw-r--r--recipes-bsp/ti-wifi-utils/ti-wifi-utils/upgrade_libnl_to_32.patch28
-rw-r--r--recipes-bsp/ti-wifi-utils/ti-wifi-utils_R8.7.bb51
-rw-r--r--recipes-bsp/wifiup/wifiup/wifi.init180
-rw-r--r--recipes-bsp/wifiup/wifiup/wifi.modprobe3
-rw-r--r--recipes-bsp/wifiup/wifiup_0.1.bb23
-rw-r--r--recipes-bsp/wl12xx-firmware/wl12xx-firmware/LICENSE72
-rw-r--r--recipes-bsp/wl12xx-firmware/wl12xx-firmware/TIInit_7.6.15.btsbin0 -> 50770 bytes
-rw-r--r--recipes-bsp/wl12xx-firmware/wl12xx-firmware/wl1271-nvs.binbin0 -> 912 bytes
-rw-r--r--recipes-bsp/wl12xx-firmware/wl12xx-firmware/wl127x-fw-5-mr.binbin0 -> 354600 bytes
-rw-r--r--recipes-bsp/wl12xx-firmware/wl12xx-firmware/wl127x-fw-5-plt.binbin0 -> 352588 bytes
-rw-r--r--recipes-bsp/wl12xx-firmware/wl12xx-firmware/wl127x-fw-5-sr.binbin0 -> 370996 bytes
-rw-r--r--recipes-bsp/wl12xx-firmware/wl12xx-firmware_r6.bb49
13 files changed, 441 insertions, 0 deletions
diff --git a/recipes-bsp/ti-wifi-utils/ti-wifi-utils/plt_drop_insmod_rmmod.patch b/recipes-bsp/ti-wifi-utils/ti-wifi-utils/plt_drop_insmod_rmmod.patch
new file mode 100644
index 0000000..5bdafef
--- /dev/null
+++ b/recipes-bsp/ti-wifi-utils/ti-wifi-utils/plt_drop_insmod_rmmod.patch
@@ -0,0 +1,35 @@
+--- a/plt.c 2016-05-31 17:23:45.000000000 +0300
++++ b/plt.c 2016-05-31 18:04:25.022788401 +0300
+@@ -1158,10 +1158,10 @@
+ }
+
+ /* Load module */
+- res = insmod(modpath);
+- if (res) {
+- goto out_removenvs;
+- }
++// res = insmod(modpath);
++// if (res) {
++// goto out_removenvs;
++// }
+
+ res = plt_do_power_on(state, devname);
+ if (res < 0)
+@@ -1188,7 +1188,7 @@
+
+ /* we can ignore the return value, because we rmmod anyway */
+ plt_do_power_off(state, devname);
+- rmmod(modpath);
++// rmmod(modpath);
+
+ printf("Calibration done. ");
+ if (cmn.fem0_bands) {
+@@ -1214,7 +1214,7 @@
+ /* we can ignore the return value, because we rmmod anyway */
+ plt_do_power_off(state, devname);
+ out_rmmod:
+- rmmod(modpath);
++// rmmod(modpath);
+
+ out_removenvs:
+ fprintf(stderr, "Calibration not complete. Removing half-baked nvs\n");
diff --git a/recipes-bsp/ti-wifi-utils/ti-wifi-utils/upgrade_libnl_to_32.patch b/recipes-bsp/ti-wifi-utils/ti-wifi-utils/upgrade_libnl_to_32.patch
new file mode 100644
index 0000000..c5b6efa
--- /dev/null
+++ b/recipes-bsp/ti-wifi-utils/ti-wifi-utils/upgrade_libnl_to_32.patch
@@ -0,0 +1,28 @@
+--- a/Makefile 2016-05-31 17:23:45.000000000 +0300
++++ b/Makefile 2016-05-31 17:36:55.582844952 +0300
+@@ -1,21 +1,12 @@
+ CC = $(CROSS_COMPILE)gcc
+ CFLAGS = -O2 -Wall
+-CFLAGS += -I$(NFSROOT)/usr/include -I$(NFSROOT)/include
++CFLAGS += -I=/usr/include -I=/include -I=/usr/include/libnl3
+
+-ifdef NLROOT
+-CFLAGS += -I${NLROOT}
+-endif
+-
+-LDFLAGS += -L$(NFSROOT)/lib
++LDFLAGS += -L=/lib
+ LIBS += -lm
+
+-ifeq ($(NLVER),3)
+- CFLAGS+=-DCONFIG_LIBNL32
+- LIBS += -lnl-3 -lnl-genl-3
+-else
+- CFLAGS+=-DCONFIG_LIBNL20
+- LIBS += -lnl -lnl-genl
+-endif
++CFLAGS+=-DCONFIG_LIBNL32
++LIBS += -lnl-3 -lnl-genl-3
+
+ OBJS = nvs.o misc_cmds.o calibrator.o plt.o wl18xx_plt.o ini.o
+
diff --git a/recipes-bsp/ti-wifi-utils/ti-wifi-utils_R8.7.bb b/recipes-bsp/ti-wifi-utils/ti-wifi-utils_R8.7.bb
new file mode 100644
index 0000000..ee3ca65
--- /dev/null
+++ b/recipes-bsp/ti-wifi-utils/ti-wifi-utils_R8.7.bb
@@ -0,0 +1,51 @@
+DESCRIPTION = "The calibrator and other useful utilities for TI wireless solution based on wl12xx driver"
+HOMEPAGE = "http://software-dl.ti.com/ecs/WiLink8/latest/index_FDS.html"
+SECTION = "console/utils"
+PRIORITY = "optional"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/BSD;md5=3775480a712fc46a69647678acb234cb"
+DEPENDS = "libnl"
+# ti-compat-wireless-wl12xx
+RDEPENDS_${PN} = "wl12xx-firmware"
+
+inherit autotools-brokensep
+
+do_compile () {
+ unset CFLAGS LDFLAGS CXXFLAGS CPPFLAGS
+ # For Newer Yocto/Bitbake, CC does not
+ # include the staging directory
+ # by default
+ CC="${CC} --sysroot=${STAGING_DIR_HOST}"
+ LD="${LD} --sysroot=${STAGING_DIR_HOST}"
+ oe_runmake CC="${CC}" LD="${LD}"
+}
+
+PR = "r2"
+# tag R8.7
+SRCREV = "39542357111d1f24e866c2857d561a348c04cce4"
+
+SRC_URI = " \
+ git://git.ti.com/wilink8-wlan/18xx-ti-utils.git;protocol=git;branch=master \
+ file://upgrade_libnl_to_32.patch \
+ file://plt_drop_insmod_rmmod.patch "
+
+
+
+S = "${WORKDIR}/git"
+
+export CROSS_COMPILE = "${TARGET_PREFIX}"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/ti/wifi-utils/ini_files/127x
+ install -d ${D}${datadir}/ti/wifi-utils/ini_files/128x
+
+ install -m 0755 calibrator ${D}${bindir}/
+ install -m 0755 ${S}/hw/ini_files/127x/* ${D}${datadir}/ti/wifi-utils/ini_files/127x
+ install -m 0755 ${S}/hw/ini_files/128x/* ${D}${datadir}/ti/wifi-utils/ini_files/128x
+}
+
+FILES_${PN} += " \
+ ${datadir}/ti/wifi-utils/ini_files/127x \
+ ${datadir}/ti/wifi-utils/ini_files/128x \
+"
diff --git a/recipes-bsp/wifiup/wifiup/wifi.init b/recipes-bsp/wifiup/wifiup/wifi.init
new file mode 100644
index 0000000..064a633
--- /dev/null
+++ b/recipes-bsp/wifiup/wifiup/wifi.init
@@ -0,0 +1,180 @@
+#!/bin/sh
+
+LOCK=/var/lock/wifi_lock
+WIFI_AP_CONFIG_FILE="/var/run/hostapd.conf"
+WIFI_CLIENT_CONFIG_FILE="/var/run/wpa_supplicant.conf"
+WIFI_LOG_FILE="/var/log/wpa_supplicant.log"
+UDHCPC_WIFIUP_SCRIPT="/etc/udhcpc.d/wifiup"
+FACTORY_NVS_PATH="/lib/firmware/ti-connectivity/wl1271-nvs.bin.factory"
+NVS_PATH="/var/oem/mts/wl1271-nvs.bin"
+
+if mkdir $LOCK; then
+ trap "rm -fr $LOCK" EXIT
+else
+ echo "Wifi lock not acquired, resource in use" >&2
+ exit 1
+fi
+
+cnt=$(ps -A | grep 'wifi$' | wc -l)
+
+function init() {
+ echo "initializing wifi chip"
+
+ # install factory nvs file if necessary
+ if [[ ! -f $NVS_PATH ]]; then
+ echo "$NVS_PATH not found, using factory default"
+ mount -o remount,rw /var/oem
+ mkdir -p /var/oem/mts
+ cp $FACTORY_NVS_PATH $NVS_PATH
+ mount -o remount,ro /var/oem
+ fi
+
+ # enable wifi chip
+ mts-io-sysfs store wlan-enabled 0
+ usleep 50000
+ mts-io-sysfs store wlan-enabled 1
+ sleep 1
+ # load atmel_mci module
+ lsmod | grep -q atmel_mci || {
+ modprobe atmel_mci && sleep 3
+ }
+
+ # led
+ ## INFO: code from scripts/led_ni_setup
+ echo "netdev" > /sys/class/leds/led-b/trigger
+ echo "wlan0" > /sys/class/leds/led-b/device_name
+ echo "link tx rx" > /sys/class/leds/led-b/mode
+}
+
+function start() {
+ JSON=$(curl -m 5 -s 127.0.0.1/api?fields=wifi,lan,system/macAddress,system/mode)
+
+ : ${WIFI_AP_ENABLED:='false'}
+ : ${WIFI_AP_MAC:='0F:0A:0C:0E:05:01'}
+ : ${WIFI_CLIENT_ENABLED:='true'}
+ : ${WIFI_CLIENT_MODE:='WAN'}
+ : ${SYSTEM_MODE:='STATION'}
+
+ if [ "$SYSTEM_MODE" != "ROUTER" ]; then
+ echo "Can NOT configure WiFi Access Point or Client. System Mode: $SYSTEM_MODE"
+ exit 1
+ fi
+
+ if [ "$WIFI_AP_ENABLED" == "true" ] && [ "$WIFI_CLIENT_ENABLED" == "true" ]; then
+ echo "Can NOT enable both Wifi Access Point and Client at the same time"
+ exit 1
+ fi
+
+ if [ "$WIFI_AP_ENABLED" == "false" ] && [ "$WIFI_CLIENT_ENABLED" == "false" ]; then
+ echo "Wifi is disabled. Powering Down Wifi Chip"
+ stop
+ exit
+ fi
+
+ init
+
+ # Check to see if Wifi AP is enabled
+ # And that Wifi Client is not enabled
+ if [ "$WIFI_AP_ENABLED" == "true" ] && [ "$WIFI_CLIENT_ENABLED" == "false" ]; then
+ echo "WiFi AP enabled - Bringing up hostapd on wlan0"
+ # initialize hostapd config
+ wifi_ap_init
+ if [ -f $WIFI_AP_CONFIG_FILE ]; then
+ hostapd -B $WIFI_AP_CONFIG_FILE -P /var/run/hostapd_wlan0.pid
+ sleep 5
+ ip link set br0 address $WIFI_AP_MAC
+ else
+ echo "Error generating $WIFI_AP_CONFIG_FILE"
+ exit 1
+ fi
+ else
+ echo "WiFi AP is disabled"
+ fi
+
+ # Check to see if Wifi Client is enabled
+ # And that Wifi AP is not enabled
+ if [ "$WIFI_CLIENT_ENABLED" == "true" ] && [ "$WIFI_AP_ENABLED" == "false" ]; then
+ echo "WiFi Client enabled - Configuring wlan0"
+
+ # initialize wpasupplicant config
+ wifi_client_init
+
+ ifconfig wlan0 up
+
+ # Check to see if ap is designated
+ if [ -f $WIFI_CLIENT_CONFIG_FILE ]; then
+ echo "WiFi Client - Configuring wpa supplicant"
+ # syslog option is '-s', file option is '-f <path>'
+ wpa_supplicant -B -iwlan0 -Dnl80211 -c $WIFI_CLIENT_CONFIG_FILE -P /var/run/wpa_supplicant_wlan0.pid $ -s &
+
+ sleep 10
+
+ if [ "$WIFI_CLIENT_MODE" == "WAN" ]; then
+ echo "WiFi Client - Starting DHCP client"
+ udhcpc -i wlan0 -s $UDHCPC_WIFIUP_SCRIPT -p /var/run/udhcpc_wlan0.pid > /dev/null 2>&1 &
+ elif [ "$WIFI_CLIENT_MODE" == "LAN" ]; then
+ echo "WiFi Client - Adding to bridge"
+ brctl addif br0 wlan0
+ fi
+ sleep 2
+ fi
+ else
+ echo "WiFi client is disabled"
+ fi
+}
+
+function stop() {
+ echo -n "Shutting down wifi "
+
+ if [ -f /var/run/wpa_supplicant_wlan0.pid ]; then
+ PID=$(cat /var/run/wpa_supplicant_wlan0.pid)
+ kill $PID > /dev/null 2>&1
+ fi
+ if [ -f /var/run/udhcpc_wlan0.pid ]; then
+ PID=$(cat /var/run/udhcpc_wlan0.pid)
+ kill $PID > /dev/null 2>&1
+ fi
+ if [ -f /var/run/hostapd_wlan0.pid ]; then
+ PID=$(cat /var/run/hostapd_wlan0.pid)
+ kill $PID > /dev/null 2>&1
+ fi
+
+ modprobe -r wl12xx > /dev/null 2>&1
+ modprobe -r wlcore > /dev/null 2>&1
+ modprobe -r wlcore_sdio > /dev/null 2>&1
+ modprobe -r atmel_mci > /dev/null 2>&1
+}
+
+function scan() {
+ init
+
+ # Ensure WLAN is up
+ ifconfig wlan0 up
+ # Scan
+ iw wlan0 scan
+}
+
+case "$1" in
+ "start")
+ start
+ ;;
+ "stop")
+ stop
+ ;;
+ "restart")
+ ## Stop the service and regardless of whether it was
+ ## running or not, start it again.
+ echo "Restarting wifi"
+ stop
+ start
+ ;;
+ "scan")
+ scan
+ ;;
+ *)
+ ## If no parameters are given, print which are avaiable.
+ echo "Usage: $0 {start|stop|scan|restart}"
+ exit 1
+ ;;
+esac
+
diff --git a/recipes-bsp/wifiup/wifiup/wifi.modprobe b/recipes-bsp/wifiup/wifiup/wifi.modprobe
new file mode 100644
index 0000000..e1c3f52
--- /dev/null
+++ b/recipes-bsp/wifiup/wifiup/wifi.modprobe
@@ -0,0 +1,3 @@
+# Do not load the 'atmel_mci' module on boot.
+# Loaded by /etc/init.d/wifi after wifi power switch on.
+blacklist atmel_mci
diff --git a/recipes-bsp/wifiup/wifiup_0.1.bb b/recipes-bsp/wifiup/wifiup_0.1.bb
new file mode 100644
index 0000000..5c6003b
--- /dev/null
+++ b/recipes-bsp/wifiup/wifiup_0.1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Provides the Wifi init scripts"
+SECTION = "init scripts"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+# Was dependent on api
+RDEPENDS_${PN} = "curl jsparser"
+PR = "r4"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "wifi"
+INITSCRIPT_PARAMS = "defaults 73 27"
+
+SRC_URI += "file://wifi.init \
+ file://wifi.modprobe "
+
+do_install_append() {
+ install -d ${D}/etc/init.d
+ install -m 0755 ${WORKDIR}/wifi.init ${D}/etc/init.d/wifi
+
+ install -d ${D}/etc/modprobe.d
+ install -m 0644 ${WORKDIR}/wifi.modprobe ${D}/etc/modprobe.d/wifi.conf
+}
diff --git a/recipes-bsp/wl12xx-firmware/wl12xx-firmware/LICENSE b/recipes-bsp/wl12xx-firmware/wl12xx-firmware/LICENSE
new file mode 100644
index 0000000..29ed482
--- /dev/null
+++ b/recipes-bsp/wl12xx-firmware/wl12xx-firmware/LICENSE
@@ -0,0 +1,72 @@
+TEXAS INSTRUMENTS TEXT FILE LICENSE
+
+
+Copyright (c) 2008 – 2013 Texas Instruments Incorporated
+
+All rights reserved not granted herein.
+
+Limited License.
+
+If you download and use any version of this software from www.github.com, you
+acknowledge and agree that the terms and conditions of this license control and any
+previous licenses under which this software may have been provided on www.github.com
+are superseded and replaced by the terms and conditions of this license.
+
+Texas Instruments Incorporated grants a world-wide, royalty-free, non-exclusive
+license under copyrights and patents it now or hereafter owns or controls to make,
+have made, use, import, offer to sell and sell ("Utilize") this software subject
+to the terms herein. With respect to the foregoing patent license, such license
+is granted solely to the extent that any such patent is necessary to Utilize the
+software alone. The patent license shall not apply to any combinations which
+include this software, other than combinations with devices manufactured by or
+for TI (“TI Devices”). No hardware patent is licensed hereunder.
+
+Redistributions must preserve existing copyright notices and reproduce this license
+(including the above copyright notice and the disclaimer and (if applicable) source
+code license limitations below) in the documentation and/or other materials provided
+with the distribution
+
+Redistribution and use in binary form, without modification, are permitted provided
+that the following conditions are met:
+
+* No reverse engineering, decompilation, or disassembly of this software is permitted
+ with respect to any software provided in binary form.
+
+* any redistribution and use are licensed by TI for use only with TI Devices.
+
+* Nothing shall obligate TI to provide you with source code for the software
+ licensed and provided to you in object code.
+
+If software source code is provided to you, modification and redistribution of the
+source code are permitted provided that the following conditions are met:
+
+* any redistribution and use of the source code, including any resulting
+ derivative works, are licensed by TI for use only with TI Devices.
+
+* any redistribution and use of any object code compiled from the source
+ code and any resulting derivative works, are licensed by TI for use only
+ with TI Devices.
+
+Neither the name of Texas Instruments Incorporated nor the names of its suppliers
+may be used to endorse or promote products derived from this software without specific
+prior written permission.
+
+DISCLAIMER.
+
+THIS SOFTWARE IS PROVIDED BY TI AND TI’S LICENSORS "AS IS" AND ANY EXPRESS
+OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
+OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN
+NO EVENT SHALL TI AND TI’S LICENSORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
+NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
+OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
+EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+BY UTILIZING THIS SOFTWARE TO ENABLE ANT CODE EMBEDDED ON TI DEVICES, YOU
+AGREE THAT NOTHING IN THIS LICENSE GIVES RISE TO ANY WARRANTY OR OTHER
+OBLIGATIONS BY TI OR ITS LICENSORS WITH RESPECT TO THE ANT CODE EMBEDDED
+ON TI DEVICES AND ENABLED BY THE SOFTWARE UNDER THIS LICENSE. FURTHER, YOU
+AGREE THAT NOTHING IN THIS LICENSE GIVES RISE TO ANY RIGHT TO REVERSE ENGINEER,
+DECOMPILE OR DISASSEMBLE THE ANT CODE EMBEDDED ON THE TI DEVICES.
diff --git a/recipes-bsp/wl12xx-firmware/wl12xx-firmware/TIInit_7.6.15.bts b/recipes-bsp/wl12xx-firmware/wl12xx-firmware/TIInit_7.6.15.bts
new file mode 100644
index 0000000..ed733bc
--- /dev/null
+++ b/recipes-bsp/wl12xx-firmware/wl12xx-firmware/TIInit_7.6.15.bts
Binary files differ
diff --git a/recipes-bsp/wl12xx-firmware/wl12xx-firmware/wl1271-nvs.bin b/recipes-bsp/wl12xx-firmware/wl12xx-firmware/wl1271-nvs.bin
new file mode 100644
index 0000000..91978f9
--- /dev/null
+++ b/recipes-bsp/wl12xx-firmware/wl12xx-firmware/wl1271-nvs.bin
Binary files differ
diff --git a/recipes-bsp/wl12xx-firmware/wl12xx-firmware/wl127x-fw-5-mr.bin b/recipes-bsp/wl12xx-firmware/wl12xx-firmware/wl127x-fw-5-mr.bin
new file mode 100644
index 0000000..c953fef
--- /dev/null
+++ b/recipes-bsp/wl12xx-firmware/wl12xx-firmware/wl127x-fw-5-mr.bin
Binary files differ
diff --git a/recipes-bsp/wl12xx-firmware/wl12xx-firmware/wl127x-fw-5-plt.bin b/recipes-bsp/wl12xx-firmware/wl12xx-firmware/wl127x-fw-5-plt.bin
new file mode 100644
index 0000000..1f6249f
--- /dev/null
+++ b/recipes-bsp/wl12xx-firmware/wl12xx-firmware/wl127x-fw-5-plt.bin
Binary files differ
diff --git a/recipes-bsp/wl12xx-firmware/wl12xx-firmware/wl127x-fw-5-sr.bin b/recipes-bsp/wl12xx-firmware/wl12xx-firmware/wl127x-fw-5-sr.bin
new file mode 100644
index 0000000..c83d3eb
--- /dev/null
+++ b/recipes-bsp/wl12xx-firmware/wl12xx-firmware/wl127x-fw-5-sr.bin
Binary files differ
diff --git a/recipes-bsp/wl12xx-firmware/wl12xx-firmware_r6.bb b/recipes-bsp/wl12xx-firmware/wl12xx-firmware_r6.bb
new file mode 100644
index 0000000..75423c0
--- /dev/null
+++ b/recipes-bsp/wl12xx-firmware/wl12xx-firmware_r6.bb
@@ -0,0 +1,49 @@
+DESCRIPTION = "TI wl1271 firmware"
+HOMEPAGE = "http://processors.wiki.ti.com/index.php/ARM_Processor_Open_Source_Wireless_Connectivity"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=1c9961176d6529283e0d0c983be41b45"
+PR="r6"
+
+# bluetooth firmware from TI-ECS on github.com:
+# https://github.com/TI-ECS/bt-firmware.git
+# revision 3c0e4752ba91be195ac05226725428dfdc1a4759
+# Last file log message: "Updated to service pack 2.14"
+# file: am335x/TIInit_7.6.15.bts
+# md5sum: a46c46104c7fab23bb9ebfae1633a3af
+# wifi firmware from TI-OpenLink on github.com
+# https://github.com/TI-OpenLink/firmwares.git
+# revision 977880610b1ad9048f4b7804ba5b8fa454e0b76a
+# Last file log message: "Update the wl127x and wl128x firmwares to *.3.10.0.133 for single-role and *.5.7.0.42 for multi-role."
+# file: ti-connectivity/wl127x-fw-5-sr.bin
+# file: ti-connectivity/wl127x-fw-5-mr.bin
+# file: ti-connectivity/wl127x-fw-5-plt.bin
+
+SRC_URI = "file://wl127x-fw-5-mr.bin \
+ file://wl127x-fw-5-plt.bin \
+ file://wl127x-fw-5-sr.bin \
+ file://TIInit_7.6.15.bts \
+ file://wl1271-nvs.bin \
+ file://LICENSE "
+
+# nothing to compile
+do_configure() {
+}
+
+do_compile() {
+}
+
+do_install() {
+ install -d ${D}/lib/firmware
+ install -d ${D}/lib/firmware/ti-connectivity
+ # wifi firmware
+ install ${WORKDIR}/wl127x-fw-*-*.bin ${D}/lib/firmware/ti-connectivity
+ # uncalibrated nvs file
+ # use local copy since the one in hw/firmware dir is *wrong*
+ install ${WORKDIR}/wl1271-nvs.bin ${D}/lib/firmware/ti-connectivity/wl1271-nvs.bin.factory
+ # link to nvs file with mac address set
+ ln -sf wl1271-nvs.bin.factory ${D}/lib/firmware/ti-connectivity/wl1271-nvs.bin
+ # bluetooth firmware
+ install ${WORKDIR}/TIInit_7.6.15.bts ${D}/lib/firmware/ti-connectivity/TIInit_7.6.15.bts
+}
+
+FILES_${PN} = "/lib/firmware"