summaryrefslogtreecommitdiff
path: root/recipes-bsp/wl12xx-firmware/wl12xx-firmware_r6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/wl12xx-firmware/wl12xx-firmware_r6.bb')
-rw-r--r--recipes-bsp/wl12xx-firmware/wl12xx-firmware_r6.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-bsp/wl12xx-firmware/wl12xx-firmware_r6.bb b/recipes-bsp/wl12xx-firmware/wl12xx-firmware_r6.bb
new file mode 100644
index 0000000..75423c0
--- /dev/null
+++ b/recipes-bsp/wl12xx-firmware/wl12xx-firmware_r6.bb
@@ -0,0 +1,49 @@
+DESCRIPTION = "TI wl1271 firmware"
+HOMEPAGE = "http://processors.wiki.ti.com/index.php/ARM_Processor_Open_Source_Wireless_Connectivity"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=1c9961176d6529283e0d0c983be41b45"
+PR="r6"
+
+# bluetooth firmware from TI-ECS on github.com:
+# https://github.com/TI-ECS/bt-firmware.git
+# revision 3c0e4752ba91be195ac05226725428dfdc1a4759
+# Last file log message: "Updated to service pack 2.14"
+# file: am335x/TIInit_7.6.15.bts
+# md5sum: a46c46104c7fab23bb9ebfae1633a3af
+# wifi firmware from TI-OpenLink on github.com
+# https://github.com/TI-OpenLink/firmwares.git
+# revision 977880610b1ad9048f4b7804ba5b8fa454e0b76a
+# Last file log message: "Update the wl127x and wl128x firmwares to *.3.10.0.133 for single-role and *.5.7.0.42 for multi-role."
+# file: ti-connectivity/wl127x-fw-5-sr.bin
+# file: ti-connectivity/wl127x-fw-5-mr.bin
+# file: ti-connectivity/wl127x-fw-5-plt.bin
+
+SRC_URI = "file://wl127x-fw-5-mr.bin \
+ file://wl127x-fw-5-plt.bin \
+ file://wl127x-fw-5-sr.bin \
+ file://TIInit_7.6.15.bts \
+ file://wl1271-nvs.bin \
+ file://LICENSE "
+
+# nothing to compile
+do_configure() {
+}
+
+do_compile() {
+}
+
+do_install() {
+ install -d ${D}/lib/firmware
+ install -d ${D}/lib/firmware/ti-connectivity
+ # wifi firmware
+ install ${WORKDIR}/wl127x-fw-*-*.bin ${D}/lib/firmware/ti-connectivity
+ # uncalibrated nvs file
+ # use local copy since the one in hw/firmware dir is *wrong*
+ install ${WORKDIR}/wl1271-nvs.bin ${D}/lib/firmware/ti-connectivity/wl1271-nvs.bin.factory
+ # link to nvs file with mac address set
+ ln -sf wl1271-nvs.bin.factory ${D}/lib/firmware/ti-connectivity/wl1271-nvs.bin
+ # bluetooth firmware
+ install ${WORKDIR}/TIInit_7.6.15.bts ${D}/lib/firmware/ti-connectivity/TIInit_7.6.15.bts
+}
+
+FILES_${PN} = "/lib/firmware"