summaryrefslogtreecommitdiff
path: root/recipes-core/images
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/images')
-rw-r--r--recipes-core/images/core-image-rorootfs-overlay-initramfs.bb23
-rw-r--r--recipes-core/images/mlinux-base-image.bb19
-rw-r--r--recipes-core/images/mlinux-factory-image.bb62
-rw-r--r--recipes-core/images/mlinux-minimal-image.bb33
-rw-r--r--recipes-core/images/mlinux-mono-image.bb2
-rw-r--r--recipes-core/images/mlinux-mtcap-debug-image.bb2
-rw-r--r--recipes-core/images/mlinux-mtcap-image.bb22
-rw-r--r--recipes-core/images/mlinux-mtcap-test-image.bb2
-rw-r--r--recipes-core/images/mlinux-mtr-image.bb12
-rw-r--r--recipes-core/images/mlinux-mtrv1-image.bb16
-rw-r--r--recipes-core/images/mlinux-rs9113-base-image.bb2
-rw-r--r--recipes-core/images/mlinux-rs9113-factory-image.bb2
-rw-r--r--recipes-core/images/mlinux-rs9113-mtrv1-image.bb2
-rw-r--r--recipes-core/images/mlinux-sdk.bb2
-rw-r--r--recipes-core/images/mtcap-modules.inc2
15 files changed, 115 insertions, 88 deletions
diff --git a/recipes-core/images/core-image-rorootfs-overlay-initramfs.bb b/recipes-core/images/core-image-rorootfs-overlay-initramfs.bb
new file mode 100644
index 0000000..47946c5
--- /dev/null
+++ b/recipes-core/images/core-image-rorootfs-overlay-initramfs.bb
@@ -0,0 +1,23 @@
+# Simple initramfs image. Mostly used for live images.
+# Derived from https://github.com/cmhe/meta-readonly-rootfs-overlay
+DESCRIPTION = "Small image capable of booting a device. The kernel includes \
+the Minimal RAM-based Initial Root Filesystem (initramfs), mounts the root fs \
+read only and uses a file system overlay for written data."
+
+PACKAGE_INSTALL = "initramfs-readonly-rootfs-overlay ${VIRTUAL-RUNTIME_base-utils} udev base-passwd gptfdisk ${ROOTFS_BOOTSTRAP_INSTALL}"
+
+# Do not pollute the initrd image with rootfs features
+IMAGE_FEATURES = ""
+
+export IMAGE_BASENAME = "${PN}"
+IMAGE_LINGUAS = ""
+
+LICENSE = "MIT"
+
+IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
+inherit core-image
+
+IMAGE_ROOTFS_SIZE = "8192"
+IMAGE_ROOTFS_EXTRA_SPACE = "0"
+
+BAD_RECOMMENDATIONS += "busybox-syslog"
diff --git a/recipes-core/images/mlinux-base-image.bb b/recipes-core/images/mlinux-base-image.bb
index bd8dce7..e06e754 100644
--- a/recipes-core/images/mlinux-base-image.bb
+++ b/recipes-core/images/mlinux-base-image.bb
@@ -9,11 +9,12 @@ FILESYSTEM_FEATURES = "dosfstools \
lsof \
"
-NETWORKING_FEATURES += "bridge-utils \
+NETWORKING_FEATURES_append = " \
+ bridge-utils \
inetutils-ftp \
openssl \
rsync \
- iperf \
+ iperf3 \
lldpd \
mii-diag \
tcpdump \
@@ -26,9 +27,8 @@ NETWORKING_FEATURES += "bridge-utils \
WIFI_FEATURES = " \
libnl \
wpa-supplicant \
- wireless-tools \
iw \
- hostap-daemon hostap-utils \
+ hostapd \
"
BLUETOOTH_FEATURES = "bluez5"
@@ -48,9 +48,9 @@ TIME_FEATURES = "tzdata tzdata-africa tzdata-americas tzdata-antarctica tzdata-a
# radio-cmd: supports cellular radio activation and other configuration commands
# radio-query: queries cellular radio for common info (IMEI, RSSI, etc)
# jsparser: command line tool to parse JSON files
-MULTITECH_FEATURES += " \
- u-boot-linux-utils \
- mlinux-scripts \
+MULTITECH_FEATURES_append = " \
+ u-boot-linux-utils \
+ mlinux-scripts \
reset-handler \
radio-cmd radio-query \
jsparser \
@@ -58,12 +58,15 @@ MULTITECH_FEATURES += " \
MISC_FEATURES = "minicom lrzsz nano"
+DEBUG_FEATURES = ""
+
# Extra stuff to install
-IMAGE_INSTALL += " \
+IMAGE_INSTALL_append = " \
kernel-modules \
${WIFI_FEATURES} \
${BLUETOOTH_FEATURES} \
${FILESYSTEM_FEATURES} \
${TIME_FEATURES} \
${MISC_FEATURES} \
+ ${DEBUG_FEATURES} \
"
diff --git a/recipes-core/images/mlinux-factory-image.bb b/recipes-core/images/mlinux-factory-image.bb
index a20e64b..4afabff 100644
--- a/recipes-core/images/mlinux-factory-image.bb
+++ b/recipes-core/images/mlinux-factory-image.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "mLinux factory image"
# For now we don't put this in MTR or AEP
# Password restrictions library from Redhat
-IMAGE_INSTALL += "libpwquality"
+IMAGE_INSTALL_append = " libpwquality"
LIGHTTPD = "lighttpd \
lighttpd-module-cgi lighttpd-module-indexfile \
@@ -16,41 +16,39 @@ LIGHTTPD = "lighttpd \
"
# Lighttpd web server
-IMAGE_INSTALL += "${LIGHTTPD}"
+IMAGE_INSTALL_append = " ${LIGHTTPD}"
-IMAGE_INSTALL += "sqlite3"
+IMAGE_INSTALL_append = " sqlite3"
-IMAGE_INSTALL += "autossh"
+IMAGE_INSTALL_append= " autossh"
# Monit system/process monitor
-IMAGE_INSTALL += "monit"
+IMAGE_INSTALL_append = " monit"
# LoRa support (MTAC-LORA accessory card)
-IMAGE_INSTALL += "lora-gateway-utils lora-network-server lora-query lora-packet-forwarder-usb lora-gateway-geolocation-utils lora-packet-forwarder-geolocation mtac-xdot-util"
+IMAGE_INSTALL_append = " lora-gateway-utils lora-query lora-network-server lora-packet-forwarder-usb"
+IMAGE_INSTALL_mtcdt_append = " lora-gateway-geolocation-utils lora-packet-forwarder-geolocation"
+IMAGE_INSTALL_mtbsp-at91_append = " mtac-xdot-util"
# MQTT server
-#IMAGE_INSTALL += "mosquitto"
-IMAGE_INSTALL += "mosquitto mosquitto-clients"
+IMAGE_INSTALL_append = " mosquitto mosquitto-clients"
# Perl support
-IMAGE_INSTALL += "perl"
-IMAGE_INSTALL += "perl-module-io perl-module-fcntl"
+IMAGE_INSTALL_append = " perl"
+IMAGE_INSTALL_append = " perl-module-io perl-module-fcntl"
# not in meta-oe or oe-core...
-#IMAGE_INSTALL += "libdevice-serialport-perl"
-#IMAGE_INSTALL += "libexpect-perl"
+#IMAGE_INSTALL_append = " libdevice-serialport-perl"
+#IMAGE_INSTALL_append = " libexpect-perl"
# Python support
-IMAGE_INSTALL += "python"
+IMAGE_INSTALL_append = " python"
# Python modules
-IMAGE_INSTALL += "python-async \
-python-argparse \
+IMAGE_INSTALL_append = " python-argparse \
python-compression \
python-dateutil \
python-html \
-python-importlib \
python-psutil \
-python-pycurl \
python-pyopenssl \
python-pyserial \
python-pyudev \
@@ -64,34 +62,34 @@ python-xml \
"
# Ruby support
-IMAGE_INSTALL += "ruby"
+IMAGE_INSTALL_append = " ruby"
-IMAGE_INSTALL += "ruby-sqlite3"
-IMAGE_INSTALL += "ruby-serialport"
+IMAGE_INSTALL_append = " ruby-sqlite3"
+IMAGE_INSTALL_append = " ruby-serialport"
# OpenJDK Java runtime
-# IMAGE_INSTALL += "openjdk-8"
+# IMAGE_INSTALL_append = " openjdk-8"
# OpenJDK with JamVM VM (Multi-Tech default)
-# IMAGE_INSTALL += "jamvm"
+# IMAGE_INSTALL_append = " jamvm"
# OpenJDK with CACAO VM (run with 'java -cacao')
-# IMAGE_INSTALL += "openjdk-7-vm-cacao"
+# IMAGE_INSTALL_append = " openjdk-7-vm-cacao"
# OpenJDK Zero VM (run with 'java -zero')
-# IMAGE_INSTALL += "openjdk-7-vm-zero"
+# IMAGE_INSTALL_append = " openjdk-7-vm-zero"
# PHP support
-IMAGE_INSTALL += "php php-cli php-fpm"
+IMAGE_INSTALL_append = " php php-cli php-fpm"
# Node.js support
-IMAGE_INSTALL += "nodejs nodejs-npm"
+IMAGE_INSTALL_append = " nodejs nodejs-npm"
# Multi-Tech SMS Utility (see http://git.multitech.net)
-IMAGE_INSTALL += "sms-utils"
+IMAGE_INSTALL_append = " sms-utils"
# Multi-Tech GPS Utility
-IMAGE_INSTALL += "venus-gps"
-IMAGE_INSTALL += "pps-tools"
-IMAGE_INSTALL += "dnsmasq bluez5-pand bluez5-rfcomm"
+IMAGE_INSTALL_append = " venus-gps"
+IMAGE_INSTALL_append = " pps-tools"
+IMAGE_INSTALL_append = " dnsmasq bluez5-pand bluez5-rfcomm"
# When ntp is to use the GPS, gps-utils is required
-IMAGE_INSTALL += "gpsd libgps24 libgps ntp ntp-utils gpspipe gps-utils"
+IMAGE_INSTALL_append = " gpsd libgps ntp ntp-utils gpspipe gps-utils"
-IMAGE_INSTALL += "lxfp uvccapture"
+IMAGE_INSTALL_append = " lxfp uvccapture"
diff --git a/recipes-core/images/mlinux-minimal-image.bb b/recipes-core/images/mlinux-minimal-image.bb
index 0e1d4a3..41829ec 100644
--- a/recipes-core/images/mlinux-minimal-image.bb
+++ b/recipes-core/images/mlinux-minimal-image.bb
@@ -5,24 +5,28 @@ inherit core-image
inherit mlinux-image
IMAGE_LINGUAS = ""
-IMAGE_FEATURES += "ssh-server-openssh package-management"
+IMAGE_FEATURES_append = " ssh-server-openssh package-management"
-CORE_FEATURES = "packagegroup-core-boot packagegroup-distro-base \
+# Don't wipe out CORE_FEATURES from minimal image
+CORE_FEATURES_append = " \
+ packagegroup-core-boot packagegroup-distro-base \
packagegroup-base-ext2 \
packagegroup-base-usbhost packagegroup-base-usbgadget \
udev-extraconf usb-gadget-mode \
sysfsutils module-init-tools \
- bash procps mtd-utils mtd-utils-jffs2 \
+ bash procps \
openssh-sftp-server \
util-linux-mount util-linux-umount \
start-stop-daemon \
- sudo \
+ sudo \
${CORE_IMAGE_EXTRA_INSTALL} \
mlinux-feed-configs \
- useradd \
- get-eeprom-device-config \
+ useradd \
+ mts-io-sysfs \
"
+CORE_FEATURES_append_mtbsp-at91 = " mtd-utils mtd-utils-jffs2 fstab-at91"
+
NETWORKING_FEATURES = "ppp curl iproute2 \
iptables iputils \
"
@@ -44,10 +48,12 @@ MULTITECH_FEATURES = "kernel-module-mts-io \
config \
mts-id-eeprom \
set-rs485 \
- radio-reset"
-
+ radio-reset \
+ upgrade-reboot"
-MULTITECH_MTAC = "kernel-module-mtac \
+MULTITECH_MTAC = ""
+MULTITECH_MTAC_append_mtcdt = " \
+ kernel-module-mtac \
kernel-module-mtac-eth \
kernel-module-mtac-gpiob \
kernel-module-mtac-lora \
@@ -55,7 +61,11 @@ MULTITECH_MTAC = "kernel-module-mtac \
kernel-module-mtac-pulse \
kernel-module-mtac-xdot"
-UPGRADE_FEATURES = "upgrade-reboot mtd-utils-static"
+MULTITECH_BB = ""
+
+# BSP SPECIFIC UPGRADE FEATURES
+UPGRADE_FEATURES = ""
+UPGRADE_FEATURES_mtbsp-at91 = "mtd-utils-static"
CONSOLE = "sysvinit-inittab-start"
@@ -64,6 +74,7 @@ IMAGE_INSTALL = "${CORE_FEATURES} \
${UPGRADE_FEATURES} \
${MULTITECH_FEATURES} \
${MULTITECH_MTAC} \
- ${CONSOLE} \
+ ${MULTITECH_BB} \
+ ${CONSOLE} \
"
diff --git a/recipes-core/images/mlinux-mono-image.bb b/recipes-core/images/mlinux-mono-image.bb
index f15d7d2..d066ae9 100644
--- a/recipes-core/images/mlinux-mono-image.bb
+++ b/recipes-core/images/mlinux-mono-image.bb
@@ -1,3 +1,3 @@
require mlinux-base-image.bb
-IMAGE_INSTALL += "mono mono-helloworld"
+IMAGE_INSTALL_append = " mono mono-helloworld"
diff --git a/recipes-core/images/mlinux-mtcap-debug-image.bb b/recipes-core/images/mlinux-mtcap-debug-image.bb
index 48009ae..13a3518 100644
--- a/recipes-core/images/mlinux-mtcap-debug-image.bb
+++ b/recipes-core/images/mlinux-mtcap-debug-image.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "mLinux Conduit Access Point debug image"
require mlinux-mtcap-image.bb
# Extra stuff to install
-IMAGE_INSTALL += "lora-network-server-mtcap \
+IMAGE_INSTALL_append = " lora-network-server-mtcap \
lora-gateway-utils \
lora-query \
mosquitto mosquitto-clients \
diff --git a/recipes-core/images/mlinux-mtcap-image.bb b/recipes-core/images/mlinux-mtcap-image.bb
index ec161bd..1c0c94f 100644
--- a/recipes-core/images/mlinux-mtcap-image.bb
+++ b/recipes-core/images/mlinux-mtcap-image.bb
@@ -5,18 +5,19 @@ require mtcap-modules.inc
# For now we don't put this in MTR or AEP
# Password restrictions library from Redhat
-IMAGE_INSTALL += "libpwquality"
+IMAGE_INSTALL_append = " libpwquality"
FILESYSTEM_FEATURES = "dosfstools \
cifs-utils \
lsof \
"
-NETWORKING_FEATURES += "bridge-utils \
+NETWORKING_FEATURES_append = " \
+ bridge-utils \
inetutils-ftp \
openssl \
rsync \
- iperf \
+ iperf3 \
mii-diag \
tcpdump \
netcat \
@@ -25,9 +26,6 @@ NETWORKING_FEATURES += "bridge-utils \
busybox-ifplugd \
"
-# No accessory cards for MTAC
-MULTITECH_MTAC = ""
-
TIME_FEATURES = "tzdata tzdata-africa tzdata-americas tzdata-antarctica tzdata-arctic \
tzdata-asia tzdata-atlantic tzdata-australia tzdata-europe tzdata-pacific \
tzdata-misc \
@@ -37,13 +35,12 @@ TIME_FEATURES = "tzdata tzdata-africa tzdata-americas tzdata-antarctica tzdata-a
WIFI_FEATURES = "libnl \
wpa-supplicant \
- wireless-tools \
iw \
- hostap-daemon hostap-utils \
+ hostapd \
wilc1000 \
"
-MULTITECH_FEATURES += " \
+MULTITECH_FEATURES_append = " \
u-boot-linux-utils \
mlinux-scripts \
reset-handler \
@@ -54,7 +51,8 @@ MULTITECH_FEATURES += " \
annex-client \
"
-IMAGE_INSTALL += "lora-gateway-utils \
+IMAGE_INSTALL_append = " \
+ lora-gateway-utils \
lora-query \
lora-packet-forwarder \
lora-network-server \
@@ -68,11 +66,11 @@ MISC_FEATURES = "minicom lrzsz nano lxfp"
# Someday add wifi features
# ${WIFI_FEATURES}
#
-IMAGE_INSTALL += " \
+IMAGE_INSTALL_append = " \
${FILESYSTEM_FEATURES} \
${TIME_FEATURES} \
${MISC_FEATURES} \
"
# Multi-Tech SMS Utility (see http://git.multitech.net)
-IMAGE_INSTALL += "sms-utils"
+IMAGE_INSTALL_append = " sms-utils"
diff --git a/recipes-core/images/mlinux-mtcap-test-image.bb b/recipes-core/images/mlinux-mtcap-test-image.bb
index 58e2448..0d96b4a 100644
--- a/recipes-core/images/mlinux-mtcap-test-image.bb
+++ b/recipes-core/images/mlinux-mtcap-test-image.bb
@@ -45,7 +45,7 @@ WIFI_FEATURES = "libnl \
wpa-supplicant \
wireless-tools \
iw \
- hostap-daemon hostap-utils \
+ hostapd hostap-utils \
wilc1000 \
"
diff --git a/recipes-core/images/mlinux-mtr-image.bb b/recipes-core/images/mlinux-mtr-image.bb
index bf56719..5a557ab 100644
--- a/recipes-core/images/mlinux-mtr-image.bb
+++ b/recipes-core/images/mlinux-mtr-image.bb
@@ -3,18 +3,17 @@ DESCRIPTION = "mLinux base mtr image"
LICENSE = "MIT"
require mlinux-minimal-image.bb
-MULTITECH_MTAC = ""
FILESYSTEM_FEATURES = "dosfstools \
cifs-utils \
lsof \
"
-NETWORKING_FEATURES += "bridge-utils \
+NETWORKING_FEATURES_append = " bridge-utils \
inetutils-ftp \
openssl \
rsync \
- iperf \
+ iperf3 \
mii-diag \
tcpdump \
netcat \
@@ -26,9 +25,8 @@ NETWORKING_FEATURES += "bridge-utils \
WIFI_FEATURES = " \
libnl \
wpa-supplicant \
- wireless-tools \
iw \
- hostap-daemon hostap-utils \
+ hostapd \
"
BLUETOOTH_FEATURES = "bluez5"
@@ -48,7 +46,7 @@ TIME_FEATURES = "tzdata tzdata-africa tzdata-americas tzdata-antarctica tzdata-a
# radio-cmd: supports cellular radio activation and other configuration commands
# radio-query: queries cellular radio for common info (IMEI, RSSI, etc)
# jsparser: command line tool to parse JSON files
-MULTITECH_FEATURES += " \
+MULTITECH_FEATURES_append = " \
u-boot-linux-utils \
mlinux-scripts \
reset-handler \
@@ -59,7 +57,7 @@ MULTITECH_FEATURES += " \
MISC_FEATURES = "minicom lrzsz nano"
# Extra stuff to install
-IMAGE_INSTALL += " \
+IMAGE_INSTALL_append = " \
${WIFI_FEATURES} \
${BLUETOOTH_FEATURES} \
${FILESYSTEM_FEATURES} \
diff --git a/recipes-core/images/mlinux-mtrv1-image.bb b/recipes-core/images/mlinux-mtrv1-image.bb
index cb19add..ff9af34 100644
--- a/recipes-core/images/mlinux-mtrv1-image.bb
+++ b/recipes-core/images/mlinux-mtrv1-image.bb
@@ -3,19 +3,16 @@ DESCRIPTION = "mLinux base mtr image"
LICENSE = "MIT"
require mlinux-minimal-image.bb
-MULTITECH_MTAC = ""
FILESYSTEM_FEATURES = "dosfstools \
cifs-utils \
lsof \
"
-NETWORKING_FEATURES += "bridge-utils \
- dnsmasq \
+NETWORKING_FEATURES_append = " bridge-utils \
inetutils-ftp \
openssl \
rsync \
- iperf \
iperf3 \
mii-diag \
tcpdump \
@@ -28,9 +25,8 @@ NETWORKING_FEATURES += "bridge-utils \
WIFI_FEATURES = " \
libnl \
wpa-supplicant \
- wireless-tools \
iw \
- hostap-daemon hostap-utils \
+ hostapd \
"
BLUETOOTH_FEATURES = "bluez5 bluez5-pand"
@@ -50,7 +46,7 @@ TIME_FEATURES = "tzdata tzdata-africa tzdata-americas tzdata-antarctica tzdata-a
# radio-cmd: supports cellular radio activation and other configuration commands
# radio-query: queries cellular radio for common info (IMEI, RSSI, etc)
# jsparser: command line tool to parse JSON files
-MULTITECH_FEATURES += " \
+MULTITECH_FEATURES_append = " \
u-boot-linux-utils \
mlinux-scripts \
reset-handler \
@@ -61,10 +57,10 @@ MULTITECH_FEATURES += " \
MISC_FEATURES = "minicom lrzsz nano pps-tools"
# Extra stuff to install
-IMAGE_INSTALL += "gpsd libgps libgps24 ntp ntp-utils gpspipe gps-utils"
-IMAGE_INSTALL += "lxfp"
+IMAGE_INSTALL_append = " kernel-module-rs9113 rs9113-util rs9113-autostart"
+IMAGE_INSTALL_append = " gpsd libgps libgps24 ntp ntp-utils gpspipe gps-utils"
-IMAGE_INSTALL += " \
+IMAGE_INSTALL_append = " \
${WIFI_FEATURES} \
${BLUETOOTH_FEATURES} \
${FILESYSTEM_FEATURES} \
diff --git a/recipes-core/images/mlinux-rs9113-base-image.bb b/recipes-core/images/mlinux-rs9113-base-image.bb
index ef565b6..ed2fc83 100644
--- a/recipes-core/images/mlinux-rs9113-base-image.bb
+++ b/recipes-core/images/mlinux-rs9113-base-image.bb
@@ -2,4 +2,4 @@ require mlinux-base-image.bb
DESCRIPTION = "mLinux base image with rs9113 drivers"
# Extra stuff to install
-IMAGE_INSTALL += "kernel-module-rs9113 rs9113-autostart rs9113-util"
+IMAGE_INSTALL_append = " kernel-module-rs9113 rs9113-autostart rs9113-util"
diff --git a/recipes-core/images/mlinux-rs9113-factory-image.bb b/recipes-core/images/mlinux-rs9113-factory-image.bb
index 55a2316..40a4610 100644
--- a/recipes-core/images/mlinux-rs9113-factory-image.bb
+++ b/recipes-core/images/mlinux-rs9113-factory-image.bb
@@ -2,4 +2,4 @@ require mlinux-factory-image.bb
DESCRIPTION = "mLinux factory image with rs9113 drivers"
# Extra stuff to install
-IMAGE_INSTALL += "dnsmasq bluez5-noinst-tools python-dbus kernel-module-rs9113 rs9113-autostart rs9113-util rs9113-misc rs9113-utils-extra"
+IMAGE_INSTALL_append = " dnsmasq bluez5-noinst-tools python-dbus kernel-module-rs9113 rs9113-autostart rs9113-util rs9113-misc rs9113-utils-extra"
diff --git a/recipes-core/images/mlinux-rs9113-mtrv1-image.bb b/recipes-core/images/mlinux-rs9113-mtrv1-image.bb
index 553d9cb..6f77a44 100644
--- a/recipes-core/images/mlinux-rs9113-mtrv1-image.bb
+++ b/recipes-core/images/mlinux-rs9113-mtrv1-image.bb
@@ -30,7 +30,7 @@ WIFI_FEATURES = " \
wpa-supplicant \
wireless-tools \
iw \
- hostap-daemon hostap-utils \
+ hostapd hostap-utils \
"
BLUETOOTH_FEATURES = "bluez5 bluez5-pand"
diff --git a/recipes-core/images/mlinux-sdk.bb b/recipes-core/images/mlinux-sdk.bb
index 0f956bc..abdadbf 100644
--- a/recipes-core/images/mlinux-sdk.bb
+++ b/recipes-core/images/mlinux-sdk.bb
@@ -2,4 +2,4 @@
require mlinux-factory-image.bb
DESCRIPTION = "mLinux SDK"
-IMAGE_INSTALL += "boost i2c-tools"
+IMAGE_INSTALL_append = " boost i2c-tools"
diff --git a/recipes-core/images/mtcap-modules.inc b/recipes-core/images/mtcap-modules.inc
index 8cdfea4..ed3ca51 100644
--- a/recipes-core/images/mtcap-modules.inc
+++ b/recipes-core/images/mtcap-modules.inc
@@ -5,7 +5,7 @@
# modules that are dependency's
# of other modules.
-IMAGE_INSTALL += " \
+IMAGE_INSTALL_append = " \
kernel-module-8021q \
kernel-module-af-alg \
kernel-module-algif-hash \