summaryrefslogtreecommitdiff
path: root/recipes-core/images/mlinux-mtrv1-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/images/mlinux-mtrv1-image.bb')
-rw-r--r--recipes-core/images/mlinux-mtrv1-image.bb16
1 files changed, 6 insertions, 10 deletions
diff --git a/recipes-core/images/mlinux-mtrv1-image.bb b/recipes-core/images/mlinux-mtrv1-image.bb
index cb19add..ff9af34 100644
--- a/recipes-core/images/mlinux-mtrv1-image.bb
+++ b/recipes-core/images/mlinux-mtrv1-image.bb
@@ -3,19 +3,16 @@ DESCRIPTION = "mLinux base mtr image"
LICENSE = "MIT"
require mlinux-minimal-image.bb
-MULTITECH_MTAC = ""
FILESYSTEM_FEATURES = "dosfstools \
cifs-utils \
lsof \
"
-NETWORKING_FEATURES += "bridge-utils \
- dnsmasq \
+NETWORKING_FEATURES_append = " bridge-utils \
inetutils-ftp \
openssl \
rsync \
- iperf \
iperf3 \
mii-diag \
tcpdump \
@@ -28,9 +25,8 @@ NETWORKING_FEATURES += "bridge-utils \
WIFI_FEATURES = " \
libnl \
wpa-supplicant \
- wireless-tools \
iw \
- hostap-daemon hostap-utils \
+ hostapd \
"
BLUETOOTH_FEATURES = "bluez5 bluez5-pand"
@@ -50,7 +46,7 @@ TIME_FEATURES = "tzdata tzdata-africa tzdata-americas tzdata-antarctica tzdata-a
# radio-cmd: supports cellular radio activation and other configuration commands
# radio-query: queries cellular radio for common info (IMEI, RSSI, etc)
# jsparser: command line tool to parse JSON files
-MULTITECH_FEATURES += " \
+MULTITECH_FEATURES_append = " \
u-boot-linux-utils \
mlinux-scripts \
reset-handler \
@@ -61,10 +57,10 @@ MULTITECH_FEATURES += " \
MISC_FEATURES = "minicom lrzsz nano pps-tools"
# Extra stuff to install
-IMAGE_INSTALL += "gpsd libgps libgps24 ntp ntp-utils gpspipe gps-utils"
-IMAGE_INSTALL += "lxfp"
+IMAGE_INSTALL_append = " kernel-module-rs9113 rs9113-util rs9113-autostart"
+IMAGE_INSTALL_append = " gpsd libgps libgps24 ntp ntp-utils gpspipe gps-utils"
-IMAGE_INSTALL += " \
+IMAGE_INSTALL_append = " \
${WIFI_FEATURES} \
${BLUETOOTH_FEATURES} \
${FILESYSTEM_FEATURES} \