summaryrefslogtreecommitdiff
path: root/recipes-connectivity/bluez/python3-gatt-server_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/bluez/python3-gatt-server_1.0.bb')
-rw-r--r--recipes-connectivity/bluez/python3-gatt-server_1.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-connectivity/bluez/python3-gatt-server_1.0.bb b/recipes-connectivity/bluez/python3-gatt-server_1.0.bb
new file mode 100644
index 0000000..712ad3e
--- /dev/null
+++ b/recipes-connectivity/bluez/python3-gatt-server_1.0.bb
@@ -0,0 +1,24 @@
+inherit allarch
+HOMEPAGE = "https://github.com/Jumperr-labs/python-gatt-server"
+SRCREV = "a39ef9773e9ba845f4303b1dfd2efddf24b02238"
+PR = "r0"
+
+S = "${WORKDIR}/git"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c53d04442d1a229d62549856b7ec456a"
+
+SRC_URI = "git://github.com/Jumperr-labs/python-gatt-server.git;protocol=https"
+
+RDEPENDS_${PN} += "python3-dbus python3-pygobject"
+
+DBTEXEC = "${libexecdir}/bluetooth/"
+DEST = "${D}${DBTEXEC}"
+
+FILES_${PN} = "${DBTEXEC}"
+
+
+do_install_append() {
+ install -d ${DEST}/${PN}
+ install -m 0755 ${S}/*.py ${DEST}/${PN}
+}