summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-connectivity/hostapd/hostap-daemon_2.6.bb2
-rw-r--r--recipes-connectivity/openssh/openssh_%.bbappend1
-rw-r--r--recipes-connectivity/ppp/ppp_%.bbappend3
-rw-r--r--recipes-extended/lighttpd/lighttpd_1.4.41.bbappend2
4 files changed, 5 insertions, 3 deletions
diff --git a/recipes-connectivity/hostapd/hostap-daemon_2.6.bb b/recipes-connectivity/hostapd/hostap-daemon_2.6.bb
index e9e0f33..e9e0141 100644
--- a/recipes-connectivity/hostapd/hostap-daemon_2.6.bb
+++ b/recipes-connectivity/hostapd/hostap-daemon_2.6.bb
@@ -32,7 +32,7 @@ do_compile() {
make
}
-CONFFILES_${PN} += "${sysconfdir}/hostapd.conf"
+CONFFILES_${PN} += "${sysconfdir}/hostapd.conf ${sysconfdir}/modprobe.d/cfg80211.conf"
SRC_URI[md5sum] = "eaa56dce9bd8f1d195eb62596eab34c7"
SRC_URI[sha256sum] = "01526b90c1d23bec4b0f052039cc4456c2fd19347b4d830d1d58a0a6aea7117d"
diff --git a/recipes-connectivity/openssh/openssh_%.bbappend b/recipes-connectivity/openssh/openssh_%.bbappend
index 87891c8..53d3da1 100644
--- a/recipes-connectivity/openssh/openssh_%.bbappend
+++ b/recipes-connectivity/openssh/openssh_%.bbappend
@@ -19,3 +19,4 @@ do_install_append() {
ln -sf /var/config/ssh/$f ${D}${sysconfdir}/ssh/$f
done
}
+CONFFILES_${PN}-sshd += "${sysconfdir}/init.d/sshd"
diff --git a/recipes-connectivity/ppp/ppp_%.bbappend b/recipes-connectivity/ppp/ppp_%.bbappend
index 54b2de1..55c47df 100644
--- a/recipes-connectivity/ppp/ppp_%.bbappend
+++ b/recipes-connectivity/ppp/ppp_%.bbappend
@@ -9,7 +9,8 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
FILES_${PN} += "/etc/default/ppp"
-CONFFILES_${PN} += "${sysconfdir}/default/ppp"
+# AEP compatibility
+CONFFILES_${PN} += "${sysconfdir}/default/ppp ${sysconfdir}/init.d/ppp"
do_install_append() {
install -d -m 0755 ${D}/${sysconfdir}/default/
diff --git a/recipes-extended/lighttpd/lighttpd_1.4.41.bbappend b/recipes-extended/lighttpd/lighttpd_1.4.41.bbappend
index 8171f17..d6d4f02 100644
--- a/recipes-extended/lighttpd/lighttpd_1.4.41.bbappend
+++ b/recipes-extended/lighttpd/lighttpd_1.4.41.bbappend
@@ -18,4 +18,4 @@ do_install_append() {
install -m 0644 ${WORKDIR}/lighttpd.default ${D}${sysconfdir}/default/lighttpd
}
-CONFFILES_${PN} += "${sysconfdir}/default/lighttpd ${sysconfdir}/logrotate.d/lighttpd.conf"
+CONFFILES_${PN} += "${sysconfdir}/default/lighttpd ${sysconfdir}/logrotate.d/lighttpd.conf ${sysconfdir}/init.d/lighttpd"