summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--conf/distro/mlinux.conf2
-rw-r--r--recipes-core/multitech/config/config.init37
-rw-r--r--recipes-support/uxfp/uxfp-from-source_1.7.2-0.bb2
3 files changed, 22 insertions, 19 deletions
diff --git a/conf/distro/mlinux.conf b/conf/distro/mlinux.conf
index a89f731..bae3c17 100644
--- a/conf/distro/mlinux.conf
+++ b/conf/distro/mlinux.conf
@@ -36,7 +36,7 @@ DISTRO_EXTRA_RDEPENDS += "mlinux-version"
INHERIT += "mlinux-mirrors"
# Package feed configuration
-DISTRO_FEED_URI = "http://multitech.net/mlinux/feeds/${DISTRO_VERSION}"
+DISTRO_FEED_URI = "https://multitech.net/mlinux/feeds/${DISTRO_VERSION}"
DISTRO_FEED_PREFIX = "mlinux"
EXTRAOPKGCONFIG = ""
diff --git a/recipes-core/multitech/config/config.init b/recipes-core/multitech/config/config.init
index 2a1e0b5..f4611ab 100644
--- a/recipes-core/multitech/config/config.init
+++ b/recipes-core/multitech/config/config.init
@@ -1,5 +1,5 @@
#!/bin/sh
-
+set -x
CONFIG_DIR=/var/config
RUN_CONF_DIR=/run/config
@@ -163,7 +163,7 @@ function copydir {
links+=(${f})
continue
fi
- if ! [[ -f "$to/$f" ]] ; then
+ if ! [[ -f "$to/${newdir}/$f" ]] ; then
cp -a "${f}" "$to/${newdir}/${f}"
fi
done
@@ -222,14 +222,13 @@ case $1 in
# Create links in /etc
for file in $FILES; do
if ! [[ -L /etc/$file ]] && ! [[ -d /etc/$file ]] ; then
- rm -rf /etc/$file
- ln -sf ${CONFIG_DIR}/$file /etc/$file
- elif [[ -d /etc/$file ]] ; then
- # JAK create links in directory.
- linkdir "${CONFIG_DIR}/${file}" "/etc/${file}"
+ rm -rf /etc/$file
+ ln -sf ${CONFIG_DIR}/$file /etc/$file
+ elif [[ -d /etc/$file ]] ; then
+ linkdir "${CONFIG_DIR}/${file}" "/etc/${file}"
fi
done
-
+
# Move bluetooth wifi stuff to config directory.
# We don't have factory defaults.
((dobackup=1))
@@ -248,19 +247,21 @@ case $1 in
# We must copy individual files and create symlinks instead.
for file in ${BTWIFIFILES}; do
isdir=0
- # If last character is /, make the CONFIG directory.
+ # If last character is /, make the CONFIG directory.
if [[ ${file: -1} == / ]] ; then
isdir=1
file=${file%?}
- if ! [[ -d ${CONFIG_DIR}/$file ]] ; then
+ if ! [[ -d ${CONFIG_DIR}/$file ]] ; then
rm -f ${CONFIG_DIR}/$file 2>/dev/null || true
- mkdir ${CONFIG_DIR}/$file
- fi
- if [[ -d ${file} ]] ; then
+ mkdir ${CONFIG_DIR}/$file
+ ln -sf ${CONFIG_DIR}/$file /etc/$file 2>/dev/null || true
+ fi
+
+ if [[ -d ${file} ]] && [[ -d /etc/${file} ]] ; then
copydir "/etc/${file}" "${CONFIG_DIR}"
fi
- fi
-
+ fi
+
if ((isdir == 0)); then
dir=$(dirname $file)
if [[ $dir != '.' ]] ; then
@@ -287,8 +288,10 @@ case $1 in
)
rm -rf old
fi
- rm -rf /etc/$file
- ln -sf ${CONFIG_DIR}/$file /etc/$file
+ if [[ -e /etc/$file ]] ; then
+ rm -rf /etc/$file
+ ln -sf ${CONFIG_DIR}/$file /etc/$file
+ fi
else
if ! [[ -L "/etc/${file}" ]] ; then
rm -f "/etc/${file}/*"
diff --git a/recipes-support/uxfp/uxfp-from-source_1.7.2-0.bb b/recipes-support/uxfp/uxfp-from-source_1.7.2-0.bb
index 64b9b01..f80d7f4 100644
--- a/recipes-support/uxfp/uxfp-from-source_1.7.2-0.bb
+++ b/recipes-support/uxfp/uxfp-from-source_1.7.2-0.bb
@@ -9,7 +9,7 @@ PR = "r1"
SRCREV = "${PV}"
SRC_URI = " \
- git://git@gitlab.multitech.net/vendor-code/uxfp.git;protocol=ssh;branch=master \
+ git://git@${MTS_INTERNAL_GIT}/vendor-code/uxfp.git;protocol=ssh;branch=master \
file://0002-uxfp-add-param-syslog.patch \
"