summaryrefslogtreecommitdiff
path: root/recipes-navigation
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2019-05-22 13:44:38 -0500
committerJohn Klug <john.klug@multitech.com>2019-05-22 13:44:38 -0500
commit066eabf3dc9ec218f16fd988fd2ce2e18cb88c33 (patch)
tree7eac7c4008d77585575e369edcc299abee6ce5cd /recipes-navigation
parenta3287995c52c3d3d7ea70180a6e23492fc645863 (diff)
downloadmeta-mlinux-066eabf3dc9ec218f16fd988fd2ce2e18cb88c33.tar.gz
meta-mlinux-066eabf3dc9ec218f16fd988fd2ce2e18cb88c33.tar.bz2
meta-mlinux-066eabf3dc9ec218f16fd988fd2ce2e18cb88c33.zip
Add MTHS u-blox initialization to mLinux 5
Diffstat (limited to 'recipes-navigation')
-rw-r--r--recipes-navigation/gpsd/gpsd/gpsd-default8
-rw-r--r--recipes-navigation/gpsd/gpsd_3.16.bb2
2 files changed, 9 insertions, 1 deletions
diff --git a/recipes-navigation/gpsd/gpsd/gpsd-default b/recipes-navigation/gpsd/gpsd/gpsd-default
index 7dd5372..fa67fd1 100644
--- a/recipes-navigation/gpsd/gpsd/gpsd-default
+++ b/recipes-navigation/gpsd/gpsd/gpsd-default
@@ -52,6 +52,14 @@ GPSFIX="3"
# should not need to change the baud rate.
#
function SET_GPS_SPEED {
+if [[ $(mts-io-sysfs show hw-version) =~ ^MTHS- ]] ; then
+ if gpsctl -t 'u-blox' -D 5 -x '\x06\x41\x00\x00\x03\x1F\x90\x47\x4F\xB1\xFF\xFF\xEA\xFF' $GPS_LINE ; then
+ logger -s -t 'gpsd info' -p daemon.info "GPS LNA set high"
+ else
+ logger -s -t 'gpsd info' -p daemon.alert "ERROR: GPS LNA not set"
+ fi
+fi
+
if [[ $(cat /run/config/gpstype) == u-blox ]] ; then
# Set the baud rate. Works better with ntp at a higher baud rate.
if ! gpsctl -T 20 -t 'u-blox' -s $GPS_BAUD -b -f $GPS_LINE ; then
diff --git a/recipes-navigation/gpsd/gpsd_3.16.bb b/recipes-navigation/gpsd/gpsd_3.16.bb
index 35719aa..2111399 100644
--- a/recipes-navigation/gpsd/gpsd_3.16.bb
+++ b/recipes-navigation/gpsd/gpsd_3.16.bb
@@ -4,7 +4,7 @@ LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=d217a23f408e91c94359447735bc1800"
DEPENDS = "dbus dbus-glib ncurses python libusb1 chrpath-replacement-native pps-tools"
PROVIDES = "virtual/gpsd"
-PR="m12"
+PR="m13"
EXTRANATIVEPATH += "chrpath-native"