summaryrefslogtreecommitdiff
path: root/recipes-navigation/gpsd/gpsd_3.20.bb
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2022-04-29 14:43:42 -0500
committerJohn Klug <john.klug@multitech.com>2022-04-29 14:43:42 -0500
commit205d9f31d962931bd33f03f78790fd60b8428b13 (patch)
treefa5e09b01b11dae3461b2920c0d4d52ee4ca6b05 /recipes-navigation/gpsd/gpsd_3.20.bb
parentcf909ecf4fa6d14535e9fcaaace73116558e9321 (diff)
downloadmeta-mlinux-205d9f31d962931bd33f03f78790fd60b8428b13.tar.gz
meta-mlinux-205d9f31d962931bd33f03f78790fd60b8428b13.tar.bz2
meta-mlinux-205d9f31d962931bd33f03f78790fd60b8428b13.zip
Fix python issues in mLinux
Diffstat (limited to 'recipes-navigation/gpsd/gpsd_3.20.bb')
-rw-r--r--recipes-navigation/gpsd/gpsd_3.20.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes-navigation/gpsd/gpsd_3.20.bb b/recipes-navigation/gpsd/gpsd_3.20.bb
index 9afe0fe..cc8bd27 100644
--- a/recipes-navigation/gpsd/gpsd_3.20.bb
+++ b/recipes-navigation/gpsd/gpsd_3.20.bb
@@ -148,6 +148,7 @@ do_install_append() {
#support for python
install -d ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
install -m 755 ${S}/gps/*.py ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
+ python3 -m compileall ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
#support for systemd
install -d ${D}${systemd_unitdir}/system/
@@ -184,7 +185,7 @@ pkg_postrm_${PN}-conf() {
}
-PACKAGES =+ "libgps libgpsd gpsd-udev gpsd-conf gpsd-gpsctl gpspipe gps-utils python3-pygps-dbg python3-pygps"
+PACKAGES =+ "libgps libgpsd gpsd-udev gpsd-conf gpsd-gpsctl gpspipe gps-utils python3-pygps-pyc python3-pygps-dbg python3-pygps"
# PACKAGES =+ "${PN} ${PN}-dbg ${PN}-dev"
# File does not exist: ${libdir}/libQgpsmm.prl
@@ -196,6 +197,7 @@ FILES_${PN} += "${sbindir}/gpsd_*"
FILES_${PN}-doc += "${docdir}"
FILES_${PN}-conf = "${sysconfdir}/default ${sysconfdir}/init.d"
+FILES_python3-pygps-pyc = "${PYTHON_SITEPACKAGES_DIR}/gps/__pycache__"
RDEPENDS_${PN}-conf = "gpsd-gpsctl bash"