summaryrefslogtreecommitdiff
path: root/recipes-core/udev/eudev_%.bbappend
diff options
context:
space:
mode:
authorAndrii Davydenko <andrii.davydenko@globallogic.com>2023-01-18 14:28:30 +0200
committerAndrii Davydenko <andrii.davydenko@globallogic.com>2023-01-19 11:30:07 +0200
commit8f0ea44328ccdb64223e369f8be7ca178c6b674a (patch)
tree5b3902d368efab5501bb4825fdf2b55dfb7dd73c /recipes-core/udev/eudev_%.bbappend
parent21d44864d999b06d2204f0d1d9b42adc94b00b7b (diff)
downloadmeta-mlinux-8f0ea44328ccdb64223e369f8be7ca178c6b674a.tar.gz
meta-mlinux-8f0ea44328ccdb64223e369f8be7ca178c6b674a.tar.bz2
meta-mlinux-8f0ea44328ccdb64223e369f8be7ca178c6b674a.zip
Add Sequans udev rule for modem_at1
Rename Main Radio ECM to the wwan0 Rename Control Radio ECM to the wwanmng0
Diffstat (limited to 'recipes-core/udev/eudev_%.bbappend')
-rw-r--r--recipes-core/udev/eudev_%.bbappend7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes-core/udev/eudev_%.bbappend b/recipes-core/udev/eudev_%.bbappend
index a7b0d67..5966524 100644
--- a/recipes-core/udev/eudev_%.bbappend
+++ b/recipes-core/udev/eudev_%.bbappend
@@ -1,17 +1,20 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
RDEPENDS_${PN} += "bash"
-PR .= ".mlinux8"
+PR .= ".mlinux9"
# add custom rules for persistent modem device names
SRC_URI += "file://cellular_radios.rules \
file://cellular_radios.sh \
file://ubi.rules \
- file://${MACHINE}.rules"
+ file://${MACHINE}.rules \
+ file://cellular_radios_cdc_ecm.rules \
+ "
do_install_append() {
install -m 644 ${WORKDIR}/cellular_radios.rules ${D}${sysconfdir}/udev/rules.d/
install -m 644 ${WORKDIR}/${MACHINE}.rules ${D}${sysconfdir}/udev/rules.d/
+ install -m 644 ${WORKDIR}/cellular_radios_cdc_ecm.rules ${D}${sysconfdir}/udev/rules.d/
install -d ${D}${sysconfdir}/udev/scripts
install -m 755 ${WORKDIR}/cellular_radios.sh ${D}${sysconfdir}/udev/scripts/
}