summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrii Davydenko <andrii.davydenko@globallogic.com>2023-01-18 14:28:30 +0200
committerAndrii Davydenko <andrii.davydenko@globallogic.com>2023-01-19 11:30:07 +0200
commit8f0ea44328ccdb64223e369f8be7ca178c6b674a (patch)
tree5b3902d368efab5501bb4825fdf2b55dfb7dd73c
parent21d44864d999b06d2204f0d1d9b42adc94b00b7b (diff)
downloadmeta-mlinux-8f0ea44328ccdb64223e369f8be7ca178c6b674a.tar.gz
meta-mlinux-8f0ea44328ccdb64223e369f8be7ca178c6b674a.tar.bz2
meta-mlinux-8f0ea44328ccdb64223e369f8be7ca178c6b674a.zip
Add Sequans udev rule for modem_at1
Rename Main Radio ECM to the wwan0 Rename Control Radio ECM to the wwanmng0
-rw-r--r--recipes-core/udev/eudev/cellular_radios.rules3
-rw-r--r--recipes-core/udev/eudev/cellular_radios_cdc_ecm.rules11
-rw-r--r--recipes-core/udev/eudev_%.bbappend7
3 files changed, 19 insertions, 2 deletions
diff --git a/recipes-core/udev/eudev/cellular_radios.rules b/recipes-core/udev/eudev/cellular_radios.rules
index 78c5741..e94e835 100644
--- a/recipes-core/udev/eudev/cellular_radios.rules
+++ b/recipes-core/udev/eudev/cellular_radios.rules
@@ -83,5 +83,8 @@ ATTRS{idVendor}=="2c7c", ATTRS{idProduct}=="0195", ENV{ID_IFACE}=="03", SYMLINK+
ATTRS{idVendor}=="2c7c", ATTRS{idProduct}=="0125", ENV{ID_IFACE}=="02", SYMLINK+="modem_at0"
ATTRS{idVendor}=="2c7c", ATTRS{idProduct}=="0125", ENV{ID_IFACE}=="03", SYMLINK+="modem_at1", ACTION=="add", RUN+="/etc/udev/scripts/cellular_radios.sh"
+# Sequans CB610L: ttyACM0
+ATTRS{idVendor}=="258d", ATTRS{idProduct}=="2000", ENV{ID_IFACE}=="02", SYMLINK+="modem_at1", ACTION=="add", RUN+="/etc/udev/scripts/cellular_radios.sh"
+
LABEL="mlinux_end"
diff --git a/recipes-core/udev/eudev/cellular_radios_cdc_ecm.rules b/recipes-core/udev/eudev/cellular_radios_cdc_ecm.rules
new file mode 100644
index 0000000..a6a553a
--- /dev/null
+++ b/recipes-core/udev/eudev/cellular_radios_cdc_ecm.rules
@@ -0,0 +1,11 @@
+ACTION!="add|change|move", GOTO="mlinux_end"
+SUBSYSTEM!="net", GOTO="mlinux_end"
+
+# Main Radio ECM interface of Sequans CB610L
+ATTRS{idVendor}=="258d", ATTRS{idProduct}=="2000", ENV{ID_USB_INTERFACE_NUM}=="00", NAME="wwan0"
+
+# Control Radio ECM interface of Sequans CB610L
+ATTRS{idVendor}=="258d", ATTRS{idProduct}=="2000", ENV{ID_USB_INTERFACE_NUM}=="04", NAME="wwanmng0"
+
+
+LABEL="mlinux_end"
diff --git a/recipes-core/udev/eudev_%.bbappend b/recipes-core/udev/eudev_%.bbappend
index a7b0d67..5966524 100644
--- a/recipes-core/udev/eudev_%.bbappend
+++ b/recipes-core/udev/eudev_%.bbappend
@@ -1,17 +1,20 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
RDEPENDS_${PN} += "bash"
-PR .= ".mlinux8"
+PR .= ".mlinux9"
# add custom rules for persistent modem device names
SRC_URI += "file://cellular_radios.rules \
file://cellular_radios.sh \
file://ubi.rules \
- file://${MACHINE}.rules"
+ file://${MACHINE}.rules \
+ file://cellular_radios_cdc_ecm.rules \
+ "
do_install_append() {
install -m 644 ${WORKDIR}/cellular_radios.rules ${D}${sysconfdir}/udev/rules.d/
install -m 644 ${WORKDIR}/${MACHINE}.rules ${D}${sysconfdir}/udev/rules.d/
+ install -m 644 ${WORKDIR}/cellular_radios_cdc_ecm.rules ${D}${sysconfdir}/udev/rules.d/
install -d ${D}${sysconfdir}/udev/scripts
install -m 755 ${WORKDIR}/cellular_radios.sh ${D}${sysconfdir}/udev/scripts/
}