summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Bayer <bbayer@multitech.com>2016-11-14 14:57:26 -0600
committerBrandon Bayer <bbayer@multitech.com>2016-11-14 14:57:26 -0600
commitfa9d9ac8939b1f123826bec3de08ce615137ecf4 (patch)
tree7b2fa05f196c8c6e10ae7b46c720876d251ba16b
parent46e34ac649528cfb8aaec7bbbb52c775799dcdb1 (diff)
downloadmeta-mlinux-fa9d9ac8939b1f123826bec3de08ce615137ecf4.tar.gz
meta-mlinux-fa9d9ac8939b1f123826bec3de08ce615137ecf4.tar.bz2
meta-mlinux-fa9d9ac8939b1f123826bec3de08ce615137ecf4.zip
fix: only install mtcdt specific lora files on mtcdt
-rw-r--r--recipes-connectivity/lora/lora-gateway_4.0.1.bb7
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb11
2 files changed, 12 insertions, 6 deletions
diff --git a/recipes-connectivity/lora/lora-gateway_4.0.1.bb b/recipes-connectivity/lora/lora-gateway_4.0.1.bb
index 5e269e1..6204e33 100644
--- a/recipes-connectivity/lora/lora-gateway_4.0.1.bb
+++ b/recipes-connectivity/lora/lora-gateway_4.0.1.bb
@@ -6,7 +6,7 @@ SECTION = "console/utils"
LICENSE = "SEMTECH"
LIC_FILES_CHKSUM = "file://LICENSE;md5=a2bdef95625509f821ba00460e3ae0eb"
DEPENDS = ""
-PR = "r8"
+PR = "r9"
SRCREV = "v${PV}"
SRC_URI = "git://github.com/Lora-net/lora_gateway.git;protocol=git \
@@ -42,7 +42,6 @@ do_install() {
install -m 0644 libloragw/readme.md ${D}${libdir}/lora/lora-gw-readme.md
install -d ${D}/opt/lora/
- install -m 0755 ${WORKDIR}/ln-lora-spi-dev.sh ${D}/opt/lora/
install -d ${D}/opt/lora/gateway-utils
install -m 0755 libloragw/test_* ${D}/opt/lora/gateway-utils/
@@ -54,6 +53,10 @@ do_install() {
install -m 0755 util_lbt_test/util_lbt_test ${D}/opt/lora/gateway-utils/
}
+do_install_append_mtcdt() {
+ install -m 0755 ${WORKDIR}/ln-lora-spi-dev.sh ${D}/opt/lora/
+}
+
PACKAGES += "${PN}-utils ${PN}-utils-dbg"
FILES_${PN} = "${libdir}/lora/lora-gw-readme.md"
diff --git a/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb b/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
index b8026c4..834ff6c 100644
--- a/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
+++ b/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
@@ -6,7 +6,7 @@ SECTION = "console/utils"
LICENSE = "SEMTECH"
LIC_FILES_CHKSUM = "file://LICENSE;md5=22af7693d7b76ef0fc76161c4be76c45"
DEPENDS = "lora-gateway"
-PR = "r6"
+PR = "r7"
SRCREV = "v${PV}"
@@ -38,9 +38,6 @@ do_compile() {
do_install() {
install -d ${D}${LORA_DIR}
install -m 755 lora_pkt_fwd/lora_pkt_fwd ${D}${LORA_DIR}/
- install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json
- install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_0.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json.MTAC_LORA_1_0
- install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json.MTAC_LORA_1_5
install -m 755 ${WORKDIR}/local_conf.json ${D}${LORA_DIR}/
install -d ${D}${LORA_DIR}/forwarder-utils
@@ -50,6 +47,12 @@ do_install() {
install -m 755 ${WORKDIR}/README.md ${D}${LORA_DIR}/
}
+do_install_append_mtcdt() {
+ install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json
+ install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_0.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json.MTAC_LORA_1_0
+ install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0 ${D}${LORA_DIR}/global_conf.json.MTAC_LORA_1_5
+}
+
do_install_append_mtcap() {
install -m 755 ${WORKDIR}/global_conf.json.3.0.0.MTCAP-LORA-1-5.EU868.basic ${D}${LORA_DIR}/global_conf.json