summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarsh Sharma <harsh.sharma@multitech.com>2023-04-24 17:09:16 -0500
committerHarsh Sharma <harsh.sharma@multitech.com>2023-04-24 17:09:16 -0500
commitf9f17c1f34ec1bbb75bccb3ac84d358acb038d2e (patch)
tree4cf243ee1a0162e120958aee51180d463470004f
parent853d47b8d01e5c4511ee381fa9bef1bce4710bcd (diff)
downloadmeta-mlinux-f9f17c1f34ec1bbb75bccb3ac84d358acb038d2e.tar.gz
meta-mlinux-f9f17c1f34ec1bbb75bccb3ac84d358acb038d2e.tar.bz2
meta-mlinux-f9f17c1f34ec1bbb75bccb3ac84d358acb038d2e.zip
Updated lora recipes to HEAD
-rw-r--r--recipes-connectivity/lora/lora-basic-station-sx1303_2.0.6-16.bb (renamed from recipes-connectivity/lora/lora-basic-station-sx1303_2.0.6-11.bb)0
-rw-r--r--recipes-connectivity/lora/lora-basic-station_2.0.6-16.bb (renamed from recipes-connectivity/lora/lora-basic-station_2.0.6-11.bb)0
-rw-r--r--recipes-connectivity/lora/lora-gateway-sx1303_2.0.43.bb (renamed from recipes-connectivity/lora/lora-gateway-sx1303_2.0.42.bb)2
-rwxr-xr-xrecipes-connectivity/lora/lora-network-server/lora-network-server.init38
-rw-r--r--recipes-connectivity/lora/lora-network-server_2.6.38.bb (renamed from recipes-connectivity/lora/lora-network-server_2.6.21.bb)0
5 files changed, 21 insertions, 19 deletions
diff --git a/recipes-connectivity/lora/lora-basic-station-sx1303_2.0.6-11.bb b/recipes-connectivity/lora/lora-basic-station-sx1303_2.0.6-16.bb
index 4e48df3..4e48df3 100644
--- a/recipes-connectivity/lora/lora-basic-station-sx1303_2.0.6-11.bb
+++ b/recipes-connectivity/lora/lora-basic-station-sx1303_2.0.6-16.bb
diff --git a/recipes-connectivity/lora/lora-basic-station_2.0.6-11.bb b/recipes-connectivity/lora/lora-basic-station_2.0.6-16.bb
index 7568330..7568330 100644
--- a/recipes-connectivity/lora/lora-basic-station_2.0.6-11.bb
+++ b/recipes-connectivity/lora/lora-basic-station_2.0.6-16.bb
diff --git a/recipes-connectivity/lora/lora-gateway-sx1303_2.0.42.bb b/recipes-connectivity/lora/lora-gateway-sx1303_2.0.43.bb
index 68a6322..774bf5d 100644
--- a/recipes-connectivity/lora/lora-gateway-sx1303_2.0.42.bb
+++ b/recipes-connectivity/lora/lora-gateway-sx1303_2.0.43.bb
@@ -21,7 +21,7 @@ SRC_URI = "git://github.com/MultiTechSystems/sx1302_hal.git;protocol=https;branc
file://global_conf.json.MTCAP3.US915 \
"
-SRC_URI[sha256sum] = "dbfebdee1292e891d32bca52a9ef78b350557383d4d86c96c198e182249aa30f"
+SRC_URI[sha256sum] = "9ec3e31b9f8d4c58d5523219bba6765d88bcdfe0f24a191e9722d7b693a5d2f4"
S = "${WORKDIR}/git"
diff --git a/recipes-connectivity/lora/lora-network-server/lora-network-server.init b/recipes-connectivity/lora/lora-network-server/lora-network-server.init
index 8e2e729..530e9b9 100755
--- a/recipes-connectivity/lora/lora-network-server/lora-network-server.init
+++ b/recipes-connectivity/lora/lora-network-server/lora-network-server.init
@@ -99,24 +99,6 @@ setup_mtcdt3() {
lora_2_id=$lora_id
}
-hardware_found() {
- if [[ "$lora_id" =~ "$lora_mtac_g_id" ]]; then
- setup_mtcdt_2_1
- elif [[ "$lora_id" =~ "$lora_mtac_2g4_id" ]]; then
- setup_mtcdt_2g4
- elif [[ "$lora_id" =~ "$lora_mtac_003_id" ]]; then
- setup_mtcdt003
- elif [[ "$lora_id" =~ "$lora_mtac_id" ]]; then
- setup_mtcdt
- elif [[ "$lora_id" =~ "$lora_mtcap3_id" ]]; then
- setup_mtcap3
- elif [[ "$lora_id" =~ "$lora_mtcap_id" ]]; then
- setup_mtcap
- else
- return 1
- fi
-}
-
setup_mtcdt_2g4() {
mts-io-sysfs store lora/reset 0
mts-io-sysfs store lora/boot 0
@@ -264,6 +246,26 @@ setup_mtcap() {
return 0
}
+
+hardware_found() {
+ if [[ "$lora_id" =~ "$lora_mtac_g_id" ]]; then
+ setup_mtcdt_2_1
+ elif [[ "$lora_id" =~ "$lora_mtac_2g4_id" ]]; then
+ setup_mtcdt_2g4
+ elif [[ "$lora_id" =~ "$lora_mtac_003_id" ]]; then
+ setup_mtcdt003
+ elif [[ "$lora_id" =~ "$lora_mtac_id" ]]; then
+ setup_mtcdt
+ elif [[ "$lora_id" =~ "$lora_mtcap3_id" ]]; then
+ setup_mtcap3
+ elif [[ "$lora_id" =~ "$lora_mtcap_id" ]]; then
+ setup_mtcap
+ else
+ return 1
+ fi
+}
+
+
do_start() {
# create run directory
mkdir -p $run_dir/1
diff --git a/recipes-connectivity/lora/lora-network-server_2.6.21.bb b/recipes-connectivity/lora/lora-network-server_2.6.38.bb
index c7d043b..c7d043b 100644
--- a/recipes-connectivity/lora/lora-network-server_2.6.21.bb
+++ b/recipes-connectivity/lora/lora-network-server_2.6.38.bb