summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykola Salomatin <mykola.salomatin@globallogic.com>2022-01-13 17:00:21 +0200
committerJohn Klug <john.klug@multitech.com>2022-05-26 10:00:50 -0500
commite2ae9b10a5fd2f58b591e35d6a588d75e17923bc (patch)
tree4e625429cbda2f98f9d5b9131725bc7b83fb3ba7
parent475ae9c3f3ba6ce4b2442ce1e56cc1cb20855ddd (diff)
downloadmeta-mlinux-e2ae9b10a5fd2f58b591e35d6a588d75e17923bc.tar.gz
meta-mlinux-e2ae9b10a5fd2f58b591e35d6a588d75e17923bc.tar.bz2
meta-mlinux-e2ae9b10a5fd2f58b591e35d6a588d75e17923bc.zip
[MTX-4319] mPower R.6.0.x: Build process - update scripts to the latest version from Dunfell
Replacing a variable pointing to the root directory due to a change in the build process.
-rw-r--r--classes/mlinux-image.bbclass2
-rw-r--r--recipes-core/mlinux/mlinux-version.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/classes/mlinux-image.bbclass b/classes/mlinux-image.bbclass
index dab5e5b..f89e77a 100644
--- a/classes/mlinux-image.bbclass
+++ b/classes/mlinux-image.bbclass
@@ -15,7 +15,7 @@ ROOTFS_POSTPROCESS_COMMAND += "mlinux_set_root_password;"
# set custom product sw version to /etc/issue file
mlinux_set_product_version () {
PREV_DIR=$(pwd)
- cd "$TOPDIR"
+ cd "${OEROOT}"
PRODUCT_VER=$(git describe)
cd "$PREV_DIR"
PRODUCT_DATE=$(date +%Y-%m-%dT%H:%M:%S)
diff --git a/recipes-core/mlinux/mlinux-version.bb b/recipes-core/mlinux/mlinux-version.bb
index 924b3e0..3960f47 100644
--- a/recipes-core/mlinux/mlinux-version.bb
+++ b/recipes-core/mlinux/mlinux-version.bb
@@ -25,7 +25,7 @@ image_version = "${@define_iv(d)}"
def define_iv(d):
import subprocess
- source_dir = d.getVar('TOPDIR',True) + "/.."
+ source_dir = d.getVar('OEROOT',True)
cmd = "git describe"
proc = subprocess.Popen(cmd, stdout=subprocess.PIPE, shell=True, cwd=source_dir)
out, err = proc.communicate()