summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrii Pientsov <andrii.pientsov@globallogic.com>2021-04-23 09:28:26 +0300
committerAndrii Pientsov <andrii.pientsov@globallogic.com>2021-04-23 09:28:26 +0300
commitab42f333b425d003762342fec447a6e062632a7d (patch)
tree1eb34a91c4728543557214b1e6b8187dc99fc205
parentf60de840658c2fb99f5f22823b5bdeb8e3065bd9 (diff)
parentcdaf8c05b93729f5f26fd21b22d730917618280a (diff)
downloadmeta-mlinux-ab42f333b425d003762342fec447a6e062632a7d.tar.gz
meta-mlinux-ab42f333b425d003762342fec447a6e062632a7d.tar.bz2
meta-mlinux-ab42f333b425d003762342fec447a6e062632a7d.zip
Merge branch 'ap/temp' into mtre-dunfell
-rw-r--r--recipes-core/battd/battd-ml_1.0.bb3
-rwxr-xr-xrecipes-navigation/gpsd/gpsd/gpsd40
-rw-r--r--recipes-navigation/gpsd/gpsd_3.20.bb2
3 files changed, 25 insertions, 20 deletions
diff --git a/recipes-core/battd/battd-ml_1.0.bb b/recipes-core/battd/battd-ml_1.0.bb
index b02d0b8..e4d2da7 100644
--- a/recipes-core/battd/battd-ml_1.0.bb
+++ b/recipes-core/battd/battd-ml_1.0.bb
@@ -5,10 +5,11 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
PROVIDES = "annex-client"
# This is only for ARM
COMPATIBLE_HOST = "(arm-mlinux-linux-gnueabi)"
+RDEPENDS_${PN} += "libcurl"
INSANE_SKIP_${PN} += "build-deps already-stripped ldflags"
-PR = "r1"
+PR = "r2"
TAR_PR = "r1"
SRC_URI = "http://multitech.net/downloads/${PN}_${PV}-${TAR_PR}_${TUNE_PKGARCH}.tar.xz \
"
diff --git a/recipes-navigation/gpsd/gpsd/gpsd b/recipes-navigation/gpsd/gpsd/gpsd
index 36ca387..1f14107 100755
--- a/recipes-navigation/gpsd/gpsd/gpsd
+++ b/recipes-navigation/gpsd/gpsd/gpsd
@@ -38,24 +38,6 @@ CAPABILITY=/sys/devices/platform/mts-io/capability/gps
([[ -n $GPS_LINE ]]) || exit 0
-((numtries = 10))
-if [[ $(cat /run/config/gpstype) == u-blox ]] ; then
- while ((numtries > 0)) ; do
- if [ -c $GPS_LINE ];then
- logger -s -t 'gpsd info' -p daemon.info $GPS_LINE" found"
- break
- fi
- sleep 1
- done
- if ((numtries == 0));then
- logger -s -t 'gpsd info' -p daemon.info $GPS_LINE" not found. gpsd will not start"
- exit 0
- fi
-else
- # Exit if no gps found
- ([[ -c $GPS_LINE ]]) || exit 0
-fi
-
# Assemble the GPS devices
# PPS device is needed so GPSD finds the PPS.
if [[ -c $GPS_PPS ]] ; then
@@ -81,6 +63,28 @@ fi
#
do_start()
{
+ # Don't bother starting GPSD if the device does not exist
+ # Wait a little bit in case the device has not yet
+ # been enumerated.
+ ((numtries = 10))
+ if [[ $(cat /run/config/gpstype) == u-blox ]] ; then
+ while ((numtries > 0)) ; do
+ ((numtries--))
+ if [[ -c $GPS_LINE ]];then
+ logger -s -t 'gpsd info' -p daemon.info $GPS_LINE" found"
+ break
+ fi
+ sleep 1
+ done
+ if ((numtries == 0));then
+ logger -s -t 'gpsd info' -p daemon.info $GPS_LINE" not found. gpsd will not start"
+ exit 0
+ fi
+ else
+ # Exit if no gps found
+ ([[ -c $GPS_LINE ]]) || exit 0
+ fi
+
/usr/sbin/start-stop-daemon -N -20 --start --quiet --pidfile $PIDFILE --exec $DAEMON --test \
-- $GPSD_OPTIONS -P $PIDFILE $GPS_DEVICES > /dev/null \
|| return 1
diff --git a/recipes-navigation/gpsd/gpsd_3.20.bb b/recipes-navigation/gpsd/gpsd_3.20.bb
index ba1b33e..514ca0a 100644
--- a/recipes-navigation/gpsd/gpsd_3.20.bb
+++ b/recipes-navigation/gpsd/gpsd_3.20.bb
@@ -4,7 +4,7 @@ LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=01764c35ae34d9521944bb6ab312af53"
DEPENDS = "dbus dbus-glib ncurses python3 libusb1 chrpath-replacement-native pps-tools"
PROVIDES = "virtual/gpsd"
-PR="m6"
+PR="m7"
#TODO
#the recipe generates python2 pygps package for Atmel based devices and python3 pygps package for TI based devices.