summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesse Gilles <jgilles@multitech.com>2015-05-06 11:26:13 -0500
committerJesse Gilles <jgilles@multitech.com>2015-05-06 11:26:13 -0500
commitaaa961e85d6ad5088d9d8fb5bd6a81df6b3f9d89 (patch)
treeda69baa409ff6b11919fa4affca8a30eb5561ed1
parente4c292e0fb5d2a840b2ce9d4d28875aaf547b93e (diff)
downloadmeta-mlinux-aaa961e85d6ad5088d9d8fb5bd6a81df6b3f9d89.tar.gz
meta-mlinux-aaa961e85d6ad5088d9d8fb5bd6a81df6b3f9d89.tar.bz2
meta-mlinux-aaa961e85d6ad5088d9d8fb5bd6a81df6b3f9d89.zip
jsoncpp: fix dependencies for static lib only
This forces -dev package to pull in -staticdev as well for toolchains
-rw-r--r--recipes-support/jsoncpp/jsoncpp_1.6.0.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes-support/jsoncpp/jsoncpp_1.6.0.bb b/recipes-support/jsoncpp/jsoncpp_1.6.0.bb
index 01a1c2f..80f3f70 100644
--- a/recipes-support/jsoncpp/jsoncpp_1.6.0.bb
+++ b/recipes-support/jsoncpp/jsoncpp_1.6.0.bb
@@ -6,6 +6,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c56ee55c03a55f8105b969d8270632ce"
DEPENDS = ""
BBCLASSEXTEND = "native"
+# static lib only, require staticdev
+RDEPENDS_${PN}-dev = "${PN}-staticdev"
+
#tag 1.6.0
SRCREV="cbe7e7c9cbd39d864588c5cf2436690634562d3f"
@@ -13,7 +16,7 @@ SRC_URI = " git://github.com/open-source-parsers/jsoncpp.git;protocol=git \
file://Makefile \
"
-PR = "r0"
+PR = "r1"
S = "${WORKDIR}/git"
@@ -26,3 +29,6 @@ do_install() {
oe_runmake install DESTDIR=${D}
}
+# this recipe provides dev packages only (static lib)
+PACKAGES = "${PN}-dev ${PN}-staticdev ${PN}-dbg"
+