summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2016-11-29 18:32:38 -0600
committerJohn Klug <john.klug@multitech.com>2016-11-29 18:32:38 -0600
commita9b868c5ffdaf8a8020571a7be61c5c977cba4b4 (patch)
treee93bb397a77ce11778fa7921f10af9900c1ec22a
parentfd8e0a15f32252f38ba36645535b54c33b3bdb18 (diff)
downloadmeta-mlinux-a9b868c5ffdaf8a8020571a7be61c5c977cba4b4.tar.gz
meta-mlinux-a9b868c5ffdaf8a8020571a7be61c5c977cba4b4.tar.bz2
meta-mlinux-a9b868c5ffdaf8a8020571a7be61c5c977cba4b4.zip
Fix udev missing file
-rw-r--r--recipes-navigation/gpsd/gpsd-3.7/udev.patch41
-rw-r--r--recipes-navigation/gpsd/gpsd_3.7.bbappend6
2 files changed, 45 insertions, 2 deletions
diff --git a/recipes-navigation/gpsd/gpsd-3.7/udev.patch b/recipes-navigation/gpsd/gpsd-3.7/udev.patch
new file mode 100644
index 0000000..fdc40cb
--- /dev/null
+++ b/recipes-navigation/gpsd/gpsd-3.7/udev.patch
@@ -0,0 +1,41 @@
+diff -uprN old/60-gpsd.rules new/60-gpsd.rules
+--- old/60-gpsd.rules 2016-11-29 17:43:46.300653070 -0600
++++ new/60-gpsd.rules 2016-11-29 17:47:39.540652577 -0600
+@@ -22,26 +22,26 @@
+ SUBSYSTEM!="tty", GOTO="gpsd_rules_end"
+
+ # Prolific Technology, Inc. PL2303 Serial Port
+-ATTR{idVendor}=="067b", ATTR{idProduct}=="2303", SYMLINK+="gps%n", RUN+="/lib/udev/gpsd.hotplug.wrapper"
++ATTR{idVendor}=="067b", ATTR{idProduct}=="2303", SYMLINK+="gps%n", RUN+="/lib/udev/gpsd.hotplug"
+ # ATEN International Co., Ltd UC-232A Serial Port [pl2303]
+-ATTR{idVendor}=="0557", ATTR{idProduct}=="2008", SYMLINK+="gps%n", RUN+="/lib/udev/gpsd.hotplug.wrapper"
++ATTR{idVendor}=="0557", ATTR{idProduct}=="2008", SYMLINK+="gps%n", RUN+="/lib/udev/gpsd.hotplug"
+ # FTDI 8U232AM
+-ATTR{idVendor}=="0403", ATTR{idProduct}=="6001", SYMLINK+="gps%n", RUN+="/lib/udev/gpsd.hotplug.wrapper"
++ATTR{idVendor}=="0403", ATTR{idProduct}=="6001", SYMLINK+="gps%n", RUN+="/lib/udev/gpsd.hotplug"
+ # Cypress M8/CY7C64013 (DeLorme uses these)
+-ATTR{idVendor}=="1163", ATTR{idProduct}=="0100", SYMLINK+="gps%n", RUN+="/lib/udev/gpsd.hotplug.wrapper"
++ATTR{idVendor}=="1163", ATTR{idProduct}=="0100", SYMLINK+="gps%n", RUN+="/lib/udev/gpsd.hotplug"
+ # PS-360 OEM (Microsoft GPS sold with Street and Trips 2005)
+-ATTR{idVendor}=="067b", ATTR{idProduct}=="aaa0", SYMLINK+="gps%n", RUN+="/lib/udev/gpsd.hotplug.wrapper"
++ATTR{idVendor}=="067b", ATTR{idProduct}=="aaa0", SYMLINK+="gps%n", RUN+="/lib/udev/gpsd.hotplug"
+ # Garmin International GPSmap, various models (tested with Garmin GPS 18 USB)
+-ATTR{idVendor}=="091e", ATTR{idProduct}=="0003", SYMLINK+="gps%n", RUN+="/lib/udev/gpsd.hotplug.wrapper"
++ATTR{idVendor}=="091e", ATTR{idProduct}=="0003", SYMLINK+="gps%n", RUN+="/lib/udev/gpsd.hotplug"
+ # Cygnal Integrated Products, Inc. CP210x Composite Device (Used by Holux m241)
+-ATTR{idVendor}=="10c4", ATTR{idProduct}=="ea60", SYMLINK+="gps%n", RUN+="/lib/udev/gpsd.hotplug.wrapper"
++ATTR{idVendor}=="10c4", ATTR{idProduct}=="ea60", SYMLINK+="gps%n", RUN+="/lib/udev/gpsd.hotplug"
+ # u-blox AG, u-blox 5 (tested with Navilock NL-402U)
+-ATTR{idVendor}=="1546", ATTR{idProduct}=="01a5", SYMLINK="gps%n", RUN+="/lib/udev/gpsd.hotplug.wrapper"
++ATTR{idVendor}=="1546", ATTR{idProduct}=="01a5", SYMLINK="gps%n", RUN+="/lib/udev/gpsd.hotplug"
+ # FTDI FT232
+-ATTR{idVendor}=="0403", ATTR{idProduct}=="6001", SYMLINK="gps%n", RUN+="/lib/udev/gpsd.hotplug.wrapper"
++ATTR{idVendor}=="0403", ATTR{idProduct}=="6001", SYMLINK="gps%n", RUN+="/lib/udev/gpsd.hotplug"
+ # u-blox 4
+-ATTR{idVendor}=="1546", ATTR{idProduct}=="01a4", SYMLINK="gps%n", RUN+="/lib/udev/gpsd.hotplug.wrapper"
++ATTR{idVendor}=="1546", ATTR{idProduct}=="01a4", SYMLINK="gps%n", RUN+="/lib/udev/gpsd.hotplug"
+
+-ACTION=="remove", RUN+="/lib/udev/gpsd.hotplug.wrapper"
++ACTION=="remove", RUN+="/lib/udev/gpsd.hotplug"
+
+ LABEL="gpsd_rules_end"
diff --git a/recipes-navigation/gpsd/gpsd_3.7.bbappend b/recipes-navigation/gpsd/gpsd_3.7.bbappend
index 73b814f..8081b6f 100644
--- a/recipes-navigation/gpsd/gpsd_3.7.bbappend
+++ b/recipes-navigation/gpsd/gpsd_3.7.bbappend
@@ -1,7 +1,9 @@
PR .= ".mlinux1"
-SRC_URI += " file://Conduit.patch;patchdir=.."
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}"
+SRC_URI += " file://Conduit.patch;patchdir=.. \
+ file://udev.patch;patchdir=.. \
+ "
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-${PV}:${THISDIR}/${PN}"
python do_patch_prepend () {
import os