summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerhii Kostiuk <serhii.o.kostiuk@globallogic.com>2023-02-10 14:42:47 +0200
committerSerhii Kostiuk <serhii.o.kostiuk@globallogic.com>2023-02-10 14:42:47 +0200
commita60f89b06926f96d26fdbb3d0106921908c020e6 (patch)
tree586b7123026657a8558cf8ecc5a24036cb3dfb25
parentdea41e6ad307bb9498e50d35c5b17f3c98a8c5e1 (diff)
downloadmeta-mlinux-a60f89b06926f96d26fdbb3d0106921908c020e6.tar.gz
meta-mlinux-a60f89b06926f96d26fdbb3d0106921908c020e6.tar.bz2
meta-mlinux-a60f89b06926f96d26fdbb3d0106921908c020e6.zip
[GP-1733] Disable echo on /dev/modem_at1
Disable the "echo" terminos option for /dev/modem_at1. This change is mandatory for Sequans, becase the Sequans radios do not tolerate garbage in their input.
-rw-r--r--recipes-core/udev/eudev/cellular_radios.sh5
-rw-r--r--recipes-core/udev/eudev_%.bbappend2
2 files changed, 6 insertions, 1 deletions
diff --git a/recipes-core/udev/eudev/cellular_radios.sh b/recipes-core/udev/eudev/cellular_radios.sh
index cb9258b..ee0ba2e 100644
--- a/recipes-core/udev/eudev/cellular_radios.sh
+++ b/recipes-core/udev/eudev/cellular_radios.sh
@@ -13,3 +13,8 @@ if [[ -f $READYFILE ]] ; then
echo 1 >$READYFILE
fi
+# Disable echo for modem_at1. Mandatory for Sequans
+STTY_PATH=/bin/stty
+if [[ -x "$STTY_PATH" && -n "$DEVNAME" ]]; then
+ "$STTY_PATH" -echo -echoe -echok -echoctl -echoke -F "$DEVNAME"
+fi
diff --git a/recipes-core/udev/eudev_%.bbappend b/recipes-core/udev/eudev_%.bbappend
index 5966524..f781c83 100644
--- a/recipes-core/udev/eudev_%.bbappend
+++ b/recipes-core/udev/eudev_%.bbappend
@@ -1,7 +1,7 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
RDEPENDS_${PN} += "bash"
-PR .= ".mlinux9"
+PR .= ".mlinux10"
# add custom rules for persistent modem device names
SRC_URI += "file://cellular_radios.rules \