summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2020-10-05 15:45:57 -0500
committerJohn Klug <john.klug@multitech.com>2020-12-07 15:19:53 -0600
commita1b2411811443a9c96bc32f87290d3c2dba171e7 (patch)
treef1745960deebb0b6d98b42eb0c11cd94cada81c5
parent795e93c0e0cbde494dd1b450ab7d548e78cf9c64 (diff)
downloadmeta-mlinux-a1b2411811443a9c96bc32f87290d3c2dba171e7.tar.gz
meta-mlinux-a1b2411811443a9c96bc32f87290d3c2dba171e7.tar.bz2
meta-mlinux-a1b2411811443a9c96bc32f87290d3c2dba171e7.zip
Fix chat_wrapper so APN can be changed when roaming
-rwxr-xr-xrecipes-core/multitech/config/chat_wrapper2
-rw-r--r--recipes-core/multitech/config_2.3.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes-core/multitech/config/chat_wrapper b/recipes-core/multitech/config/chat_wrapper
index b0bf9e5..c65dd81 100755
--- a/recipes-core/multitech/config/chat_wrapper
+++ b/recipes-core/multitech/config/chat_wrapper
@@ -312,7 +312,7 @@ fi
uptime=$(cat /proc/uptime)
[[ $uptime =~ ^([^\.]*) ]]
t0=${BASH_REMATCH[1]}
-while ! [[ $(/usr/bin/radio-query ${RADIOOPTION} --netreg) =~ ^REGISTERED$ ]] ; do
+while ! [[ $(/usr/bin/radio-query ${RADIOOPTION} --netreg) =~ ^(REGISTERED|ROAMING)$ ]] ; do
sleep 5
((WAITREG++))
uptime=$(cat /proc/uptime)
diff --git a/recipes-core/multitech/config_2.3.bb b/recipes-core/multitech/config_2.3.bb
index 8418207..41187e9 100644
--- a/recipes-core/multitech/config_2.3.bb
+++ b/recipes-core/multitech/config_2.3.bb
@@ -4,7 +4,7 @@ LICENSE = "MIT"
RDEPENDS_${PN} += "bash"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
PACKAGE_ARCH = "all"
-PR = "r10"
+PR = "r11"
PACKAGES =+ "${PN}-mths"
inherit update-rc.d
inherit allarch