summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerhii Kostiuk <serhii.o.kostiuk@globallogic.com>2022-04-08 23:52:45 +0300
committerSerhii Kostiuk <serhii.o.kostiuk@globallogic.com>2022-04-08 23:54:58 +0300
commit91e1c970d923388014ca8cc9467211913c949913 (patch)
tree0c09f8b36bda43208a3312fdc65584aaa788c04a
parent779f85d507620b23c6ff57833036c327310d8cef (diff)
parenta17ae1a9d1f1ff455e23a110d58ae31173f6aea3 (diff)
downloadmeta-mlinux-91e1c970d923388014ca8cc9467211913c949913.tar.gz
meta-mlinux-91e1c970d923388014ca8cc9467211913c949913.tar.bz2
meta-mlinux-91e1c970d923388014ca8cc9467211913c949913.zip
Merge remote-tracking branch 'origin/6' into mpower-dev-nxp
-rw-r--r--recipes-connectivity/lora/lora-gateway-sx1303_2.0.17.bb (renamed from recipes-connectivity/lora/lora-gateway-sx1303_2.0.13.bb)41
-rw-r--r--recipes-connectivity/openssl/openssl/0001-eng_dyn-Avoid-spurious-errors-when-checking-for-3.x-.patch67
-rw-r--r--recipes-connectivity/openssl/openssl_1.1.1n.bb1
3 files changed, 96 insertions, 13 deletions
diff --git a/recipes-connectivity/lora/lora-gateway-sx1303_2.0.13.bb b/recipes-connectivity/lora/lora-gateway-sx1303_2.0.17.bb
index 3bf2442..312eda4 100644
--- a/recipes-connectivity/lora/lora-gateway-sx1303_2.0.13.bb
+++ b/recipes-connectivity/lora/lora-gateway-sx1303_2.0.17.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "LoRa Packet Forwarder"
-HOMEPAGE = "https://github.com/Lora-net/sx1302_hal"
+HOMEPAGE = "https://github.com/MultiTechSystems/sx1302_hal"
PRIORITY = "optional"
SECTION = "console/utils"
# Semtech license is a modified BSD-style license
@@ -7,18 +7,21 @@ LICENSE = "Proprietary"
LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=d2119120bd616e725f4580070bd9ee19"
DEPENDS = "logrotate"
RDEPENDS_${PN} += "bash"
-PR = "r0"
-#SRCREV = "100104ee350a0e469b348ac383486d311caaf5e5"
+PR = "r6"
+
SRCREV = "V${PV}"
SRC_URI = "git://github.com/MultiTechSystems/sx1302_hal.git;protocol=https;branch=master \
+ file://reset_lgw.sh \
file://global_conf.json.MTAC_003_0_0.EU868 \
file://global_conf.json.MTAC_003_0_0.US915 \
file://global_conf.json.MTCAP3.EU868 \
file://global_conf.json.MTCAP3.US915 \
"
+SRC_URI[sha256sum] = "6499b73e97cb3e97fcfc02f4ebeee78cf273ccfec7f2221e2b1b9d1f02e7d408"
+
S = "${WORKDIR}/git"
B = "${S}"
@@ -26,7 +29,7 @@ B = "${S}"
LORA_DIR = "/opt/lora"
-CFLAGS += " -I${S}/packet_forwarder/inc -I${S}/libloragw/inc -I${S}/libtools/inc -I${S}/inc -I. -std=gnu11"
+CFLAGS += "-DNODEBUG -I${S}/packet_forwarder/inc -I${S}/libloragw/inc -I${S}/libtools/inc -I${S}/inc -I. -std=gnu11"
do_compile() {
oe_runmake packet_forwarder LDFLAGS=${LDFLAGS}
@@ -38,8 +41,17 @@ do_compile() {
do_install() {
install -d ${D}${LORA_DIR}
+ install -d ${D}${libdir}/lora
+ install -d ${D}${libdir}/lora/lgw-sx1303/lgw
+ install -d ${D}${includedir}/lora/lgw-sx1303/lgw
+
+ install -m 0644 libloragw/libloragw.a ${D}${libdir}/lora/lgw-sx1303/lgw/
+ install -m 0644 libloragw/library.cfg ${D}${libdir}/lora/lgw-sx1303/lgw/
+ install -m 0644 libloragw/inc/* ${D}${includedir}/lora/lgw-sx1303/lgw/
+
install -d ${D}${LORA_DIR}/forwarder-utils-sx1303
install -d ${D}${LORA_DIR}/gateway-utils-sx1303
+ install -m 755 ${WORKDIR}/reset_lgw.sh ${D}${LORA_DIR}/
install -m 755 packet_forwarder/lora_pkt_fwd ${D}${LORA_DIR}/lora_pkt_fwd_sx1303
install -m 755 libloragw/test_loragw* ${D}${LORA_DIR}/gateway-utils-sx1303/
install -m 755 util_boot/boot ${D}${LORA_DIR}/forwarder-utils-sx1303/util_boot
@@ -49,23 +61,27 @@ do_install() {
}
do_install_append_mtcdt() {
- install -m 644 ${WORKDIR}/global_conf.json.MTAC_003_0_0.EU868 ${D}${LORA_DIR}/global_conf.json.MTAC_003_0_0.EU868
- install -m 644 ${WORKDIR}/global_conf.json.MTAC_003_0_0.US915 ${D}${LORA_DIR}/global_conf.json.MTAC_003_0_0.US915
+ install -m 755 ${WORKDIR}/global_conf.json.MTAC_003_0_0.EU868 ${D}${LORA_DIR}/
+ install -m 755 ${WORKDIR}/global_conf.json.MTAC_003_0_0.US915 ${D}${LORA_DIR}/
}
do_install_append_mtcap() {
- install -m 644 ${WORKDIR}/global_conf.json.MTCAP3.EU868 ${D}${LORA_DIR}/global_conf.json.MTCAP3.EU868
- install -m 644 ${WORKDIR}/global_conf.json.MTCAP3.US915 ${D}${LORA_DIR}/global_conf.json.MTCAP3.US915
+}
+
+
+do_install_append_mtcap3() {
+ install -m 755 ${WORKDIR}/global_conf.json.MTCAP3.EU868 ${D}${LORA_DIR}/
+ install -m 755 ${WORKDIR}/global_conf.json.MTCAP3.US915 ${D}${LORA_DIR}/
}
do_install_append_mtcdt3() {
- install -m 644 ${WORKDIR}/global_conf.json.MTAC_003_0_0.EU868 ${D}${LORA_DIR}/global_conf.json.MTAC_003_0_0.EU868
- install -m 644 ${WORKDIR}/global_conf.json.MTAC_003_0_0.US915 ${D}${LORA_DIR}/global_conf.json.MTAC_003_0_0.US915
+ install -m 755 ${WORKDIR}/global_conf.json.MTAC_003_0_0.EU868 ${D}${LORA_DIR}/
+ install -m 755 ${WORKDIR}/global_conf.json.MTAC_003_0_0.US915 ${D}${LORA_DIR}/
}
do_install_append_mtcdt3hs() {
- install -m 644 ${WORKDIR}/global_conf.json.MTAC_003_0_0.EU868 ${D}${LORA_DIR}/global_conf.json.MTAC_003_0_0.EU868
- install -m 644 ${WORKDIR}/global_conf.json.MTAC_003_0_0.US915 ${D}${LORA_DIR}/global_conf.json.MTAC_003_0_0.US915
+ install -m 755 ${WORKDIR}/global_conf.json.MTAC_003_0_0.EU868 ${D}${LORA_DIR}/
+ install -m 755 ${WORKDIR}/global_conf.json.MTAC_003_0_0.US915 ${D}${LORA_DIR}/
}
@@ -74,5 +90,4 @@ FILES_${PN} += "${LORA_DIR}"
# disable this on purpose for dev purposes
do_rm_work() {
echo "skipping"
-
}
diff --git a/recipes-connectivity/openssl/openssl/0001-eng_dyn-Avoid-spurious-errors-when-checking-for-3.x-.patch b/recipes-connectivity/openssl/openssl/0001-eng_dyn-Avoid-spurious-errors-when-checking-for-3.x-.patch
new file mode 100644
index 0000000..c074d30
--- /dev/null
+++ b/recipes-connectivity/openssl/openssl/0001-eng_dyn-Avoid-spurious-errors-when-checking-for-3.x-.patch
@@ -0,0 +1,67 @@
+From d6bf4a2218aeb246ba7d34f02e895c37569c8265 Mon Sep 17 00:00:00 2001
+From: Tomas Mraz <tomas@openssl.org>
+Date: Wed, 16 Mar 2022 12:09:52 +0100
+Subject: [PATCH] eng_dyn: Avoid spurious errors when checking for 3.x engine
+
+Reviewed-by: Paul Dale <pauli@openssl.org>
+Reviewed-by: Richard Levitte <levitte@openssl.org>
+(Merged from https://github.com/openssl/openssl/pull/17902)
+---
+ crypto/engine/eng_dyn.c | 33 ++++++++++++++++++++++-----------
+ 1 file changed, 22 insertions(+), 11 deletions(-)
+
+diff --git a/crypto/engine/eng_dyn.c b/crypto/engine/eng_dyn.c
+index 6a0ddc162d..27d7b893cd 100644
+--- a/crypto/engine/eng_dyn.c
++++ b/crypto/engine/eng_dyn.c
+@@ -393,6 +393,26 @@ static int int_load(dynamic_data_ctx *ctx)
+ return 0;
+ }
+
++/*
++ * Unfortunately the version checker does not distinguish between
++ * engines built for openssl 1.1.x and openssl 3.x, but loading
++ * an engine that is built for openssl 3.x will cause a fatal
++ * error. Detect such engines, since EVP_PKEY_get_base_id is exported
++ * as a function in openssl 3.x, while it is named EVP_PKEY_base_id
++ * in openssl 1.1.x. Therefore we take the presence of that symbol
++ * as an indication that the engine will be incompatible.
++ */
++static int using_libcrypto_3(dynamic_data_ctx *ctx)
++{
++ int ret;
++
++ ERR_set_mark();
++ ret = DSO_bind_func(ctx->dynamic_dso, "EVP_PKEY_get_base_id") != NULL;
++ ERR_pop_to_mark();
++
++ return ret;
++}
++
+ static int dynamic_load(ENGINE *e, dynamic_data_ctx *ctx)
+ {
+ ENGINE cpy;
+@@ -442,18 +462,9 @@ static int dynamic_load(ENGINE *e, dynamic_data_ctx *ctx)
+ /*
+ * We fail if the version checker veto'd the load *or* if it is
+ * deferring to us (by returning its version) and we think it is too
+- * old.
+- * Unfortunately the version checker does not distinguish between
+- * engines built for openssl 1.1.x and openssl 3.x, but loading
+- * an engine that is built for openssl 3.x will cause a fatal
+- * error. Detect such engines, since EVP_PKEY_get_base_id is exported
+- * as a function in openssl 3.x, while it is named EVP_PKEY_base_id
+- * in openssl 1.1.x. Therefore we take the presence of that symbol
+- * as an indication that the engine will be incompatible.
++ * old. Also fail if this is engine for openssl 3.x.
+ */
+- if (vcheck_res < OSSL_DYNAMIC_OLDEST
+- || DSO_bind_func(ctx->dynamic_dso,
+- "EVP_PKEY_get_base_id") != NULL) {
++ if (vcheck_res < OSSL_DYNAMIC_OLDEST || using_libcrypto_3(ctx)) {
+ /* Fail */
+ ctx->bind_engine = NULL;
+ ctx->v_check = NULL;
+--
+2.25.1
+
diff --git a/recipes-connectivity/openssl/openssl_1.1.1n.bb b/recipes-connectivity/openssl/openssl_1.1.1n.bb
index f3a2c54..434e7b1 100644
--- a/recipes-connectivity/openssl/openssl_1.1.1n.bb
+++ b/recipes-connectivity/openssl/openssl_1.1.1n.bb
@@ -15,6 +15,7 @@ SRC_URI = "https://www.openssl.org/source/openssl-${PV}.tar.gz \
file://run-ptest \
file://0001-skip-test_symbol_presence.patch \
file://0001-buildinfo-strip-sysroot-and-debug-prefix-map-from-co.patch \
+ file://0001-eng_dyn-Avoid-spurious-errors-when-checking-for-3.x-.patch \
file://afalg.patch \
file://reproducible.patch \
"