summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2016-01-05 06:33:04 -0600
committerJason Reiss <jreiss@multitech.com>2016-01-05 06:33:04 -0600
commit7193104631cac5d083e02056511b846f167d242e (patch)
tree4817cd5fbb82bae57d7a071361e18436a19bc7ca
parentf2b5fd28cafcf404de44815044473a12bcbab1b5 (diff)
parent6fdc767120dde86367ba06af3e4fab37e7357d8e (diff)
downloadmeta-mlinux-7193104631cac5d083e02056511b846f167d242e.tar.gz
meta-mlinux-7193104631cac5d083e02056511b846f167d242e.tar.bz2
meta-mlinux-7193104631cac5d083e02056511b846f167d242e.zip
Merge branch 'master' of git://git.multitech.net/meta-mlinux
-rw-r--r--recipes-extended/multitech/sms-utils_0.0.10.bb (renamed from recipes-extended/multitech/sms-utils_0.0.8.bb)0
-rw-r--r--recipes-support/multitech/libmts-io_0.2.bb30
-rw-r--r--recipes-support/multitech/radio-cmd_0.3.bb22
3 files changed, 52 insertions, 0 deletions
diff --git a/recipes-extended/multitech/sms-utils_0.0.8.bb b/recipes-extended/multitech/sms-utils_0.0.10.bb
index a6177d7..a6177d7 100644
--- a/recipes-extended/multitech/sms-utils_0.0.8.bb
+++ b/recipes-extended/multitech/sms-utils_0.0.10.bb
diff --git a/recipes-support/multitech/libmts-io_0.2.bb b/recipes-support/multitech/libmts-io_0.2.bb
new file mode 100644
index 0000000..34115be
--- /dev/null
+++ b/recipes-support/multitech/libmts-io_0.2.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "MultiTech IO C++ Library"
+HOMEPAGE = "http://www.multitech.net/"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
+
+DEPENDS = "libmts jsoncpp cmake-native cppunit"
+BBCLASSEXTEND = "native"
+
+PR = "r0"
+SRCREV = "${PV}"
+SRC_URI = "git://git.multitech.net/libmts-io;branch=master"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ oe_runmake
+}
+
+# build and run tests for native recipe
+do_compile_append_virtclass-native() {
+ cd test
+ cmake .
+ oe_runmake
+ ./TestRunnerClient
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
diff --git a/recipes-support/multitech/radio-cmd_0.3.bb b/recipes-support/multitech/radio-cmd_0.3.bb
new file mode 100644
index 0000000..b8e5b23
--- /dev/null
+++ b/recipes-support/multitech/radio-cmd_0.3.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "MultiTech cellular radio command tool"
+HOMEPAGE = "http://www.multitech.net/"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+DEPENDS = "jsoncpp libmts libmts-io"
+
+PR = "r0"
+SRCREV = "${PV}"
+
+SRC_URI = "git://git.multitech.net/radio-cmd;branch=master"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+