summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2019-08-21 08:35:26 -0500
committerSerhii Kostiuk <serhii.o.kostiuk@globallogic.com>2020-05-20 19:50:20 +0300
commit6d50fe8666bbd1b9b739b5317e083a4c4c0b924b (patch)
tree18fa8b05db9ce84f11b26f35d0e2fd80cc4d6d04
parent92d476cc9a981de849883f07b07927e99c8072be (diff)
downloadmeta-mlinux-6d50fe8666bbd1b9b739b5317e083a4c4c0b924b.tar.gz
meta-mlinux-6d50fe8666bbd1b9b739b5317e083a4c4c0b924b.tar.bz2
meta-mlinux-6d50fe8666bbd1b9b739b5317e083a4c4c0b924b.zip
lora: remove tmp files, update geolocation
-rw-r--r--recipes-connectivity/lora/lora-gateway-geolocation_5.1.0.bb3
-rw-r--r--recipes-connectivity/lora/lora-gateway_5.0.1.bb12
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder-geolocation_5.1.0.bb3
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.AS923-LBT.basic.clksrc0~227
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.AS923.basic.clksrc0~195
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0~190
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.IN865.basic.clksrc0~196
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.KR920-LBT.basic.clksrc0~226
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.RU864.basic.clksrc0~191
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb13
10 files changed, 14 insertions, 1242 deletions
diff --git a/recipes-connectivity/lora/lora-gateway-geolocation_5.1.0.bb b/recipes-connectivity/lora/lora-gateway-geolocation_5.1.0.bb
index 424ea43..21a1eec 100644
--- a/recipes-connectivity/lora/lora-gateway-geolocation_5.1.0.bb
+++ b/recipes-connectivity/lora/lora-gateway-geolocation_5.1.0.bb
@@ -27,6 +27,9 @@ do_compile() {
}
do_install() {
+}
+
+do_install_append_mtcdt() {
install -d ${D}${includedir}/lora
install -d ${D}${libdir}/lora
install -m 0644 mlinux4/libsx1301ar/* ${D}${includedir}/lora
diff --git a/recipes-connectivity/lora/lora-gateway_5.0.1.bb b/recipes-connectivity/lora/lora-gateway_5.0.1.bb
index 23538a9..d31c439 100644
--- a/recipes-connectivity/lora/lora-gateway_5.0.1.bb
+++ b/recipes-connectivity/lora/lora-gateway_5.0.1.bb
@@ -7,18 +7,12 @@ LICENSE = "Proprietary"
LIC_FILES_CHKSUM = "file://LICENSE;md5=a2bdef95625509f821ba00460e3ae0eb"
DEPENDS = "libgps24"
RDEPENDS_${PN} = "libgps24"
-PR = "r11"
-SRCREV = "v${PV}"
+PR = "r12"
+SRCREV = "1e66084295f37f0d7f5f0a3518e43ae0cc613898"
-SRC_URI = "git://github.com/Lora-net/lora_gateway.git;protocol=git \
- file://lora-gateway-add-fpga-version-28-31-33.patch \
+SRC_URI = "git://git@gitlab.multitech.net/lora_enterprise/lora_gateway_mtac_full.git;protocol=ssh;branch=master \
file://library_4.0.cfg \
- file://lora-gateway-add-spi-path-function.patch \
file://ln-lora-spi-dev.sh \
- file://lora-gateway-change-util-tx-continuous-clksrc.patch \
- file://lora-gateway-v28-skip-IQ-invert.patch \
- file://lora-gateway-spectral-scan-skip-fpga-reset.patch \
- file://lora-gateway-gpsd.patch \
"
SRC_URI[md5sum] = "9e06a3733a9fea39a3d61f77b412badf"
diff --git a/recipes-connectivity/lora/lora-packet-forwarder-geolocation_5.1.0.bb b/recipes-connectivity/lora/lora-packet-forwarder-geolocation_5.1.0.bb
index 34a18a1..193fcf7 100644
--- a/recipes-connectivity/lora/lora-packet-forwarder-geolocation_5.1.0.bb
+++ b/recipes-connectivity/lora/lora-packet-forwarder-geolocation_5.1.0.bb
@@ -41,6 +41,9 @@ do_compile() {
}
do_install() {
+}
+
+do_install_append_mtcdt() {
install -d ${D}${LORA_DIR}
install -m 755 mlinux4/pkt_forwarder ${D}${LORA_DIR}/
install -m 755 ${WORKDIR}/global_conf.json.MTAC_LORA_2_1* ${D}${LORA_DIR}/
diff --git a/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.AS923-LBT.basic.clksrc0~ b/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.AS923-LBT.basic.clksrc0~
deleted file mode 100644
index fe57b24..0000000
--- a/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.AS923-LBT.basic.clksrc0~
+++ /dev/null
@@ -1,227 +0,0 @@
-{
- "SX1301_conf": {
- "antenna_gain": 0,
- "chan_FSK": {
- "bandwidth": 125000,
- "datarate": 50000,
- "enable": true,
- "freq_deviation": 25000,
- "if": 300000,
- "radio": 0
- },
- "chan_Lora_std": {
- "bandwidth": 250000,
- "enable": true,
- "if": -200000,
- "radio": 0,
- "spread_factor": 7
- },
- "chan_multiSF_0": {
- "enable": true,
- "if": -400000,
- "radio": 0
- },
- "chan_multiSF_1": {
- "enable": true,
- "if": -200000,
- "radio": 0
- },
- "chan_multiSF_2": {
- "enable": true,
- "if": 0,
- "radio": 0
- },
- "chan_multiSF_3": {
- "enable": true,
- "if": -400000,
- "radio": 1
- },
- "chan_multiSF_4": {
- "enable": true,
- "if": -200000,
- "radio": 1
- },
- "chan_multiSF_5": {
- "enable": true,
- "if": 0,
- "radio": 1
- },
- "chan_multiSF_6": {
- "enable": true,
- "if": 200000,
- "radio": 1
- },
- "chan_multiSF_7": {
- "enable": true,
- "if": 400000,
- "radio": 1
- },
- "clksrc": 0,
- "lbt_cfg": {
- "chan_cfg": [
- {
- "freq_hz": 923200000,
- "scan_time_us": 5000
- },
- {
- "freq_hz": 923400000,
- "scan_time_us": 5000
- },
- {
- "freq_hz": 923600000,
- "scan_time_us": 5000
- },
- {
- "freq_hz": 922200000,
- "scan_time_us": 5000
- },
- {
- "freq_hz": 922400000,
- "scan_time_us": 5000
- },
- {
- "freq_hz": 922600000,
- "scan_time_us": 5000
- },
- {
- "freq_hz": 922800000,
- "scan_time_us": 5000
- },
- {
- "freq_hz": 923000000,
- "scan_time_us": 5000
- }
- ],
- "enable": true,
- "rssi_target": -80,
- "sx127x_rssi_offset": -4
- },
- "lorawan_public": true,
- "radio_0": {
- "enable": true,
- "freq": 923600000,
- "rssi_offset": -162,
- "tx_enable": true,
- "tx_freq_max": 928000000,
- "tx_freq_min": 920000000,
- "type": "SX1257"
- },
- "radio_1": {
- "enable": true,
- "freq": 922600000,
- "rssi_offset": -162,
- "tx_enable": false,
- "type": "SX1257"
- },
- "tx_lut_0": {
- "dig_gain": 3,
- "mix_gain": 8,
- "pa_gain": 0,
- "rf_power": -6
- },
- "tx_lut_1": {
- "dig_gain": 3,
- "mix_gain": 10,
- "pa_gain": 0,
- "rf_power": -3
- },
- "tx_lut_10": {
- "dig_gain": 3,
- "mix_gain": 11,
- "pa_gain": 2,
- "rf_power": 16
- },
- "tx_lut_11": {
- "dig_gain": 3,
- "mix_gain": 10,
- "pa_gain": 3,
- "rf_power": 20
- },
- "tx_lut_12": {
- "dig_gain": 3,
- "mix_gain": 11,
- "pa_gain": 3,
- "rf_power": 23
- },
- "tx_lut_13": {
- "dig_gain": 3,
- "mix_gain": 12,
- "pa_gain": 3,
- "rf_power": 24
- },
- "tx_lut_14": {
- "dig_gain": 3,
- "mix_gain": 13,
- "pa_gain": 3,
- "rf_power": 25
- },
- "tx_lut_15": {
- "dig_gain": 3,
- "mix_gain": 15,
- "pa_gain": 3,
- "rf_power": 26
- },
- "tx_lut_2": {
- "dig_gain": 3,
- "mix_gain": 12,
- "pa_gain": 0,
- "rf_power": 0
- },
- "tx_lut_3": {
- "dig_gain": 3,
- "mix_gain": 8,
- "pa_gain": 1,
- "rf_power": 3
- },
- "tx_lut_4": {
- "dig_gain": 3,
- "mix_gain": 10,
- "pa_gain": 1,
- "rf_power": 6
- },
- "tx_lut_5": {
- "dig_gain": 3,
- "mix_gain": 12,
- "pa_gain": 1,
- "rf_power": 10
- },
- "tx_lut_6": {
- "dig_gain": 3,
- "mix_gain": 12,
- "pa_gain": 1,
- "rf_power": 11
- },
- "tx_lut_7": {
- "dig_gain": 3,
- "mix_gain": 9,
- "pa_gain": 2,
- "rf_power": 12
- },
- "tx_lut_8": {
- "dig_gain": 3,
- "mix_gain": 15,
- "pa_gain": 1,
- "rf_power": 13
- },
- "tx_lut_9": {
- "dig_gain": 3,
- "mix_gain": 10,
- "pa_gain": 2,
- "rf_power": 14
- }
- },
- "gateway_conf": {
- "gateway_ID": "<WILL-BE-AUTO-REPLACED-WITH-LORA-EUI>",
- "server_address": "52.3.215.147",
- "serv_port_up": 20000,
- "serv_port_down": 20000,
- "forward_crc_disabled": false,
- "forward_crc_error": true,
- "forward_crc_valid": true,
- "keepalive_interval": 10,
- "push_timeout_ms": 120,
- "stat_interval": 20,
- "synch_word": 52,
- "autoquit_threshold": 60
- }
-}
diff --git a/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.AS923.basic.clksrc0~ b/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.AS923.basic.clksrc0~
deleted file mode 100644
index 2f01b16..0000000
--- a/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.AS923.basic.clksrc0~
+++ /dev/null
@@ -1,195 +0,0 @@
-{
- "SX1301_conf": {
- "antenna_gain": 0,
- "chan_FSK": {
- "bandwidth": 125000,
- "datarate": 50000,
- "enable": true,
- "freq_deviation": 25000,
- "if": 300000,
- "radio": 0
- },
- "chan_Lora_std": {
- "bandwidth": 250000,
- "enable": true,
- "if": -200000,
- "radio": 0,
- "spread_factor": 7
- },
- "chan_multiSF_0": {
- "enable": true,
- "if": -400000,
- "radio": 0
- },
- "chan_multiSF_1": {
- "enable": true,
- "if": -200000,
- "radio": 0
- },
- "chan_multiSF_2": {
- "enable": true,
- "if": 0,
- "radio": 0
- },
- "chan_multiSF_3": {
- "enable": true,
- "if": -400000,
- "radio": 1
- },
- "chan_multiSF_4": {
- "enable": true,
- "if": -200000,
- "radio": 1
- },
- "chan_multiSF_5": {
- "enable": true,
- "if": 0,
- "radio": 1
- },
- "chan_multiSF_6": {
- "enable": true,
- "if": 200000,
- "radio": 1
- },
- "chan_multiSF_7": {
- "enable": true,
- "if": 400000,
- "radio": 1
- },
- "clksrc": 0,
- "lbt_cfg": {
- "chan_cfg": [
- ],
- "enable": false,
- "rssi_target": -80,
- "sx127x_rssi_offset": -4
- },
- "lorawan_public": true,
- "radio_0": {
- "enable": true,
- "freq": 923600000,
- "rssi_offset": -162,
- "tx_enable": true,
- "tx_freq_max": 928000000,
- "tx_freq_min": 920000000,
- "type": "SX1257"
- },
- "radio_1": {
- "enable": true,
- "freq": 922600000,
- "rssi_offset": -162,
- "tx_enable": false,
- "type": "SX1257"
- },
- "tx_lut_0": {
- "dig_gain": 3,
- "mix_gain": 8,
- "pa_gain": 0,
- "rf_power": -6
- },
- "tx_lut_1": {
- "dig_gain": 3,
- "mix_gain": 10,
- "pa_gain": 0,
- "rf_power": -3
- },
- "tx_lut_10": {
- "dig_gain": 3,
- "mix_gain": 11,
- "pa_gain": 2,
- "rf_power": 16
- },
- "tx_lut_11": {
- "dig_gain": 3,
- "mix_gain": 10,
- "pa_gain": 3,
- "rf_power": 20
- },
- "tx_lut_12": {
- "dig_gain": 3,
- "mix_gain": 11,
- "pa_gain": 3,
- "rf_power": 23
- },
- "tx_lut_13": {
- "dig_gain": 3,
- "mix_gain": 12,
- "pa_gain": 3,
- "rf_power": 24
- },
- "tx_lut_14": {
- "dig_gain": 3,
- "mix_gain": 13,
- "pa_gain": 3,
- "rf_power": 25
- },
- "tx_lut_15": {
- "dig_gain": 3,
- "mix_gain": 15,
- "pa_gain": 3,
- "rf_power": 26
- },
- "tx_lut_2": {
- "dig_gain": 3,
- "mix_gain": 12,
- "pa_gain": 0,
- "rf_power": 0
- },
- "tx_lut_3": {
- "dig_gain": 3,
- "mix_gain": 8,
- "pa_gain": 1,
- "rf_power": 3
- },
- "tx_lut_4": {
- "dig_gain": 3,
- "mix_gain": 10,
- "pa_gain": 1,
- "rf_power": 6
- },
- "tx_lut_5": {
- "dig_gain": 3,
- "mix_gain": 12,
- "pa_gain": 1,
- "rf_power": 10
- },
- "tx_lut_6": {
- "dig_gain": 3,
- "mix_gain": 12,
- "pa_gain": 1,
- "rf_power": 11
- },
- "tx_lut_7": {
- "dig_gain": 3,
- "mix_gain": 9,
- "pa_gain": 2,
- "rf_power": 12
- },
- "tx_lut_8": {
- "dig_gain": 3,
- "mix_gain": 15,
- "pa_gain": 1,
- "rf_power": 13
- },
- "tx_lut_9": {
- "dig_gain": 3,
- "mix_gain": 10,
- "pa_gain": 2,
- "rf_power": 14
- }
- },
- "gateway_conf": {
- "gateway_ID": "<WILL-BE-AUTO-REPLACED-WITH-LORA-EUI>",
- "server_address": "52.3.215.147",
- "serv_port_up": 20000,
- "serv_port_down": 20000,
- "forward_crc_disabled": false,
- "forward_crc_error": true,
- "forward_crc_valid": true,
- "keepalive_interval": 10,
- "push_timeout_ms": 120,
- "stat_interval": 20,
- "synch_word": 52,
- "autoquit_threshold": 60
- }
-}
diff --git a/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0~ b/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0~
deleted file mode 100644
index 56d447c..0000000
--- a/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.EU868.basic.clksrc0~
+++ /dev/null
@@ -1,190 +0,0 @@
-{
- "SX1301_conf": {
- "antenna_gain": 0,
- "chan_FSK": {
- "bandwidth": 125000,
- "datarate": 50000,
- "enable": true,
- "if": 300000,
- "radio": 1
- },
- "chan_Lora_std": {
- "bandwidth": 250000,
- "enable": true,
- "if": -200000,
- "radio": 1,
- "spread_factor": 7
- },
- "chan_multiSF_0": {
- "enable": true,
- "if": -400000,
- "radio": 1
- },
- "chan_multiSF_1": {
- "enable": true,
- "if": -200000,
- "radio": 1
- },
- "chan_multiSF_2": {
- "enable": true,
- "if": 0,
- "radio": 1
- },
- "chan_multiSF_3": {
- "enable": true,
- "if": -400000,
- "radio": 0
- },
- "chan_multiSF_4": {
- "enable": true,
- "if": -200000,
- "radio": 0
- },
- "chan_multiSF_5": {
- "enable": true,
- "if": 0,
- "radio": 0
- },
- "chan_multiSF_6": {
- "enable": true,
- "if": 200000,
- "radio": 0
- },
- "chan_multiSF_7": {
- "enable": true,
- "if": 400000,
- "radio": 0
- },
- "clksrc": 0,
- "lbt_cfg": {
- "enable": false,
- "rssi_target": 160
- },
- "lorawan_public": true,
- "radio_0": {
- "enable": true,
- "freq": 867500000,
- "rssi_offset": -162,
- "tx_enable": true,
- "tx_freq_max": 870000000,
- "tx_freq_min": 863000000,
- "type": "SX1257"
- },
- "radio_1": {
- "enable": true,
- "freq": 868500000,
- "rssi_offset": -162,
- "tx_enable": false,
- "type": "SX1257"
- },
- "tx_lut_0": {
- "dig_gain": 0,
- "mix_gain": 11,
- "pa_gain": 0,
- "rf_power": -6
- },
- "tx_lut_1": {
- "dig_gain": 0,
- "mix_gain": 13,
- "pa_gain": 0,
- "rf_power": -3
- },
- "tx_lut_10": {
- "dig_gain": 0,
- "mix_gain": 15,
- "pa_gain": 2,
- "rf_power": 16
- },
- "tx_lut_11": {
- "dig_gain": 0,
- "mix_gain": 10,
- "pa_gain": 3,
- "rf_power": 20
- },
- "tx_lut_12": {
- "dig_gain": 0,
- "mix_gain": 12,
- "pa_gain": 3,
- "rf_power": 23
- },
- "tx_lut_13": {
- "dig_gain": 0,
- "mix_gain": 13,
- "pa_gain": 3,
- "rf_power": 25
- },
- "tx_lut_14": {
- "dig_gain": 0,
- "mix_gain": 15,
- "pa_gain": 3,
- "rf_power": 26
- },
- "tx_lut_15": {
- "dig_gain": 0,
- "mix_gain": 15,
- "pa_gain": 3,
- "rf_power": 27
- },
- "tx_lut_2": {
- "dig_gain": 0,
- "mix_gain": 9,
- "pa_gain": 1,
- "rf_power": 0
- },
- "tx_lut_3": {
- "dig_gain": 0,
- "mix_gain": 10,
- "pa_gain": 1,
- "rf_power": 3
- },
- "tx_lut_4": {
- "dig_gain": 0,
- "mix_gain": 12,
- "pa_gain": 1,
- "rf_power": 6
- },
- "tx_lut_5": {
- "dig_gain": 0,
- "mix_gain": 10,
- "pa_gain": 2,
- "rf_power": 10
- },
- "tx_lut_6": {
- "dig_gain": 0,
- "mix_gain": 11,
- "pa_gain": 2,
- "rf_power": 11
- },
- "tx_lut_7": {
- "dig_gain": 0,
- "mix_gain": 11,
- "pa_gain": 2,
- "rf_power": 12
- },
- "tx_lut_8": {
- "dig_gain": 2,
- "mix_gain": 12,
- "pa_gain": 2,
- "rf_power": 13
- },
- "tx_lut_9": {
- "dig_gain": 0,
- "mix_gain": 13,
- "pa_gain": 2,
- "rf_power": 14
- }
- },
- "gateway_conf": {
- "forward_crc_disabled": false,
- "forward_crc_error": true,
- "forward_crc_valid": true,
- "gateway_ID": "<WILL-BE-AUTO-REPLACED-WITH-LORA-EUI>",
- "keepalive_interval": 10,
- "push_timeout_ms": 100,
- "serv_port_down": 20000,
- "serv_port_up": 20000,
- "server_address": "52.3.215.147",
- "stat_interval": 30,
- "autoquit_threshold": 60
- }
-}
diff --git a/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.IN865.basic.clksrc0~ b/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.IN865.basic.clksrc0~
deleted file mode 100644
index 34e1c44..0000000
--- a/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.IN865.basic.clksrc0~
+++ /dev/null
@@ -1,196 +0,0 @@
-{
- "SX1301_conf": {
- "antenna_gain": 0,
- "chan_FSK": {
- "bandwidth": 125000,
- "datarate": 50000,
- "enable": true,
- "freq_deviation": 25000,
- "if": 300000,
- "radio": 1
- },
- "chan_Lora_std": {
- "bandwidth": 250000,
- "enable": true,
- "if": 0,
- "radio": 0,
- "spread_factor": 7
- },
- "chan_multiSF_": {
- "radio": null
- },
- "chan_multiSF_0": {
- "enable": true,
- "if": -137500,
- "radio": 0
- },
- "chan_multiSF_1": {
- "enable": true,
- "if": 202500,
- "radio": 0
- },
- "chan_multiSF_2": {
- "enable": true,
- "if": 32500,
- "radio": 0
- },
- "chan_multiSF_3": {
- "enable": true,
- "if": -400000,
- "radio": 1
- },
- "chan_multiSF_4": {
- "enable": true,
- "if": -200000,
- "radio": 1
- },
- "chan_multiSF_5": {
- "enable": true,
- "if": 0,
- "radio": 1
- },
- "chan_multiSF_6": {
- "enable": true,
- "if": 200000,
- "radio": 1
- },
- "chan_multiSF_7": {
- "enable": true,
- "if": 400000,
- "radio": 1
- },
- "clksrc": 0,
- "lbt_cfg": {
- "enable": false,
- "rssi_target": 160
- },
- "lorawan_public": true,
- "radio_0": {
- "enable": true,
- "freq": 865200000,
- "rssi_offset": -162,
- "tx_enable": true,
- "tx_freq_max": 867000000,
- "tx_freq_min": 865000000,
- "tx_notch_freq": 129000,
- "type": "SX1257"
- },
- "radio_1": {
- "enable": true,
- "freq": 866385000,
- "rssi_offset": -162,
- "tx_enable": false,
- "type": "SX1257"
- },
- "tx_lut_0": {
- "dig_gain": 0,
- "mix_gain": 11,
- "pa_gain": 0,
- "rf_power": -6
- },
- "tx_lut_1": {
- "dig_gain": 0,
- "mix_gain": 13,
- "pa_gain": 0,
- "rf_power": -3
- },
- "tx_lut_10": {
- "dig_gain": 0,
- "mix_gain": 15,
- "pa_gain": 2,
- "rf_power": 16
- },
- "tx_lut_11": {
- "dig_gain": 0,
- "mix_gain": 10,
- "pa_gain": 3,
- "rf_power": 20
- },
- "tx_lut_12": {
- "dig_gain": 0,
- "mix_gain": 12,
- "pa_gain": 3,
- "rf_power": 23
- },
- "tx_lut_13": {
- "dig_gain": 0,
- "mix_gain": 13,
- "pa_gain": 3,
- "rf_power": 25
- },
- "tx_lut_14": {
- "dig_gain": 0,
- "mix_gain": 15,
- "pa_gain": 3,
- "rf_power": 26
- },
- "tx_lut_15": {
- "dig_gain": 0,
- "mix_gain": 15,
- "pa_gain": 3,
- "rf_power": 27
- },
- "tx_lut_2": {
- "dig_gain": 0,
- "mix_gain": 9,
- "pa_gain": 1,
- "rf_power": 0
- },
- "tx_lut_3": {
- "dig_gain": 0,
- "mix_gain": 10,
- "pa_gain": 1,
- "rf_power": 3
- },
- "tx_lut_4": {
- "dig_gain": 0,
- "mix_gain": 12,
- "pa_gain": 1,
- "rf_power": 6
- },
- "tx_lut_5": {
- "dig_gain": 0,
- "mix_gain": 10,
- "pa_gain": 2,
- "rf_power": 10
- },
- "tx_lut_6": {
- "dig_gain": 0,
- "mix_gain": 11,
- "pa_gain": 2,
- "rf_power": 11
- },
- "tx_lut_7": {
- "dig_gain": 0,
- "mix_gain": 11,
- "pa_gain": 2,
- "rf_power": 12
- },
- "tx_lut_8": {
- "dig_gain": 2,
- "mix_gain": 12,
- "pa_gain": 2,
- "rf_power": 13
- },
- "tx_lut_9": {
- "dig_gain": 0,
- "mix_gain": 13,
- "pa_gain": 2,
- "rf_power": 14
- }
- },
- "gateway_conf": {
- "gateway_ID": "<WILL-BE-AUTO-REPLACED-WITH-LORA-EUI>",
- "server_address": "52.3.215.147",
- "serv_port_up": 20000,
- "serv_port_down": 20000,
- "forward_crc_disabled": false,
- "forward_crc_error": true,
- "forward_crc_valid": true,
- "keepalive_interval": 10,
- "push_timeout_ms": 120,
- "stat_interval": 20,
- "synch_word": 52,
- "autoquit_threshold": 60
- }
-}
diff --git a/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.KR920-LBT.basic.clksrc0~ b/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.KR920-LBT.basic.clksrc0~
deleted file mode 100644
index 2d8d3e8..0000000
--- a/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.KR920-LBT.basic.clksrc0~
+++ /dev/null
@@ -1,226 +0,0 @@
-{
- "SX1301_conf": {
- "antenna_gain": 0,
- "chan_FSK": {
- "bandwidth": 125000,
- "datarate": 50000,
- "enable": false,
- "if": 300000,
- "radio": 0
- },
- "chan_Lora_std": {
- "bandwidth": 250000,
- "enable": false,
- "if": -200000,
- "radio": 0,
- "spread_factor": 7
- },
- "chan_multiSF_0": {
- "enable": true,
- "if": -400000,
- "radio": 0
- },
- "chan_multiSF_1": {
- "enable": true,
- "if": -200000,
- "radio": 0
- },
- "chan_multiSF_2": {
- "enable": true,
- "if": 0,
- "radio": 0
- },
- "chan_multiSF_3": {
- "enable": true,
- "if": -400000,
- "radio": 1
- },
- "chan_multiSF_4": {
- "enable": true,
- "if": -200000,
- "radio": 1
- },
- "chan_multiSF_5": {
- "enable": true,
- "if": 0,
- "radio": 1
- },
- "chan_multiSF_6": {
- "enable": true,
- "if": 200000,
- "radio": 1
- },
- "chan_multiSF_7": {
- "enable": true,
- "if": 400000,
- "radio": 1
- },
- "clksrc": 0,
- "lbt_cfg": {
- "chan_cfg": [
- {
- "freq_hz": 922100000,
- "scan_time_us": 5000
- },
- {
- "freq_hz": 922300000,
- "scan_time_us": 5000
- },
- {
- "freq_hz": 922500000,
- "scan_time_us": 5000
- },
- {
- "freq_hz": 922700000,
- "scan_time_us": 5000
- },
- {
- "freq_hz": 922900000,
- "scan_time_us": 5000
- },
- {
- "freq_hz": 923100000,
- "scan_time_us": 5000
- },
- {
- "freq_hz": 923300000,
- "scan_time_us": 5000
- },
- {
- "freq_hz": 921900000,
- "scan_time_us": 5000
- }
- ],
- "enable": true,
- "rssi_target": -65,
- "sx127x_rssi_offset": -4
- },
- "lorawan_public": true,
- "radio_0": {
- "enable": true,
- "freq": 922500000,
- "rssi_offset": -162,
- "tx_enable": true,
- "tx_freq_max": 923300000,
- "tx_freq_min": 920900000,
- "type": "SX1257"
- },
- "radio_1": {
- "enable": true,
- "freq": 922900000,
- "rssi_offset": -162,
- "tx_enable": false,
- "type": "SX1257"
- },
- "tx_lut_0": {
- "dig_gain": 3,
- "mix_gain": 8,
- "pa_gain": 0,
- "rf_power": -6
- },
- "tx_lut_1": {
- "dig_gain": 3,
- "mix_gain": 10,
- "pa_gain": 0,
- "rf_power": -3
- },
- "tx_lut_10": {
- "dig_gain": 3,
- "mix_gain": 11,
- "pa_gain": 2,
- "rf_power": 16
- },
- "tx_lut_11": {
- "dig_gain": 3,
- "mix_gain": 10,
- "pa_gain": 3,
- "rf_power": 20
- },
- "tx_lut_12": {
- "dig_gain": 3,
- "mix_gain": 11,
- "pa_gain": 3,
- "rf_power": 23
- },
- "tx_lut_13": {
- "dig_gain": 3,
- "mix_gain": 12,
- "pa_gain": 3,
- "rf_power": 24
- },
- "tx_lut_14": {
- "dig_gain": 3,
- "mix_gain": 13,
- "pa_gain": 3,
- "rf_power": 25
- },
- "tx_lut_15": {
- "dig_gain": 3,
- "mix_gain": 15,
- "pa_gain": 3,
- "rf_power": 26
- },
- "tx_lut_2": {
- "dig_gain": 3,
- "mix_gain": 12,
- "pa_gain": 0,
- "rf_power": 0
- },
- "tx_lut_3": {
- "dig_gain": 3,
- "mix_gain": 8,
- "pa_gain": 1,
- "rf_power": 3
- },
- "tx_lut_4": {
- "dig_gain": 3,
- "mix_gain": 10,
- "pa_gain": 1,
- "rf_power": 6
- },
- "tx_lut_5": {
- "dig_gain": 3,
- "mix_gain": 12,
- "pa_gain": 1,
- "rf_power": 10
- },
- "tx_lut_6": {
- "dig_gain": 3,
- "mix_gain": 12,
- "pa_gain": 1,
- "rf_power": 11
- },
- "tx_lut_7": {
- "dig_gain": 3,
- "mix_gain": 9,
- "pa_gain": 2,
- "rf_power": 12
- },
- "tx_lut_8": {
- "dig_gain": 3,
- "mix_gain": 15,
- "pa_gain": 1,
- "rf_power": 13
- },
- "tx_lut_9": {
- "dig_gain": 3,
- "mix_gain": 10,
- "pa_gain": 2,
- "rf_power": 14
- }
- },
- "gateway_conf": {
- "gateway_ID": "<WILL-BE-AUTO-REPLACED-WITH-LORA-EUI>",
- "server_address": "52.3.215.147",
- "serv_port_up": 20000,
- "serv_port_down": 20000,
- "forward_crc_disabled": false,
- "forward_crc_error": true,
- "forward_crc_valid": true,
- "keepalive_interval": 10,
- "push_timeout_ms": 120,
- "stat_interval": 20,
- "synch_word": 52,
- "autoquit_threshold": 60
- }
-}
diff --git a/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.RU864.basic.clksrc0~ b/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.RU864.basic.clksrc0~
deleted file mode 100644
index 04d1ec9..0000000
--- a/recipes-connectivity/lora/lora-packet-forwarder/global_conf.json.3.0.0.MTAC_LORA_1_5.RU864.basic.clksrc0~
+++ /dev/null
@@ -1,191 +0,0 @@
-{
- "SX1301_conf": {
- "antenna_gain": 0,
- "chan_FSK": {
- "bandwidth": 125000,
- "datarate": 50000,
- "freq_deviation": 25000,
- "enable": true,
- "if": 0,
- "radio": 0
- },
- "chan_Lora_std": {
- "bandwidth": 250000,
- "enable": true,
- "if": -200000,
- "radio": 0,
- "spread_factor": 7
- },
- "chan_multiSF_0": {
- "enable": true,
- "if": -400000,
- "radio": 0
- },
- "chan_multiSF_1": {
- "enable": true,
- "if": -200000,
- "radio": 0
- },
- "chan_multiSF_2": {
- "enable": true,
- "if": 0,
- "radio": 0
- },
- "chan_multiSF_3": {
- "enable": true,
- "if": -400000,
- "radio": 1
- },
- "chan_multiSF_4": {
- "enable": true,
- "if": -200000,
- "radio": 1
- },
- "chan_multiSF_5": {
- "enable": true,
- "if": 0,
- "radio": 1
- },
- "chan_multiSF_6": {
- "enable": true,
- "if": 200000,
- "radio": 1
- },
- "chan_multiSF_7": {
- "enable": false,
- "if": 400000,
- "radio": 0
- },
- "clksrc": 0,
- "lbt_cfg": {
- "enable": false,
- "rssi_target": 160
- },
- "lorawan_public": true,
- "radio_0": {
- "enable": true,
- "freq": 869100000,
- "rssi_offset": -162,
- "tx_enable": true,
- "tx_freq_max": 870000000,
- "tx_freq_min": 864000000,
- "type": "SX1257"
- },
- "radio_1": {
- "enable": true,
- "freq": 868100000,
- "rssi_offset": -162,
- "tx_enable": false,
- "type": "SX1257"
- },
- "tx_lut_0": {
- "dig_gain": 0,
- "mix_gain": 11,
- "pa_gain": 0,
- "rf_power": -6
- },
- "tx_lut_1": {
- "dig_gain": 0,
- "mix_gain": 13,
- "pa_gain": 0,
- "rf_power": -3
- },
- "tx_lut_10": {
- "dig_gain": 0,
- "mix_gain": 15,
- "pa_gain": 2,
- "rf_power": 16
- },
- "tx_lut_11": {
- "dig_gain": 0,
- "mix_gain": 10,
- "pa_gain": 3,
- "rf_power": 20
- },
- "tx_lut_12": {
- "dig_gain": 0,
- "mix_gain": 12,
- "pa_gain": 3,
- "rf_power": 23
- },
- "tx_lut_13": {
- "dig_gain": 0,
- "mix_gain": 13,
- "pa_gain": 3,
- "rf_power": 25
- },
- "tx_lut_14": {
- "dig_gain": 0,
- "mix_gain": 15,
- "pa_gain": 3,
- "rf_power": 26
- },
- "tx_lut_15": {
- "dig_gain": 0,
- "mix_gain": 15,
- "pa_gain": 3,
- "rf_power": 27
- },
- "tx_lut_2": {
- "dig_gain": 0,
- "mix_gain": 9,
- "pa_gain": 1,
- "rf_power": 0
- },
- "tx_lut_3": {
- "dig_gain": 0,
- "mix_gain": 10,
- "pa_gain": 1,
- "rf_power": 3
- },
- "tx_lut_4": {
- "dig_gain": 0,
- "mix_gain": 12,
- "pa_gain": 1,
- "rf_power": 6
- },
- "tx_lut_5": {
- "dig_gain": 0,
- "mix_gain": 10,
- "pa_gain": 2,
- "rf_power": 10
- },
- "tx_lut_6": {
- "dig_gain": 0,
- "mix_gain": 11,
- "pa_gain": 2,
- "rf_power": 11
- },
- "tx_lut_7": {
- "dig_gain": 0,
- "mix_gain": 11,
- "pa_gain": 2,
- "rf_power": 12
- },
- "tx_lut_8": {
- "dig_gain": 2,
- "mix_gain": 12,
- "pa_gain": 2,
- "rf_power": 13
- },
- "tx_lut_9": {
- "dig_gain": 0,
- "mix_gain": 13,
- "pa_gain": 2,
- "rf_power": 14
- }
- },
- "gateway_conf": {
- "forward_crc_disabled": false,
- "forward_crc_error": true,
- "forward_crc_valid": true,
- "gateway_ID": "<WILL-BE-AUTO-REPLACED-WITH-LORA-EUI>",
- "keepalive_interval": 10,
- "push_timeout_ms": 100,
- "serv_port_down": 20000,
- "serv_port_up": 20000,
- "server_address": "52.3.215.147",
- "stat_interval": 30,
- "autoquit_threshold": 60
- }
-}
diff --git a/recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb b/recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb
index 282d09e..bcbe3f4 100644
--- a/recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb
+++ b/recipes-connectivity/lora/lora-packet-forwarder_4.0.1.bb
@@ -5,13 +5,13 @@ SECTION = "console/utils"
# Semtech license is a modified BSD-style license
LICENSE = "Proprietary"
LIC_FILES_CHKSUM = "file://LICENSE;md5=22af7693d7b76ef0fc76161c4be76c45"
-DEPENDS = "lora-gateway logrotate lora-logging"
+DEPENDS = "lora-gateway logrotate lora-logging gpsd"
RDEPENDS_${PN} += "bash"
-PR = "r16"
+PR = "r17"
-SRCREV = "v${PV}"
+SRCREV = "a32deb8ba7ce6987a7964958c079f3dc078fa0c8"
-SRC_URI = "git://github.com/Lora-net/packet_forwarder.git;protocol=git \
+SRC_URI = "git://git@gitlab.multitech.net/lora_enterprise/packet_forwarder_mtac_full.git;protocol=ssh;branch=master \
file://README.md \
file://lora-packet-forwarder.init \
file://lora-packet-forwarder.default \
@@ -35,10 +35,6 @@ SRC_URI = "git://github.com/Lora-net/packet_forwarder.git;protocol=git \
file://global_conf.json.3.1.0.MTCAP-LORA-1-5.KR920-LBT.basic \
file://global_conf.json.3.1.0.MTCAP-LORA-1-5.RU864.basic \
file://local_conf.json \
- file://lora-packet-forwarder-add-spi-dev-path.patch \
- file://lora-packet-forwarder-remove-jit-power-check.patch \
- file://lora-packet-forwarder-gpsd.patch \
- file://lora-packet-forwarder-beacon-rfu-fix.patch \
"
@@ -100,6 +96,7 @@ do_install_append_mtcap() {
install -m 755 ${WORKDIR}/global_conf.json.3.1.0.MTCAP-LORA-1-5.IN865.basic ${D}${LORA_DIR}/global_conf.json.MTCAP_LORA_1_5.IN865
}
+
FILES_${PN} += "${LORA_DIR}"
FILES_${PN}-dbg += "${LORA_DIR}/.debug ${LORA_DIR}/forwarder-utils/.debug"