summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarsh Sharma <harsh.sharma@multitech.com>2022-04-08 10:03:10 -0500
committerHarsh Sharma <harsh.sharma@multitech.com>2022-04-08 10:03:10 -0500
commit6d4402d83d6586078b53fabc2f958350b1c6e05c (patch)
treed29d9c654322c41eb87947c8ae8a1a41674ef972
parenta8e554fe313b4cd5e349987c609a6419e29b65a2 (diff)
downloadmeta-mlinux-6d4402d83d6586078b53fabc2f958350b1c6e05c.tar.gz
meta-mlinux-6d4402d83d6586078b53fabc2f958350b1c6e05c.tar.bz2
meta-mlinux-6d4402d83d6586078b53fabc2f958350b1c6e05c.zip
Updated lora 1303 recipe
-rw-r--r--recipes-connectivity/lora/lora-gateway-sx1303_2.0.17.bb (renamed from recipes-connectivity/lora/lora-gateway-sx1303_2.0.12.bb)44
1 files changed, 30 insertions, 14 deletions
diff --git a/recipes-connectivity/lora/lora-gateway-sx1303_2.0.12.bb b/recipes-connectivity/lora/lora-gateway-sx1303_2.0.17.bb
index f6c5fac..1eade0b 100644
--- a/recipes-connectivity/lora/lora-gateway-sx1303_2.0.12.bb
+++ b/recipes-connectivity/lora/lora-gateway-sx1303_2.0.17.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "LoRa Packet Forwarder"
-HOMEPAGE = "https://github.com/Lora-net/sx1302_hal"
+HOMEPAGE = "https://github.com/MultiTechSystems/sx1302_hal"
PRIORITY = "optional"
SECTION = "console/utils"
# Semtech license is a modified BSD-style license
@@ -7,18 +7,22 @@ LICENSE = "Proprietary"
LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=d2119120bd616e725f4580070bd9ee19"
DEPENDS = "logrotate"
RDEPENDS_${PN} += "bash"
-PR = "r0"
-SRCREV = "100104ee350a0e469b348ac383486d311caaf5e5"
-#SRCREV = "V${PV}"
+PR = "r6"
+
+#SRCREV = "06531662f3ef73a0e9878ed5313451d8a6cafbc5"
+SRCREV = "V${PV}"
SRC_URI = "git://github.com/MultiTechSystems/sx1302_hal.git;protocol=https;branch=master \
+ file://reset_lgw.sh \
file://global_conf.json.MTAC_003_0_0.EU868 \
file://global_conf.json.MTAC_003_0_0.US915 \
file://global_conf.json.MTCAP3.EU868 \
file://global_conf.json.MTCAP3.US915 \
"
+SRC_URI[sha256sum] = "48ef8bc6d6496f2c97495bca8891413ca08fea03c9099495d212110dffad8027"
+
S = "${WORKDIR}/git"
B = "${S}"
@@ -26,7 +30,7 @@ B = "${S}"
LORA_DIR = "/opt/lora"
-CFLAGS += " -I${S}/packet_forwarder/inc -I${S}/libloragw/inc -I${S}/libtools/inc -I${S}/inc -I. -std=gnu11"
+CFLAGS += "-DNODEBUG -I${S}/packet_forwarder/inc -I${S}/libloragw/inc -I${S}/libtools/inc -I${S}/inc -I. -std=gnu11"
do_compile() {
oe_runmake packet_forwarder LDFLAGS=${LDFLAGS}
@@ -38,8 +42,17 @@ do_compile() {
do_install() {
install -d ${D}${LORA_DIR}
+ install -d ${D}${libdir}/lora
+ install -d ${D}${libdir}/lora/lgw-sx1303/lgw
+ install -d ${D}${includedir}/lora/lgw-sx1303/lgw
+
+ install -m 0644 libloragw/libloragw.a ${D}${libdir}/lora/lgw-sx1303/lgw/
+ install -m 0644 libloragw/library.cfg ${D}${libdir}/lora/lgw-sx1303/lgw/
+ install -m 0644 libloragw/inc/* ${D}${includedir}/lora/lgw-sx1303/lgw/
+
install -d ${D}${LORA_DIR}/forwarder-utils-sx1303
install -d ${D}${LORA_DIR}/gateway-utils-sx1303
+ install -m 755 ${WORKDIR}/reset_lgw.sh ${D}${LORA_DIR}/
install -m 755 packet_forwarder/lora_pkt_fwd ${D}${LORA_DIR}/lora_pkt_fwd_sx1303
install -m 755 libloragw/test_loragw* ${D}${LORA_DIR}/gateway-utils-sx1303/
install -m 755 util_boot/boot ${D}${LORA_DIR}/forwarder-utils-sx1303/util_boot
@@ -49,23 +62,27 @@ do_install() {
}
do_install_append_mtcdt() {
- install -m 644 ${WORKDIR}/global_conf.json.MTAC_003_0_0.EU868 ${D}${LORA_DIR}/global_conf.json.MTAC_003_0_0.EU868
- install -m 644 ${WORKDIR}/global_conf.json.MTAC_003_0_0.US915 ${D}${LORA_DIR}/global_conf.json.MTAC_003_0_0.US915
+ install -m 755 ${WORKDIR}/global_conf.json.MTAC_003_0_0.EU868 ${D}${LORA_DIR}/
+ install -m 755 ${WORKDIR}/global_conf.json.MTAC_003_0_0.US915 ${D}${LORA_DIR}/
}
do_install_append_mtcap() {
- install -m 644 ${WORKDIR}/global_conf.json.MTCAP3.EU868 ${D}${LORA_DIR}/global_conf.json.MTCAP3.EU868
- install -m 644 ${WORKDIR}/global_conf.json.MTCAP3.US915 ${D}${LORA_DIR}/global_conf.json.MTCAP3.US915
+}
+
+
+do_install_append_mtcap3() {
+ install -m 755 ${WORKDIR}/global_conf.json.MTCAP3.EU868 ${D}${LORA_DIR}/
+ install -m 755 ${WORKDIR}/global_conf.json.MTCAP3.US915 ${D}${LORA_DIR}/
}
do_install_append_mtcdt3() {
- install -m 644 ${WORKDIR}/global_conf.json.MTAC_003_0_0.EU868 ${D}${LORA_DIR}/global_conf.json.MTAC_003_0_0.EU868
- install -m 644 ${WORKDIR}/global_conf.json.MTAC_003_0_0.US915 ${D}${LORA_DIR}/global_conf.json.MTAC_003_0_0.US915
+ install -m 755 ${WORKDIR}/global_conf.json.MTAC_003_0_0.EU868 ${D}${LORA_DIR}/
+ install -m 755 ${WORKDIR}/global_conf.json.MTAC_003_0_0.US915 ${D}${LORA_DIR}/
}
do_install_append_mtcdt3hs() {
- install -m 644 ${WORKDIR}/global_conf.json.MTAC_003_0_0.EU868 ${D}${LORA_DIR}/global_conf.json.MTAC_003_0_0.EU868
- install -m 644 ${WORKDIR}/global_conf.json.MTAC_003_0_0.US915 ${D}${LORA_DIR}/global_conf.json.MTAC_003_0_0.US915
+ install -m 755 ${WORKDIR}/global_conf.json.MTAC_003_0_0.EU868 ${D}${LORA_DIR}/
+ install -m 755 ${WORKDIR}/global_conf.json.MTAC_003_0_0.US915 ${D}${LORA_DIR}/
}
@@ -74,5 +91,4 @@ FILES_${PN} += "${LORA_DIR}"
# disable this on purpose for dev purposes
do_rm_work() {
echo "skipping"
-
}