summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2023-03-22 17:11:04 -0500
committerJohn Klug <john.klug@multitech.com>2023-03-22 17:11:04 -0500
commit5886d7b6c309f6986333cbf0c8549e1ff18013fa (patch)
tree5f0ed944c840276353af25fb51b15380d28ce8fa
parenta9cb24008ee45e7ac1a3f5079b351da103f7efa3 (diff)
downloadmeta-mlinux-5886d7b6c309f6986333cbf0c8549e1ff18013fa.tar.gz
meta-mlinux-5886d7b6c309f6986333cbf0c8549e1ff18013fa.tar.bz2
meta-mlinux-5886d7b6c309f6986333cbf0c8549e1ff18013fa.zip
Add a recipe for package coreutils-date
-rw-r--r--recipes-core/coreutils/coreutils_%.bbappend16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-core/coreutils/coreutils_%.bbappend b/recipes-core/coreutils/coreutils_%.bbappend
new file mode 100644
index 0000000..aa2132e
--- /dev/null
+++ b/recipes-core/coreutils/coreutils_%.bbappend
@@ -0,0 +1,16 @@
+PACKAGES =+ "${PN}-date"
+
+FILES_${PN}-date = "/bin/date"
+
+
+python do_package_append() {
+ pkgdest = d.getVar("PKGDEST",True)
+ pn = d.getVar("PN",True)
+ base_bindir = d.getVar("base_bindir",True)
+ fromf = pkgdest + "/" + pn + "/" + base_bindir + "/date.coreutils"
+ todir = pkgdest + "/" + pn + "-date/" + base_bindir
+ tof = todir + "/date"
+ os.mkdir(todir,mode=0o755)
+ os.rename(fromf,tof)
+ # mv ${PKGDEST}/${PN}/${base_bindir}/date.coreutils ${PKGDEST}/${PN}-date/${base_bindir}/date
+}