summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarsh Sharma <harsh.sharma@multitech.com>2023-04-26 14:06:58 -0500
committerHarsh Sharma <harsh.sharma@multitech.com>2023-04-26 14:06:58 -0500
commit38aba82156d7242035e534c74acf9dd1eb0cfea0 (patch)
treeecdd5b2abae59220ac86fb0059b17e2e4dd9ce5b
parent117f619490406efb0532f7e0a53808994c53b06f (diff)
downloadmeta-mlinux-38aba82156d7242035e534c74acf9dd1eb0cfea0.tar.gz
meta-mlinux-38aba82156d7242035e534c74acf9dd1eb0cfea0.tar.bz2
meta-mlinux-38aba82156d7242035e534c74acf9dd1eb0cfea0.zip
Revert "Updated lora recipes to HEAD"
This reverts commit f9f17c1f34ec1bbb75bccb3ac84d358acb038d2e.
-rw-r--r--recipes-connectivity/lora/lora-basic-station-sx1303_2.0.6-11.bb (renamed from recipes-connectivity/lora/lora-basic-station-sx1303_2.0.6-16.bb)0
-rw-r--r--recipes-connectivity/lora/lora-basic-station_2.0.6-11.bb (renamed from recipes-connectivity/lora/lora-basic-station_2.0.6-16.bb)0
-rw-r--r--recipes-connectivity/lora/lora-gateway-sx1303_2.0.42.bb (renamed from recipes-connectivity/lora/lora-gateway-sx1303_2.0.43.bb)2
-rwxr-xr-xrecipes-connectivity/lora/lora-network-server/lora-network-server.init38
-rw-r--r--recipes-connectivity/lora/lora-network-server_2.6.21.bb (renamed from recipes-connectivity/lora/lora-network-server_2.6.38.bb)0
5 files changed, 19 insertions, 21 deletions
diff --git a/recipes-connectivity/lora/lora-basic-station-sx1303_2.0.6-16.bb b/recipes-connectivity/lora/lora-basic-station-sx1303_2.0.6-11.bb
index 4e48df3..4e48df3 100644
--- a/recipes-connectivity/lora/lora-basic-station-sx1303_2.0.6-16.bb
+++ b/recipes-connectivity/lora/lora-basic-station-sx1303_2.0.6-11.bb
diff --git a/recipes-connectivity/lora/lora-basic-station_2.0.6-16.bb b/recipes-connectivity/lora/lora-basic-station_2.0.6-11.bb
index 7568330..7568330 100644
--- a/recipes-connectivity/lora/lora-basic-station_2.0.6-16.bb
+++ b/recipes-connectivity/lora/lora-basic-station_2.0.6-11.bb
diff --git a/recipes-connectivity/lora/lora-gateway-sx1303_2.0.43.bb b/recipes-connectivity/lora/lora-gateway-sx1303_2.0.42.bb
index 774bf5d..68a6322 100644
--- a/recipes-connectivity/lora/lora-gateway-sx1303_2.0.43.bb
+++ b/recipes-connectivity/lora/lora-gateway-sx1303_2.0.42.bb
@@ -21,7 +21,7 @@ SRC_URI = "git://github.com/MultiTechSystems/sx1302_hal.git;protocol=https;branc
file://global_conf.json.MTCAP3.US915 \
"
-SRC_URI[sha256sum] = "9ec3e31b9f8d4c58d5523219bba6765d88bcdfe0f24a191e9722d7b693a5d2f4"
+SRC_URI[sha256sum] = "dbfebdee1292e891d32bca52a9ef78b350557383d4d86c96c198e182249aa30f"
S = "${WORKDIR}/git"
diff --git a/recipes-connectivity/lora/lora-network-server/lora-network-server.init b/recipes-connectivity/lora/lora-network-server/lora-network-server.init
index 530e9b9..8e2e729 100755
--- a/recipes-connectivity/lora/lora-network-server/lora-network-server.init
+++ b/recipes-connectivity/lora/lora-network-server/lora-network-server.init
@@ -99,6 +99,24 @@ setup_mtcdt3() {
lora_2_id=$lora_id
}
+hardware_found() {
+ if [[ "$lora_id" =~ "$lora_mtac_g_id" ]]; then
+ setup_mtcdt_2_1
+ elif [[ "$lora_id" =~ "$lora_mtac_2g4_id" ]]; then
+ setup_mtcdt_2g4
+ elif [[ "$lora_id" =~ "$lora_mtac_003_id" ]]; then
+ setup_mtcdt003
+ elif [[ "$lora_id" =~ "$lora_mtac_id" ]]; then
+ setup_mtcdt
+ elif [[ "$lora_id" =~ "$lora_mtcap3_id" ]]; then
+ setup_mtcap3
+ elif [[ "$lora_id" =~ "$lora_mtcap_id" ]]; then
+ setup_mtcap
+ else
+ return 1
+ fi
+}
+
setup_mtcdt_2g4() {
mts-io-sysfs store lora/reset 0
mts-io-sysfs store lora/boot 0
@@ -246,26 +264,6 @@ setup_mtcap() {
return 0
}
-
-hardware_found() {
- if [[ "$lora_id" =~ "$lora_mtac_g_id" ]]; then
- setup_mtcdt_2_1
- elif [[ "$lora_id" =~ "$lora_mtac_2g4_id" ]]; then
- setup_mtcdt_2g4
- elif [[ "$lora_id" =~ "$lora_mtac_003_id" ]]; then
- setup_mtcdt003
- elif [[ "$lora_id" =~ "$lora_mtac_id" ]]; then
- setup_mtcdt
- elif [[ "$lora_id" =~ "$lora_mtcap3_id" ]]; then
- setup_mtcap3
- elif [[ "$lora_id" =~ "$lora_mtcap_id" ]]; then
- setup_mtcap
- else
- return 1
- fi
-}
-
-
do_start() {
# create run directory
mkdir -p $run_dir/1
diff --git a/recipes-connectivity/lora/lora-network-server_2.6.38.bb b/recipes-connectivity/lora/lora-network-server_2.6.21.bb
index c7d043b..c7d043b 100644
--- a/recipes-connectivity/lora/lora-network-server_2.6.38.bb
+++ b/recipes-connectivity/lora/lora-network-server_2.6.21.bb