summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Dorokhin <mykyta.dorokhin@globallogic.com>2023-01-25 14:01:59 +0200
committerMykyta Dorokhin <mykyta.dorokhin@globallogic.com>2023-01-25 14:02:10 +0200
commit2552c0524cb1772bef1604b475628cd1dc481b96 (patch)
tree7d313c2d28bb2738e97f54d8daf7cb6f516fe936
parentc94c9986362ebf4084734a3963415c5d894cf3a6 (diff)
downloadmeta-mlinux-2552c0524cb1772bef1604b475628cd1dc481b96.tar.gz
meta-mlinux-2552c0524cb1772bef1604b475628cd1dc481b96.tar.bz2
meta-mlinux-2552c0524cb1772bef1604b475628cd1dc481b96.zip
Switch to cryptsetup 2.3.7
Fix mtcpmhs build
-rw-r--r--recipes-crypto/cryptsetup/cryptsetup_2.3.7.bb (renamed from recipes-crypto/cryptsetup/cryptsetup_2.4.3.bb)45
1 files changed, 16 insertions, 29 deletions
diff --git a/recipes-crypto/cryptsetup/cryptsetup_2.4.3.bb b/recipes-crypto/cryptsetup/cryptsetup_2.3.7.bb
index 4f8bbf0..d303f27 100644
--- a/recipes-crypto/cryptsetup/cryptsetup_2.4.3.bb
+++ b/recipes-crypto/cryptsetup/cryptsetup_2.3.7.bb
@@ -13,14 +13,16 @@ DEPENDS = " \
json-c \
libdevmapper \
popt \
- util-linux-libuuid \
+ util-linux \
"
-DEPENDS:append:libc-musl = " argp-standalone"
-LDFLAGS:append:libc-musl = " -largp"
+RDEPENDS_${PN} = " \
+ libdevmapper \
+"
SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/v${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}/${BP}.tar.xz"
-SRC_URI[sha256sum] = "fc0df945188172264ec5bf1d0bda08264fadc8a3f856d47eba91f31fe354b507"
+SRC_URI[md5sum] = "9c5952cebb836ee783b0b76c5380a964"
+SRC_URI[sha256sum] = "61835132a5986217af17b8943013aa3fe6d47bdc1a07386343526765e2ce27a9"
inherit autotools gettext pkgconfig
@@ -38,9 +40,8 @@ PACKAGECONFIG ??= " \
blkid \
luks-adjust-xts-keysize \
openssl \
- ssh-token \
"
-PACKAGECONFIG:append:class-target = " \
+PACKAGECONFIG_append_class-target = " \
udev \
"
@@ -69,7 +70,14 @@ PACKAGECONFIG[nss] = "--with-crypto_backend=nss,,nss"
PACKAGECONFIG[kernel] = "--with-crypto_backend=kernel"
PACKAGECONFIG[nettle] = "--with-crypto_backend=nettle,,nettle"
PACKAGECONFIG[luks2] = "--with-default-luks-format=LUKS2,--with-default-luks-format=LUKS1"
-PACKAGECONFIG[ssh-token] = "--enable-ssh-token,--disable-ssh-token,libssh"
+
+RRECOMMENDS_${PN} = "kernel-module-aes-generic \
+ kernel-module-dm-crypt \
+ kernel-module-md5 \
+ kernel-module-cbc \
+ kernel-module-sha256-generic \
+ kernel-module-xts \
+"
EXTRA_OECONF = "--enable-static"
# Building without largefile is not supported by upstream
@@ -79,27 +87,6 @@ EXTRA_OECONF += "--disable-static-cryptsetup"
# There's no recipe for libargon2 yet
EXTRA_OECONF += "--disable-libargon2"
-do_install:append() {
- # The /usr/lib/cryptsetup directory is always created, even when ssh-token
- # is disabled. In that case it is empty and causes a packaging error. Since
- # there is no reason to distribute the empty directory, the easiest solution
- # is to remove it if it is empty.
- rmdir -p --ignore-fail-on-non-empty ${D}${libdir}/${BPN}
-}
-
-FILES:${PN} += "${@bb.utils.contains('DISTRO_FEATURES','systemd','${exec_prefix}/lib/tmpfiles.d/cryptsetup.conf', '', d)}"
-
-RDEPENDS:${PN} = " \
- libdevmapper \
-"
-
-RRECOMMENDS:${PN}:class-target = " \
- kernel-module-aes-generic \
- kernel-module-dm-crypt \
- kernel-module-md5 \
- kernel-module-cbc \
- kernel-module-sha256-generic \
- kernel-module-xts \
-"
+FILES_${PN} += "${@bb.utils.contains('DISTRO_FEATURES','systemd','${exec_prefix}/lib/tmpfiles.d/cryptsetup.conf', '', d)}"
BBCLASSEXTEND = "native nativesdk"