summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2022-12-02 14:49:18 -0600
committerJohn Klug <john.klug@multitech.com>2022-12-02 14:49:18 -0600
commit1b094c0c04abe9e305c6bed846c4d520732d5ca3 (patch)
tree1af5fa94264cf5a3afab6212d3e49151f10df180
parent5e6cfb3075d4abe391ea4f8217cebfa288429e39 (diff)
downloadmeta-mlinux-1b094c0c04abe9e305c6bed846c4d520732d5ca3.tar.gz
meta-mlinux-1b094c0c04abe9e305c6bed846c4d520732d5ca3.tar.bz2
meta-mlinux-1b094c0c04abe9e305c6bed846c4d520732d5ca3.zip
Create openssh-sshd-mlinit to distinguish mPower recipe from mLinux
-rw-r--r--recipes-connectivity/openssh/openssh_8.4p1.bb13
1 files changed, 8 insertions, 5 deletions
diff --git a/recipes-connectivity/openssh/openssh_8.4p1.bb b/recipes-connectivity/openssh/openssh_8.4p1.bb
index 2fb4816..a65ab70 100644
--- a/recipes-connectivity/openssh/openssh_8.4p1.bb
+++ b/recipes-connectivity/openssh/openssh_8.4p1.bb
@@ -8,6 +8,8 @@ SECTION = "console/network"
LICENSE = "BSD & ISC & MIT"
LIC_FILES_CHKSUM = "file://LICENCE;md5=18d9e5a8b3dd1790d73502f50426d4d3"
+PR = "r1"
+
DEPENDS = "zlib openssl virtual/crypt"
DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
@@ -38,9 +40,9 @@ inherit manpages useradd update-rc.d update-alternatives systemd
USERADD_PACKAGES = "${PN}-sshd"
USERADD_PARAM_${PN}-sshd = "--system --no-create-home --home-dir /var/run/sshd --shell /bin/false --user-group sshd"
-INITSCRIPT_PACKAGES = "${PN}-sshd"
-INITSCRIPT_NAME_${PN}-sshd = "sshd"
-INITSCRIPT_PARAMS_${PN}-sshd = "defaults 9"
+INITSCRIPT_PACKAGES = "${PN}-sshd-mlinit"
+INITSCRIPT_NAME_${PN}-sshd-mlinit = "sshd"
+INITSCRIPT_PARAMS_${PN}-sshd-mlinit = "defaults 9"
SYSTEMD_PACKAGES = "${PN}-sshd"
SYSTEMD_SERVICE_${PN}-sshd = "sshd.socket"
@@ -144,10 +146,11 @@ do_install_ptest () {
ALLOW_EMPTY_${PN} = "1"
-PACKAGES =+ "${PN}-keygen ${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-sftp ${PN}-misc ${PN}-sftp-server"
+PACKAGES =+ "${PN}-sshd-mlinit ${PN}-keygen ${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-sftp ${PN}-misc ${PN}-sftp-server"
FILES_${PN}-scp = "${bindir}/scp.${BPN}"
FILES_${PN}-ssh = "${bindir}/ssh.${BPN} ${sysconfdir}/ssh/ssh_config"
-FILES_${PN}-sshd = "${sbindir}/sshd ${sysconfdir}/init.d/sshd ${systemd_unitdir}/system"
+FILES_${PN}-sshd = "${sbindir}/sshd ${systemd_unitdir}/system"
+FILES_${PN}-sshd-mlinit = "${sysconfdir}/init.d/sshd"
FILES_${PN}-sshd += "${sysconfdir}/ssh/moduli ${sysconfdir}/ssh/sshd_config ${sysconfdir}/ssh/sshd_config_readonly ${sysconfdir}/default/volatiles/99_sshd ${sysconfdir}/pam.d/sshd"
FILES_${PN}-sshd += "${libexecdir}/${BPN}/sshd_check_keys"
FILES_${PN}-sftp = "${bindir}/sftp"