summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerhii Kostiuk <serhii.o.kostiuk@globallogic.com>2022-03-26 17:31:49 +0200
committerSerhii Kostiuk <serhii.o.kostiuk@globallogic.com>2022-03-26 17:31:49 +0200
commit0233aa52d7f4abaa1bc04184d3b2b214ccd61ee4 (patch)
tree54381c97614ff5df3685214db82c9f2d5143e9c3
parentf3609e715f82130f500cbfe061f1abda8d2fb679 (diff)
parent6ef5397d050a73cc8bd2d523c768476d338b8eec (diff)
downloadmeta-mlinux-0233aa52d7f4abaa1bc04184d3b2b214ccd61ee4.tar.gz
meta-mlinux-0233aa52d7f4abaa1bc04184d3b2b214ccd61ee4.tar.bz2
meta-mlinux-0233aa52d7f4abaa1bc04184d3b2b214ccd61ee4.zip
Merge remote-tracking branch 'origin/6' into mpower-dev-nxp
-rw-r--r--classes/mlinux-mirrors.bbclass22
-rw-r--r--recipes-connectivity/c-ares/c-ares_1.10.0.bb2
-rw-r--r--recipes-connectivity/lora/lora-gateway-geolocation_5.1.0.bb2
-rw-r--r--recipes-connectivity/lora/lora-network-server_2.5.35.bb2
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder-geolocation_5.1.0.bb2
-rw-r--r--recipes-connectivity/mosquitto/mosquitto_1.6.14.bb2
-rw-r--r--recipes-connectivity/openssh/openssh_8.4p1.bb2
-rw-r--r--recipes-connectivity/openssl/openssl_1.1.1n.bb2
-rw-r--r--recipes-core/annex-client/annex-client.bb2
-rw-r--r--recipes-core/battd/battd-ml_1.0.bb2
-rw-r--r--recipes-devtools/node-red/node-red_0.15.3.bb4
-rw-r--r--recipes-extended/autossh/autossh_1.4c.bb2
-rw-r--r--recipes-support/qfirehose/qfirehose_1.2.bb2
-rw-r--r--recipes-support/uxfp/uxfp_1.7.2-0.bb2
14 files changed, 25 insertions, 25 deletions
diff --git a/classes/mlinux-mirrors.bbclass b/classes/mlinux-mirrors.bbclass
index 5a88695..d288182 100644
--- a/classes/mlinux-mirrors.bbclass
+++ b/classes/mlinux-mirrors.bbclass
@@ -1,14 +1,14 @@
MIRRORS_append () {
-cvs://.*/.* http://multitech.net/mlinux/sources/
-svn://.*/.* http://multitech.net/mlinux/sources/
-git://.*/.* http://multitech.net/mlinux/sources/
-hg://.*/.* http://multitech.net/mlinux/sources/
-bzr://.*/.* http://multitech.net/mlinux/sources/
-osc://.*/.* http://multitech.net/mlinux/sources/
-p4://.*/.* http://multitech.net/mlinux/sources/
-ftp://.*/.* http://multitech.net/mlinux/sources/
-https?$://.*/.* http://multitech.net/mlinux/sources/
-http?$://.*/.* http://multitech.net/mlinux/sources/
+cvs://.*/.* https://multitech.net/mlinux/sources/
+svn://.*/.* https://multitech.net/mlinux/sources/
+git://.*/.* https://multitech.net/mlinux/sources/
+hg://.*/.* https://multitech.net/mlinux/sources/
+bzr://.*/.* https://multitech.net/mlinux/sources/
+osc://.*/.* https://multitech.net/mlinux/sources/
+p4://.*/.* https://multitech.net/mlinux/sources/
+ftp://.*/.* https://multitech.net/mlinux/sources/
+https?$://.*/.* https://multitech.net/mlinux/sources/
+http?$://.*/.* https://multitech.net/mlinux/sources/
}
-SAVANNAH_GNU_MIRROR = "http://download-mirror.savannah.gnu.org/releases"
+SAVANNAH_GNU_MIRROR = "https://download-mirror.savannah.gnu.org/releases"
diff --git a/recipes-connectivity/c-ares/c-ares_1.10.0.bb b/recipes-connectivity/c-ares/c-ares_1.10.0.bb
index 0d1ef9d..c391b07 100644
--- a/recipes-connectivity/c-ares/c-ares_1.10.0.bb
+++ b/recipes-connectivity/c-ares/c-ares_1.10.0.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://README;beginline=17;endline=23;md5=d08205a43bc63c12cf
PR = "r0"
-SRC_URI = "http://c-ares.haxx.se/download/c-ares-${PV}.tar.gz"
+SRC_URI = "https://c-ares.haxx.se/download/c-ares-${PV}.tar.gz"
SRC_URI[md5sum] = "1196067641411a75d3cbebe074fd36d8"
SRC_URI[sha256sum] = "3d701674615d1158e56a59aaede7891f2dde3da0f46a6d3c684e0ae70f52d3db"
diff --git a/recipes-connectivity/lora/lora-gateway-geolocation_5.1.0.bb b/recipes-connectivity/lora/lora-gateway-geolocation_5.1.0.bb
index 511a8b3..e421522 100644
--- a/recipes-connectivity/lora/lora-gateway-geolocation_5.1.0.bb
+++ b/recipes-connectivity/lora/lora-gateway-geolocation_5.1.0.bb
@@ -11,7 +11,7 @@ PSR = "r4"
PR = "r6"
SRCREV = "v${PV}"
-SRC_URI = "http://multitech.net/downloads/lora-packet-forwarder-geolocation_arm926ejste_${PV}-${PSR}.tar.gz \
+SRC_URI = "https://multitech.net/downloads/lora-packet-forwarder-geolocation_arm926ejste_${PV}-${PSR}.tar.gz \
file://config.json \
file://config_64ch.json \
"
diff --git a/recipes-connectivity/lora/lora-network-server_2.5.35.bb b/recipes-connectivity/lora/lora-network-server_2.5.35.bb
index 7b1bca8..97a9852 100644
--- a/recipes-connectivity/lora/lora-network-server_2.5.35.bb
+++ b/recipes-connectivity/lora/lora-network-server_2.5.35.bb
@@ -8,7 +8,7 @@ RDEPENDS_${PN} += "lora-packet-forwarder logrotate bash lora-logging jsoncpp"
PR = "r0"
CONFFILES_${PN} += "${sysconfdir}/default/lora-network-server ${sysconfdir}/init.d/lora-network-server"
-SRC_URI = "http://multitech.net/downloads/lora-network-server_${PV}.tar.gz \
+SRC_URI = "https://multitech.net/downloads/lora-network-server_${PV}.tar.gz \
file://lora-network-server.init \
file://lora-network-server.default \
"
diff --git a/recipes-connectivity/lora/lora-packet-forwarder-geolocation_5.1.0.bb b/recipes-connectivity/lora/lora-packet-forwarder-geolocation_5.1.0.bb
index ace77f7..e6c2816 100644
--- a/recipes-connectivity/lora/lora-packet-forwarder-geolocation_5.1.0.bb
+++ b/recipes-connectivity/lora/lora-packet-forwarder-geolocation_5.1.0.bb
@@ -13,7 +13,7 @@ PR = "r7"
SRCREV = "v${PV}"
-SRC_URI = "http://multitech.net/downloads/lora-packet-forwarder-geolocation_arm926ejste_${PV}-${PSR}.tar.gz \
+SRC_URI = "https://multitech.net/downloads/lora-packet-forwarder-geolocation_arm926ejste_${PV}-${PSR}.tar.gz \
file://global_conf.json.MTAC_LORA_2_1_loc_dual_antenna_8ch_full_diversity_EU868 \
file://global_conf.json.MTAC_LORA_2_1_loc_dual_antenna_8ch_full_diversity_JP920 \
file://global_conf.json.MTAC_LORA_2_1_loc_dual_antenna_8ch_partial_diversity_EU868 \
diff --git a/recipes-connectivity/mosquitto/mosquitto_1.6.14.bb b/recipes-connectivity/mosquitto/mosquitto_1.6.14.bb
index fffe7de..9968c6d 100644
--- a/recipes-connectivity/mosquitto/mosquitto_1.6.14.bb
+++ b/recipes-connectivity/mosquitto/mosquitto_1.6.14.bb
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=62ddc846179e908dc0c8efec4a42ef20 \
"
DEPENDS = "uthash"
-SRC_URI = "http://mosquitto.org/files/source/mosquitto-${PV}.tar.gz \
+SRC_URI = "https://mosquitto.org/files/source/mosquitto-${PV}.tar.gz \
file://mosquitto.init \
file://1571.patch \
file://install-protocol.patch \
diff --git a/recipes-connectivity/openssh/openssh_8.4p1.bb b/recipes-connectivity/openssh/openssh_8.4p1.bb
index 128e2e3..2fb4816 100644
--- a/recipes-connectivity/openssh/openssh_8.4p1.bb
+++ b/recipes-connectivity/openssh/openssh_8.4p1.bb
@@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "file://LICENCE;md5=18d9e5a8b3dd1790d73502f50426d4d3"
DEPENDS = "zlib openssl virtual/crypt"
DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
-SRC_URI = "http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-${PV}.tar.gz \
+SRC_URI = "https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-${PV}.tar.gz \
file://sshd_config \
file://ssh_config \
file://init \
diff --git a/recipes-connectivity/openssl/openssl_1.1.1n.bb b/recipes-connectivity/openssl/openssl_1.1.1n.bb
index e562294..f3a2c54 100644
--- a/recipes-connectivity/openssl/openssl_1.1.1n.bb
+++ b/recipes-connectivity/openssl/openssl_1.1.1n.bb
@@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=d343e62fc9c833710bbbed25f27364c8"
DEPENDS = "hostperl-runtime-native"
-SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz \
+SRC_URI = "https://www.openssl.org/source/openssl-${PV}.tar.gz \
file://run-ptest \
file://0001-skip-test_symbol_presence.patch \
file://0001-buildinfo-strip-sysroot-and-debug-prefix-map-from-co.patch \
diff --git a/recipes-core/annex-client/annex-client.bb b/recipes-core/annex-client/annex-client.bb
index 83dd602..7864b43 100644
--- a/recipes-core/annex-client/annex-client.bb
+++ b/recipes-core/annex-client/annex-client.bb
@@ -8,7 +8,7 @@ PROVIDES = "annex-client"
# To update this, manually copy ipk from Jenkin's job to .net/downloads/
PR = "r3"
ANNEX_PR = "r1"
-SRC_URI = "http://multitech.net/downloads/annex-client-from-src_1.0-${ANNEX_PR}.0_${TUNE_PKGARCH}.ipk \
+SRC_URI = "https://multitech.net/downloads/annex-client-from-src_1.0-${ANNEX_PR}.0_${TUNE_PKGARCH}.ipk \
file://annex-client.init \
file://monitor-annexcd \
file://call_home \
diff --git a/recipes-core/battd/battd-ml_1.0.bb b/recipes-core/battd/battd-ml_1.0.bb
index efc1687..7a7b65d 100644
--- a/recipes-core/battd/battd-ml_1.0.bb
+++ b/recipes-core/battd/battd-ml_1.0.bb
@@ -11,7 +11,7 @@ INSANE_SKIP_${PN} += "build-deps already-stripped ldflags"
PR = "r2"
TAR_PR = "r1"
-SRC_URI = "http://multitech.net/downloads/${BPN}_${PV}-${TAR_PR}_${TUNE_PKGARCH}.tar.xz \
+SRC_URI = "https://multitech.net/downloads/${BPN}_${PV}-${TAR_PR}_${TUNE_PKGARCH}.tar.xz \
"
SRC_URI[md5sum] = "a99f5fdb78ed5755f7df3e6a0553dd75"
diff --git a/recipes-devtools/node-red/node-red_0.15.3.bb b/recipes-devtools/node-red/node-red_0.15.3.bb
index bacf9fd..4898ebc 100644
--- a/recipes-devtools/node-red/node-red_0.15.3.bb
+++ b/recipes-devtools/node-red/node-red_0.15.3.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Node-RED"
-HOMEPAGE = "http://nodered.org"
+HOMEPAGE = "https://nodered.org"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
DEPENDS = "nodejs nodejs-native"
@@ -20,7 +20,7 @@ do_install() {
oe_runnpm install --prefix./node_modules/node-red nodemailer
# Build patched serialport.
# Original is https://registry.npmjs.org/serialport/-/serialport-1.7.4.tgz
- oe_runnpm install --prefix ./node_modules/node-red http://multitech.net/mlinux/sources/node-red-serialport-1.7.4-mt1.tgz
+ oe_runnpm install --prefix ./node_modules/node-red https://multitech.net/mlinux/sources/node-red-serialport-1.7.4-mt1.tgz
# modules needed for loragw
oe_runnpm install --prefix ./node_modules/node-red extend dissolve node-constants
diff --git a/recipes-extended/autossh/autossh_1.4c.bb b/recipes-extended/autossh/autossh_1.4c.bb
index 8ba78f8..a8b4fbb 100644
--- a/recipes-extended/autossh/autossh_1.4c.bb
+++ b/recipes-extended/autossh/autossh_1.4c.bb
@@ -8,7 +8,7 @@ inherit autotools-brokensep
PR = "r1"
-SRC_URI = "http://www.harding.motd.ca/autossh/autossh-1.4c.tgz"
+SRC_URI = "https://www.harding.motd.ca/autossh/autossh-1.4c.tgz"
SRC_URI[md5sum] = "26520eea934f296be0783dabe7fcfd28"
SRC_URI[sha256sum] = "6fcaba6a409a46bdf832086736bb8f09d245ebce11027f41d39588a95dc7fd1d"
diff --git a/recipes-support/qfirehose/qfirehose_1.2.bb b/recipes-support/qfirehose/qfirehose_1.2.bb
index 3141636..c25fa54 100644
--- a/recipes-support/qfirehose/qfirehose_1.2.bb
+++ b/recipes-support/qfirehose/qfirehose_1.2.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2
PR = "r0"
-SRC_URI = "http://www.multitech.net/downloads/${PN}-${PACKAGE_ARCH}-${PV}-${PR}.tar.gz;name=${PACKAGE_ARCH}"
+SRC_URI = "https://www.multitech.net/downloads/${PN}-${PACKAGE_ARCH}-${PV}-${PR}.tar.gz;name=${PACKAGE_ARCH}"
SRC_URI[arm926ejste.md5sum] = "2e304e622b6581bd0f4e8133b59a5d58"
SRC_URI[arm926ejste.sha256sum] = "a835acd64c79eb7839dbb7ee1e9da0c3b4d7333d7660f45755b3a2ab89205a84"
SRC_URI[armv7vet2hf-neon.md5sum] = "51ee58b0b97945f0540b9d81c1845bc3"
diff --git a/recipes-support/uxfp/uxfp_1.7.2-0.bb b/recipes-support/uxfp/uxfp_1.7.2-0.bb
index a9d84b9..9475475 100644
--- a/recipes-support/uxfp/uxfp_1.7.2-0.bb
+++ b/recipes-support/uxfp/uxfp_1.7.2-0.bb
@@ -5,7 +5,7 @@ RDEPENDS_${PN} += "libudev libusb1"
PR = "r1"
-SRC_URI = "http://www.multitech.net/downloads/uxfp-${PACKAGE_ARCH}-${PV}-${PR}.tar.gz;name=${PACKAGE_ARCH}"
+SRC_URI = "https://www.multitech.net/downloads/uxfp-${PACKAGE_ARCH}-${PV}-${PR}.tar.gz;name=${PACKAGE_ARCH}"
SRC_URI[arm926ejste.md5sum] = "a9ab48db1a710237e7269add4e4981bd"
SRC_URI[arm926ejste.sha256sum] = "7f7ba9dee4c31480f41dcca87c4411189f3f5db169edd88ead345c2eef79f39b"
SRC_URI[armv7vet2hf-neon.md5sum] = "ed5fe90aa818b53a77e0ac6df1ac01e5"