summaryrefslogtreecommitdiff
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2016-12-07 16:23:14 -0600
committerJason Reiss <jreiss@multitech.com>2016-12-07 16:23:14 -0600
commite004071e4578fea2a813689d3c6af23d161f6d74 (patch)
tree0324861b27e567d8642b35cb17d3f2c2a5e7a2c3 /recipes-connectivity
parenta45e7e34734aaba132408f72bfa3485a963995aa (diff)
downloadmeta-mlinux-atmel-e004071e4578fea2a813689d3c6af23d161f6d74.tar.gz
meta-mlinux-atmel-e004071e4578fea2a813689d3c6af23d161f6d74.tar.bz2
meta-mlinux-atmel-e004071e4578fea2a813689d3c6af23d161f6d74.zip
lora: remove old network server recipe
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/lora/lora-network-server_1.0.16.bb49
1 files changed, 0 insertions, 49 deletions
diff --git a/recipes-connectivity/lora/lora-network-server_1.0.16.bb b/recipes-connectivity/lora/lora-network-server_1.0.16.bb
deleted file mode 100644
index 7a3d27c..0000000
--- a/recipes-connectivity/lora/lora-network-server_1.0.16.bb
+++ /dev/null
@@ -1,49 +0,0 @@
-DESCRIPTION = "MultiTech LoRa Network Server"
-PRIORITY = "optional"
-SECTION = "console/utils"
-LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=7ffae4666a986c4ccf45e99e464f8402"
-DEPENDS = "jsoncpp libmts mosquitto sqlite3"
-RDEPENDS_${PN} += "lora-packet-forwarder logrotate"
-PR = "r1"
-
-SRC_URI = "http://multitech.net/downloads/lora-network-server_${TUNE_PKGARCH}_${PV}.tar.gz \
- file://lora-network-server.init \
- file://lora-network-server.default \
- file://lora-network-server.logrotate.conf \
- "
-
-SRC_URI[md5sum] = "3169970ea9b96656847d7472a2cf1f0f"
-SRC_URI[sha256sum] = "81b3c348911464fccbb70e3ff0c60dbcf77af69c2205aec3591fc2ceff7a5c52"
-
-# binaries are already stripped, so suppress warning
-INSANE_SKIP_${PN} = "already-stripped"
-
-S = "${WORKDIR}"
-
-LORA_DIR = "/opt/lora"
-
-do_compile() {
-}
-
-inherit update-rc.d
-
-INITSCRIPT_NAME = "lora-network-server"
-INITSCRIPT_PARAMS = "defaults 80 30"
-
-do_install() {
- install -d ${D}${LORA_DIR}
- install -m 0755 lora-network-server ${D}${LORA_DIR}/
- install -m 0644 lora-network-server.conf.sample ${D}${LORA_DIR}/lora-network-server.conf.sample
-
- install -d ${D}${sysconfdir}/default
- install -m 0644 ${WORKDIR}/lora-network-server.default ${D}${sysconfdir}/default/lora-network-server
- install -d ${D}${sysconfdir}/init.d
- install -m 0755 ${WORKDIR}/lora-network-server.init ${D}${sysconfdir}/init.d/lora-network-server
- install -d ${D}${sysconfdir}/logrotate.d
- install -m 0644 ${WORKDIR}/lora-network-server.logrotate.conf ${D}${sysconfdir}/logrotate.d/lora-network-server.conf
-}
-
-CONFFILES_${PN} = "${sysconfdir}/default/lora-network-server"
-FILES_${PN} += "${LORA_DIR}"
-FILES_${PN}-dbg += "${LORA_DIR}/.debug"