summaryrefslogtreecommitdiff
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2016-12-07 15:16:23 -0600
committerJason Reiss <jreiss@multitech.com>2016-12-07 15:16:23 -0600
commita45e7e34734aaba132408f72bfa3485a963995aa (patch)
treef685404819fad77774b4ce8da81e50e0f9b43d45 /recipes-connectivity
parent71e2fa03b457a51fc54587f557cd8e8d52c25837 (diff)
downloadmeta-mlinux-atmel-a45e7e34734aaba132408f72bfa3485a963995aa.tar.gz
meta-mlinux-atmel-a45e7e34734aaba132408f72bfa3485a963995aa.tar.bz2
meta-mlinux-atmel-a45e7e34734aaba132408f72bfa3485a963995aa.zip
lora: update network server to 1.0.17
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/lora/lora-network-server_1.0.17.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-connectivity/lora/lora-network-server_1.0.17.bb b/recipes-connectivity/lora/lora-network-server_1.0.17.bb
new file mode 100644
index 0000000..83e8f31
--- /dev/null
+++ b/recipes-connectivity/lora/lora-network-server_1.0.17.bb
@@ -0,0 +1,49 @@
+DESCRIPTION = "MultiTech LoRa Network Server"
+PRIORITY = "optional"
+SECTION = "console/utils"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7ffae4666a986c4ccf45e99e464f8402"
+DEPENDS = "jsoncpp libmts mosquitto sqlite3"
+RDEPENDS_${PN} += "lora-packet-forwarder logrotate"
+PR = "r1"
+
+SRC_URI = "http://multitech.net/downloads/lora-network-server_${TUNE_PKGARCH}_${PV}.tar.gz \
+ file://lora-network-server.init \
+ file://lora-network-server.default \
+ file://lora-network-server.logrotate.conf \
+ "
+
+SRC_URI[md5sum] = "4c88bdf1f213f2e37eb12eb9efcb96b0"
+SRC_URI[sha256sum] = "84b20fa48fa70d58e147fa079a5986d498ec78ad076b99b4b3a7dcc4f6a70a8e"
+
+# binaries are already stripped, so suppress warning
+INSANE_SKIP_${PN} = "already-stripped"
+
+S = "${WORKDIR}"
+
+LORA_DIR = "/opt/lora"
+
+do_compile() {
+}
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "lora-network-server"
+INITSCRIPT_PARAMS = "defaults 80 30"
+
+do_install() {
+ install -d ${D}${LORA_DIR}
+ install -m 0755 lora-network-server ${D}${LORA_DIR}/
+ install -m 0644 lora-network-server.conf.sample ${D}${LORA_DIR}/lora-network-server.conf.sample
+
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/lora-network-server.default ${D}${sysconfdir}/default/lora-network-server
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/lora-network-server.init ${D}${sysconfdir}/init.d/lora-network-server
+ install -d ${D}${sysconfdir}/logrotate.d
+ install -m 0644 ${WORKDIR}/lora-network-server.logrotate.conf ${D}${sysconfdir}/logrotate.d/lora-network-server.conf
+}
+
+CONFFILES_${PN} = "${sysconfdir}/default/lora-network-server"
+FILES_${PN} += "${LORA_DIR}"
+FILES_${PN}-dbg += "${LORA_DIR}/.debug"