summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2023-01-30 12:44:20 -0600
committerJohn Klug <john.klug@multitech.com>2023-05-24 16:35:20 -0500
commit7d93c0eae2be4a2e3e2f5e42aba16d639f982ae1 (patch)
tree8f24bb775b01a02968631232a7c270807ef9ffd9
parented557f2f0626937d0a4967c37256cf36a1018429 (diff)
downloadmeta-mlinux-atmel-7d93c0eae2be4a2e3e2f5e42aba16d639f982ae1.tar.gz
meta-mlinux-atmel-7d93c0eae2be4a2e3e2f5e42aba16d639f982ae1.tar.bz2
meta-mlinux-atmel-7d93c0eae2be4a2e3e2f5e42aba16d639f982ae1.zip
Python2 packages are removed
-rw-r--r--recipes-core/images/mlinux-commissioning-image.bb2
-rw-r--r--recipes-core/images/mlinux-factory-image.bb32
-rw-r--r--recipes-core/images/mlinux-rs9113-factory-image.bb2
3 files changed, 18 insertions, 18 deletions
diff --git a/recipes-core/images/mlinux-commissioning-image.bb b/recipes-core/images/mlinux-commissioning-image.bb
index 199f0f3..acef975 100644
--- a/recipes-core/images/mlinux-commissioning-image.bb
+++ b/recipes-core/images/mlinux-commissioning-image.bb
@@ -2,6 +2,6 @@ require mlinux-rs9113-factory-image.bb
DESCRIPTION = "mLinux factory image with commissioning support"
# Extra stuff to install
-IMAGE_INSTALL_append = " dnsmasq bluez5-noinst-tools python-dbus commissioning commissioning-php-fpm rp-net-examples"
+IMAGE_INSTALL_append = " dnsmasq bluez5-noinst-tools python3-dbus commissioning commissioning-php-fpm rp-net-examples"
IMAGE_INSTALL_remove = "useradd"
ROOTFS_POSTPROCESS_COMMAND_remove = "mlinux_set_root_password;"
diff --git a/recipes-core/images/mlinux-factory-image.bb b/recipes-core/images/mlinux-factory-image.bb
index 3b690d7..ae2535c 100644
--- a/recipes-core/images/mlinux-factory-image.bb
+++ b/recipes-core/images/mlinux-factory-image.bb
@@ -49,22 +49,22 @@ IMAGE_INSTALL_append = " perl-module-io perl-module-fcntl"
# Python support
# Python 2 is obsolete.
PYTHON_2_FEATURES = " python \
-python-argparse \
-python-compression \
-python-dateutil \
-python-html \
-python-psutil \
-python-pyopenssl \
-python-pyserial \
-python-pyudev \
-python-pyusb \
-python-simplejson \
-python-sqlite3 \
-python-syslog \
-python-textutils \
-python-unixadmin \
-python-xml \
-python-dbus \
+python3-argparse \
+python3-compression \
+python3-dateutil \
+python3-html \
+python3-psutil \
+python3-pyopenssl \
+python3-pyserial \
+python3-pyudev \
+python3-pyusb \
+python3-simplejson \
+python3-sqlite3 \
+python3-syslog \
+python3-textutils \
+python3-unixadmin \
+python3-xml \
+python3-dbus \
"
PYTHON_3_FEATURES = " \
python3-core \
diff --git a/recipes-core/images/mlinux-rs9113-factory-image.bb b/recipes-core/images/mlinux-rs9113-factory-image.bb
index ff326b9..f7134cf 100644
--- a/recipes-core/images/mlinux-rs9113-factory-image.bb
+++ b/recipes-core/images/mlinux-rs9113-factory-image.bb
@@ -2,4 +2,4 @@ require mlinux-factory-image.bb
DESCRIPTION = "mLinux factory image with WiFi/BT related support packages"
# Extra stuff to install
-IMAGE_INSTALL_append = " dnsmasq bluez5-noinst-tools python-dbus"
+IMAGE_INSTALL_append = " dnsmasq bluez5-noinst-tools python3-dbus"