summaryrefslogtreecommitdiff
path: root/recipes-connectivity/hostapd
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/hostapd')
-rw-r--r--recipes-connectivity/hostapd/hostap-daemon-2.6/default4
-rw-r--r--recipes-connectivity/hostapd/hostap-daemon_2.6.bb1
2 files changed, 5 insertions, 0 deletions
diff --git a/recipes-connectivity/hostapd/hostap-daemon-2.6/default b/recipes-connectivity/hostapd/hostap-daemon-2.6/default
index 0923a8c..afc965d 100644
--- a/recipes-connectivity/hostapd/hostap-daemon-2.6/default
+++ b/recipes-connectivity/hostapd/hostap-daemon-2.6/default
@@ -1,2 +1,6 @@
# set to "yes" to start hostapd on boot
START_ON_BOOT="no"
+# Stuff to creat the device if needed.
+DEV=wifi1
+PREUP="[[ -d /sys/class/net/${DEV} ]] || /opt/rs9113/onebox_util rpine0 create_vap ${DEV} ap"
+POSTUP="ifup wifi1"
diff --git a/recipes-connectivity/hostapd/hostap-daemon_2.6.bb b/recipes-connectivity/hostapd/hostap-daemon_2.6.bb
index e9e0141..b0b7046 100644
--- a/recipes-connectivity/hostapd/hostap-daemon_2.6.bb
+++ b/recipes-connectivity/hostapd/hostap-daemon_2.6.bb
@@ -7,6 +7,7 @@ LIC_FILES_CHKSUM = "file://README;md5=8aa4e8c78b59b12016c4cb2d0a8db350"
DEPENDS = "libnl openssl sqlite3"
SUMMARY = "User space daemon for extended IEEE 802.11 management"
+PR = "r1"
inherit update-rc.d
INITSCRIPT_NAME = "hostapd"