summaryrefslogtreecommitdiff
path: root/recipes-connectivity/hostapd
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2018-08-28 10:05:40 -0500
committerJohn Klug <john.klug@multitech.com>2018-08-28 10:05:40 -0500
commit735bee1d2fbcef9a35083bd1bae8e64fb542087c (patch)
tree7ca8f259335294fdd57f32829d4cb3b1c1a7cc6b /recipes-connectivity/hostapd
parent7e2aa20ea7de96fb62a3b7797aace975117429f1 (diff)
downloadmeta-mlinux-735bee1d2fbcef9a35083bd1bae8e64fb542087c.tar.gz
meta-mlinux-735bee1d2fbcef9a35083bd1bae8e64fb542087c.tar.bz2
meta-mlinux-735bee1d2fbcef9a35083bd1bae8e64fb542087c.zip
Add stuff to bring up hostapd device
Diffstat (limited to 'recipes-connectivity/hostapd')
-rw-r--r--recipes-connectivity/hostapd/hostap-daemon-2.6/default4
-rw-r--r--recipes-connectivity/hostapd/hostap-daemon_2.6.bb1
2 files changed, 5 insertions, 0 deletions
diff --git a/recipes-connectivity/hostapd/hostap-daemon-2.6/default b/recipes-connectivity/hostapd/hostap-daemon-2.6/default
index 0923a8c..afc965d 100644
--- a/recipes-connectivity/hostapd/hostap-daemon-2.6/default
+++ b/recipes-connectivity/hostapd/hostap-daemon-2.6/default
@@ -1,2 +1,6 @@
# set to "yes" to start hostapd on boot
START_ON_BOOT="no"
+# Stuff to creat the device if needed.
+DEV=wifi1
+PREUP="[[ -d /sys/class/net/${DEV} ]] || /opt/rs9113/onebox_util rpine0 create_vap ${DEV} ap"
+POSTUP="ifup wifi1"
diff --git a/recipes-connectivity/hostapd/hostap-daemon_2.6.bb b/recipes-connectivity/hostapd/hostap-daemon_2.6.bb
index e9e0141..b0b7046 100644
--- a/recipes-connectivity/hostapd/hostap-daemon_2.6.bb
+++ b/recipes-connectivity/hostapd/hostap-daemon_2.6.bb
@@ -7,6 +7,7 @@ LIC_FILES_CHKSUM = "file://README;md5=8aa4e8c78b59b12016c4cb2d0a8db350"
DEPENDS = "libnl openssl sqlite3"
SUMMARY = "User space daemon for extended IEEE 802.11 management"
+PR = "r1"
inherit update-rc.d
INITSCRIPT_NAME = "hostapd"