summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJames Maki <jmaki@multitech.com>2010-04-23 12:32:53 -0500
committerJames Maki <jmaki@multitech.com>2010-04-23 12:32:53 -0500
commit5450acde53db80f453a658f59ab887212680ca34 (patch)
treec67ba88c2d9e5a4fcf84919ea607214618614bd5 /configure.in
downloadvenus-gps-5450acde53db80f453a658f59ab887212680ca34.tar.gz
venus-gps-5450acde53db80f453a658f59ab887212680ca34.tar.bz2
venus-gps-5450acde53db80f453a658f59ab887212680ca34.zip
initial commit
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..897c99a
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,19 @@
+AC_INIT([src/venus_gps.c])
+AM_INIT_AUTOMAKE([venus-gps], [0.0.2])
+AM_CONFIG_HEADER([config.h])
+
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_MAKE_SET
+
+AC_HEADER_STDC
+
+AC_CHECK_HEADERS([unistd.h getopt.h errno.h time.h termios.h sys/types.h \
+sys/stat.h fcntl.h stdarg.h asm/byteorder.h netdb.h stdint.h signal.h], [],AC_MSG_ERROR([
+required header missing]))
+
+AC_DEFINE([DEBUG], 0, [set to 1 to enable debug])
+AC_DEFINE([CONFIG_USE_SYSLOG], 0, [set to 1 to use syslog for logging])
+
+AC_OUTPUT([Makefile src/Makefile])
+